1. tulik23's Avatar
    Hi



    i have an iphone 3gs (from italy)
    with 3.1.2 7d11 version and
    mc132t
    05.11.07 modem fw

    without the ecid files !!!

    is there any way i can jailbrak it ?
    as i understod if i dont have the ecid files , i am doommmmed

    please help

    thx
    2010-04-14 02:48 PM
  2. masyh's Avatar
    I have a 3gs iphone JB and unlocked for 3.1.2, Unfortunately i was not able to save SHSH file, I did install INFINIDOCK from Cydia and the phone rebooted, i ran blackra1n several times but it cannot JB, when I ran blackra1n it shows on the screen for a while and the phone get off itself. I have tried igoogle recovery aslo but failed, Any solution please
    2010-04-14 04:30 PM
  3. mj0528's Avatar
    Did you try Redsn0w? It works well, but if Blackra1n isn't working then it may not work either. It should work though. Download redsn0w 0.92 and the 3.1.2 3gs firmware from this site or another googled site. Launch redsn0w and you follow the onscreen instructions. If you installed something from Cydia or have Cydia, then you are already JB. Sounds like you are in the Blackra1n boot cycle that a lot of people are having. Check this site as others have left their phone plugged in and continuosly rebooting for hours to come back to a JB working phone.
    2010-04-14 11:58 PM
  4. sami4021's Avatar
    Redsn0w 0.9.4b is the newest version
    2010-04-15 12:04 AM
  5. dhamien's Avatar
    No, redsn0w 0.9.2 is what should be used for a 3GS on 3.1.2 - 0.9.4 was actually specifically made for the ipt2g old bootrom.
    2010-04-16 12:52 AM
LINK TO POST COPIED TO CLIPBOARD