1. jseivers's Avatar
    I am having a terrible time finding any sources to fix the issue where people are not getting the white/red screen when applying the iReb fix. I am just like the others....put phone in DFU mode...start iReb and click my version "3g", but after waiting for a while, I get no white/red screen.

    any options that I can try ?

    Thanks in advance !!
    2010-04-20 09:07 PM
  2. Pwncess74's Avatar
    I'm having the same problem. If anyone has an answer please let me know.
    thanks.
    2010-04-24 06:36 PM
  3. Marv1993's Avatar
    I think I got it!!I had this problem to with my iPhone 3G which was running on 3.1.3 and iReb didn't give me the white screen and I couldn't restore the Custom Firmware that I made with snowbreeze!
    I tried many many things and finally this worked:

    I used iTunes 9.0.1 and Windows Vista, if you can't find some of the folders there are hidden! You have to make them visible first!
    I put my iPhone in DFU Mode (not connected to PC yet)
    Then I went to
    C:\Users\[MY USERNAME]\AppData\Roaming\Apple Computer\iTunes
    There I went into the folder Device support and I put my custom firmware in here. Then I renamed my custom firmware to x12220000_5_Recovery.ipsw
    And the other .ipsw that was in there got deleted by me!
    Then I went into the Folder iPhone Software Updated and also put my custom firmware in there and renamed it to:
    iPhone1,2_3.1.3_7E18_Restore.ipsw
    And the other Firmware that was in there got deleted by me! It had the same name!
    So then I opened up iTunes and connected my iPhone 3G which was still in DFU Mode!
    Then I pressed Shift > Restore and chose the Firmware
    iPhone1,2_3.1.3_7E18_Restore in the folder:
    C:\Users\[MY USERNAME]\AppData\Roaming\Apple Computer\iTunes\iPhone Software Update

    Then it worked! Try it for yourself!! ;)
    Last edited by Marv1993; 2010-05-08 at 10:51 PM.
    2010-05-08 10:46 PM
  4. DGrinch's Avatar
    didnt work 4 me
    2010-05-10 01:09 AM
  5. Marv1993's Avatar
    do u have the same ihpone and everything i have is the same?
    2010-05-10 04:06 PM
  6. gucaguci's Avatar
    it managed to give my 3g a white screen, then came the "2" error. oh well
    Last edited by gucaguci; 2010-05-25 at 03:12 PM.
    2010-05-25 03:08 PM
  7. Marv1993's Avatar
    I don't know if u used the same iTunes Version than I did..
    use the 9.0.3 version that i used from here:

    Old Version of iTunes Download - OldApps.com
    2010-05-25 04:14 PM
  8. TisManus's Avatar
    I think I got it!!I had this problem to with my iPhone 3G which was running on 3.1.3 and iReb didn't give me the white screen and I couldn't restore the Custom Firmware that I made with snowbreeze!
    I tried many many things and finally this worked:

    I used iTunes 9.0.1 and Windows Vista, if you can't find some of the folders there are hidden! You have to make them visible first!
    I put my iPhone in DFU Mode (not connected to PC yet)
    Then I went to
    C:Users[MY USERNAME]AppDataRoamingApple ComputeriTunes
    There I went into the folder Device support and I put my custom firmware in here. Then I renamed my custom firmware to x12220000_5_Recovery.ipsw
    And the other .ipsw that was in there got deleted by me!
    Then I went into the Folder iPhone Software Updated and also put my custom firmware in there and renamed it to:
    iPhone1,2_3.1.3_7E18_Restore.ipsw
    And the other Firmware that was in there got deleted by me! It had the same name!
    So then I opened up iTunes and connected my iPhone 3G which was still in DFU Mode!
    Then I pressed Shift > Restore and chose the Firmware
    iPhone1,2_3.1.3_7E18_Restore in the folder:
    C:Users[MY USERNAME]AppDataRoamingApple ComputeriTunesiPhone Software Update

    Then it worked! Try it for yourself!!
    I'm hoping that this works! So far I had the Sn0wbreeze logo and it shows the Apple logo with the loading bar under it!

    Edit: It's installing! Hoping that it will be JB.

    Edit 2: Jailbroken and unlocked! Thanks alot Marv1993!!
    Last edited by TisManus; 2010-06-12 at 12:50 PM.
    2010-06-12 12:42 PM
  9. Marv1993's Avatar
    I'm hoping that this works! So far I had the Sn0wbreeze logo and it shows the Apple logo with the loading bar under it!

    Edit: It's installing! Hoping that it will be JB.

    Edit 2: Jailbroken and unlocked! Thanks alot Marv1993!!
    YES! Glad it worked for you! You are very welcome!
    2010-07-04 10:56 PM
  10. katastrophic's Avatar
    I can't find the folder named iPhone Software Update. I see Device Support. I showed the hidden files/folders already.
    2012-02-25 08:22 AM
LINK TO POST COPIED TO CLIPBOARD