1. jkraze88's Avatar
    Hi there, Ive got an iphone 3g on 4.2.1, its stuck in recovery mode. Ive used tiny umbrella, it resets my phone then goes back to recovery, same with recboot. It will not restore via itunes, gives error at like 80%. I've used redsnow, sometimes redsnow will crash, sometimes redsnow will work, I will get the pineapple, things will start to install, then at 90% it will go black and return to recovery mode!! How can I get this damn thing out of recovery?! =( TIA
    2011-02-16 05:57 AM
  2. i.Annie's Avatar
    You updated the baseband to 6.15.00? If so you'll need to restore to a custom 4.2.1 fw that doesn't have the iPad baseband packaged in it to get your phone out of recovery.
    2011-02-16 05:59 AM
  3. jkraze88's Avatar
    I'm trying to fix this for a friend, I don't think they would know how to do that. They do not even know what the firmware version is, and since it's stuck in recovery mode Im kind of shooting in the dark. It has a newer itunes logo so I've tried 4.2.1 and 4.2 but neither have worked, it just resets back into recovery after redsnow almost finishes installing.

    Can I damage the phones brain if use a custome fw when the baseband is not the problem, or is it pretty clear that is my problem? TIA
    2011-02-16 06:13 AM
  4. i.Annie's Avatar
    Well, the best option for you is to restore to stock 3.1.3 and jailbreak it. Then go in and see the baseband (modem firmware) in settings>general>about

    If it doesn't have the 6.15.00 baseband, it's good to restore to the stock 4.2.1 firmware and jb.

    A custom fw will not damage the phone. I can't say if the baseband is the issue bc I don't know if it is updated to it (you'd actually have to have manually do it yourself if that's the case). It's another issue if the baseband isn't updated. But a custom 4.2.1 firmware you can find online without the baseband upgrade packaged will fix the problem either way.
    2011-02-16 06:19 AM
  5. jkraze88's Avatar
    I'de love to just restore it but It always hits an error during the process when using itunes. Im downloading the custom fw right now, thanks for the advice! Will see if it works.
    2011-02-16 06:37 AM
  6. i.Annie's Avatar
    Well the error can definitely depend on the baseband or if the device is being set properly to dfu to restore. It varies.

    Forgot to tell you, when restoring to a custom fw, you'll want to get redsn0w 0.9.6rc8 and stock 4.2.1 fw. Then set phone into Pwned DFU mode only before restoring.
    2011-02-16 06:41 AM
  7. jkraze88's Avatar
    ya I got that redsn0w version, so start redsnow,load the stock firmware, check the box for pwned DFU mode.

    Then can I use redsnow again choosing the custom fw, or do I go into itunes and choose the custom fw? Thank you!
    2011-02-16 06:48 AM
  8. i.Annie's Avatar
    No you'll want to use the custom firmware in iTunes. Good luck
    2011-02-16 06:52 AM
  9. Benniwise's Avatar
    I had same issue as you did. I just fixed mine last night.

    Click here for instructions.

    Hope this works.

    -Benniwise
    2011-02-16 01:31 PM
  10. jkraze88's Avatar
    Thank you iAnnie!! I did exactly what you said and it worked. Thought I hit another roadblock when I put my simcard in and had 1bar reception, but fixed once I used ultrasn0w. Thanks again!!!
    2011-02-17 04:52 AM
  11. i.Annie's Avatar
    Great, glad you got it fixed
    2011-02-17 06:47 AM
LINK TO POST COPIED TO CLIPBOARD