1. TanjaZ's Avatar
    My iPhone 3GS (6.4M 3S2 later model) has been running 4.2.1. with the iPad baseband 06.15.00 fine until 4 days ago. I jailbroke with redsnOw 0.9.6rc6 in December (tethered jailbreak) and have been using stock ipsw 4.2.1 whenever I've had to unlock it again (like when I run out of power). I have Windows XP (not a Mac).

    4 days ago I went onto iTunes using wifi and tried to update apps. Instead I got stuck on the emergency screen. RedsnOw can't find the ipsw I've been using all these months (probably because apple has stopped signing it.)

    I have saved SHSH blobs with tinyumbrella twice: my blobs from 4.1 before I went to iPad baseband, and from 4 days ago, when I'm running 4.2.1. 8C148a bb 06.15.00. I'm using the latest version of tinyumbrella 4.30.03.
    I've tried to restore using my 4.2.1. blobs but that doesn't work. When I restore using my 4.1 blobs my phone appears jailbroken but I can't unlock it: iTunes says "this sim card inserted in this card does not seem to be supported." It's a ChungHua card (in Taiwan)so it isn't supported.

    I can't use redsnOw 0.9.6rc8 because it can't find the ipsw.

    My questions are:
    1. Is my phone actually still jailbroken? It looks like it is right now, and just needing to be unlocked, but the 4.1 shsh blobs don't account for my 06.15.00 baseband.

    2.I was doing fine with stock ipsw (4.2.1 (3GS): iPhone2,1_4.2.1_8C148a_Restore.ipsw) but now do I have to use a custom ipsw? Is there a way I can keep using the same ipsw I was using up until 4 days ago?

    3.If I need to use custom firmware can you point me in the right direction? There's a lot offered out there and I would like a written guide of some kind telling me the basics of what custom firmware is etc. I don't have a Mac, or a friend with a Mac, so I can't use Pawnage tools myself.

    4.Do I need to jailbreak again? Using redsnOw since it's the program that brought the ipad baseband into my regular 4.2.1 firmware? Or can UltrasnOw or some other method work too?

    Thanks for any help you can give me.
    2011-03-19 02:48 AM
  2. i.Annie's Avatar
    So many questions

    I am not sure I'm understanding fully, got confused partway through but I can point you in the right direction.

    Since you said you have SHSHs for 4.2.1, get a custom 4.2.1 firmware. You can make one with sn0wbreeze from ih8sn0w.com.

    You'll want to create that cfw and then use TinyUmbrella's TSS Server. While the server is running, open iTunes and shift+restore to the custom firmware. Then you should be able to unlock with ultrasn0w from Cydia.

    If you don't have an official carrier's SIM to activate with, you will want to go into Expert mode in sn0wbreeze to select "activate" in the general submenu. If you do have a SIM to activate with, don't do that.

    Edit: forgot to say, when you restore you want to put your phone in pwned DFU mode with redsn0w first.

    So do as follows:
    1) create custom 4.2.1 fw
    2) open redsn0w 0.9.6rc8, browse to stock 4.2.1, select pwned DFU mode only
    3) follow timer to do so
    4) open TinyUmbrella, click save SHSH then click start TSS server
    5) open iTunes and hold shift and click restore
    6) select your custom 4.2.1 fw
    Last edited by i.Annie; 2011-03-19 at 03:00 AM. Reason: Automerged Doublepost
    2011-03-19 03:00 AM
  3. TanjaZ's Avatar
    Thanks for answering so fast!

    So I can use snOwbreeze even though I used redsnOw before?
    2011-03-19 03:02 AM
  4. i.Annie's Avatar
    Yes, because sn0wbreeze creates the custom firmware you need, it is allowing you to restore so any previous jb method isn't relevant.
    2011-03-19 03:05 AM
  5. TanjaZ's Avatar
    Can I save the stock 4.2.1 ipsw to my computer and get redsnOw to find it even though it keeps disappearing whenever I connect to iTunes?
    (I know this sounds like a dumb question. It's a mystery to me how iTunes can erase a file from my computer that I've been using for months!)
    2011-03-19 03:08 AM
  6. i.Annie's Avatar
    You can I just don't remember where iTunes saves it. I would just download it from the Downloads section here on MMi and save it somewhere you can find it.
    2011-03-19 03:11 AM
  7. TanjaZ's Avatar
    " open redsn0w 0.9.6rc8, browse to stock 4.2.1, select pwned DFU mode only "

    I am not able to do this. RedsnOw will not recognize stock iPhone1,2_4.2.1_8C148_Restore.ipsw
    I don't know why?

    Anyone can tell me?
    2011-03-19 04:29 AM
  8. i.Annie's Avatar
    Are you sure your redsn0w is version 0.9.6rc8?
    2011-03-19 04:31 AM
  9. TanjaZ's Avatar

    Ok, after 3 tries it works. Ah the mysterious gremlins!
    Last edited by TanjaZ; 2011-03-19 at 04:53 AM. Reason: Automerged Doublepost
    2011-03-19 04:53 AM
  10. i.Annie's Avatar
    Yeah these things are weird :/
    2011-03-19 04:56 AM
  11. TanjaZ's Avatar
    I get error 1600 from iTunes. says it can't restore...
    2011-03-19 05:36 AM
  12. life2enjoi's Avatar
    i think thats the problem is used iPad baseband 06.15.00
    2011-03-19 05:44 AM
  13. TanjaZ's Avatar
    that's why I have a custom ipsw from sn0wbreeze.

    I'll work on this again later. Now I need to leave for the day. Bye!
    2011-03-19 05:49 AM