1. Kenbot74's Avatar
    I have seen many complaints over the past few days indicating after upgrade to 4.3.1 with redsn0w, that Cydia now reports HTTP/1.1 404 Not Found for several of the default repositories. For the life of me, I don't know why this happens, but I do know how to fix it (essentially reset Cydia). Using this method, I have restored Cydia to normal working condition on both my iPhone and iPad. Some folks will say that this is a pain in the *** compared to using apps like Cyfix, but this works and Cyfix does not (for this case).

    General notes:

    1.) Do not delete any directories *ever* (just files) or Cydia will fail to open
    2.) Write down your custom repos as Cydia will restart with only the default installed
    3.) If you can't find iFile (bigboss?), you will have to use mobile terminal or ssh


    Here is the step-by-step:

    1.) Download iFile from Cydia (not app store). It is $4, but has a free trial. Well worth it if you are uncomfortable with the command line (has a very nice GUI).
    2.) Open iFile and navigate to /var/lib/apt/lists/partial/
    3.) Delete all files in the directory (leave the directory or Cydia will crash)
    4.) Navigate up one dir to /var/lib/apt/lists/
    5.) Delete all files in this directory (the only thing this directory should contain is the empty partial folder)
    6.) Navigate to /var/lib/cydia
    7.) Delete metadata.plist
    8.) Navigate to /etc/apt/sources.list.d/
    9.) Delete all files in here including cydia.list
    10.) Exit and respring
    11.) Start Cydia and rejoice at the lack of 404 errors


    Hope this helps...
    2011-04-06 09:38 PM
  2. GoldfishTX's Avatar
    This works like a charm! Error gone!
    2011-04-06 11:04 PM
  3. Goldbaas's Avatar
    You sir, deserve a medal
    2011-04-07 03:49 AM
  4. ojb's Avatar
    Hi,

    in another forum I read that to delete the metadata.plist is ok.

    I tried this and everything seems to work correctly now.

    What is the purpose of the other files? Do I have to delete them?
    Or is metadata.plist only ok?
    Or do I have then inconstent data?

    Thank you in advance.

    Greetings from Munich, Bavaria, Germany
    Oli
    2011-04-07 07:58 AM
  5. Ashengrace's Avatar
    OMFG, thank you! You are truly a life saver, i was at my wits end with that sheeeit.
    2011-04-08 06:48 AM
  6. FonKaizoku's Avatar
    Thank youuuuuuu!!!!!!!!!!!!
    2011-04-10 02:40 PM
  7. macslut's Avatar
    This worked for me too, thank you.

    BTW: in terms of which repos you need to write down to add later. These were added automatically via Cydia (at least for me):
    apt.thebigboss.org/repofiles/cydia
    apt.modmyi.com
    repo666.ultrasno0w.com
    cydia.zodttd.com/repo/cydia
    2011-04-15 10:05 PM
  8. abulara's Avatar
    My friend after doing all these steps I lost all the repos and now if I want to add any I still having the same error pls help and thx
    2011-04-18 12:01 AM
  9. OMGthatsCRaZY's Avatar
    This worked like a charm, thank you!
    2011-09-06 09:36 PM
  10. sportboy123's Avatar
    now i cant open cydia. why?
    2011-10-19 11:19 PM
  11. lini44's Avatar
    hi this complicated for me to try lol im a woman who's learning & affraid to mess my phone up, & I was wondering if you could help me plz I've installed siri but it still wont work for me thx
    2012-02-01 11:36 PM
  12. rexvillavelez's Avatar
    i still have the same error when i try ti install icleaner and other apps, i did everyting as stated here, but still nothing,,
    2012-09-14 07:00 PM
  13. theguythatneedshelp's Avatar
    In step 2, I don't have the apt option, and I was wondering if there is a way to get it or to get around it

    In step 2, I don't have the apt option, and I was wondering if there is a way to get it or to get around it
    Nevermind I figured it out, thanks so much for the help
    Last edited by theguythatneedshelp; 2013-12-12 at 10:14 PM.
    2013-12-12 09:54 PM
LINK TO POST COPIED TO CLIPBOARD