1. Cruxy's Avatar
    I cannot find a way to delete the post, but it's solved!

    I just had to activate the phone in iTunes before jailbreaking it... So if you get this problem, activate your iPhone with iTunes:
    1. Connect you iPhone to your PC/Mac
    2. Unlock it with your PIN code and dissconect it as it requires it
    3. Re-connect it and wait untill iTunes asks if you want to restore a backup or set it up as a new phone
    4. Start redsn0w and iTunes will quit
    5. Jailbreak it like normal
    6. Restore your backup


    I'm sorry for this now pointless post, but i hope it will help anyone else who gets this problem

    [SIZE="5"ORIGINAL POST:[/SIZE]

    Hello! I've just got a new iPhone 4 from Apple because my old phone had some major problems.
    When i restore it with my latest backup (or a clean restore) everything works fine.

    When i try to jailbreak it with redsn0w (i've tried 0.9.6rc15, 16 and 17 with the 4.3.3 firmware ipsw file) it seems to work fine. I get Cydia, i get custom boot logos and multi task gestures. (I've tried with different combinations, but it happens no matter what i do)

    THEN! I was gonna try to call a friend, but i just got "Call Failed" when i tried to call him, and i noticed my phone only showed one bar and no operator/service name.
    I then checked the Phone menu under Settings and saw this:


    At first i tought it maybe was my SIM card, but it worked perfectly fine in my brother's iPhone 3GS and my temporary Nokia E51.
    As i mentioned earlier, i tried to restore it multiple times with and without jailbreaking it. Without the jailbreak it works fine, but with it it just shows "Uknown" under My Number
    On my old iPhone 4 with iOS 4.3.3 it worked fine, so i don't know what the problem might be!

    Does ANYONE have any ideas that might help? I'm willing to try almost anything to get my phone working with jailbreaking.. I CAN'T LIVE WITHOUT IT!!!

    Please read the entire post before you start suggesting anyhing. That would be verry appreciated
    Thanks.
    Cruxy.
    Last edited by Cruxy; 2011-05-25 at 10:36 PM. Reason: Fixed spelling errors AND SOLVED!
    2011-05-25 10:11 PM
LINK TO POST COPIED TO CLIPBOARD