1. sLi's Avatar
    After upgrading to ios5 b4, via itunes, downloading redsn0w update etc.
    -usual procedure-

    no idea if this had any effect, but on the first attempt I turned my phone off, put it in recovery mode, ran redsn0w - which failed with an "Unexpected error" (no further explanation)

    rebooted changed usb port etc. tried again, this time waiting for it to ask me to put it in recovery mode. however redsn0w (despite it being 'off') thought it was already in recovery mode and failed again.

    after various restores setting up as new phone & restoring from back up etc. I cannot get it to jailbreak.

    the closest I can get is: expoliot with limera1n, uploading first stage, uploading second stage - it then waits for device to reboot and then fails with an "unexpected error"

    EDIT: This is one phone:
    IOS5 Beta4 JB fails-nchjw.png

    Any other suggestions/solutions would be very much appreciated!
    Last edited by sLi; 2011-07-23 at 07:38 PM. Reason: Added example picture
    2011-07-23 05:07 PM
  2. ihappy's Avatar
    Are you using the newest beta version of redsn0w??

    Dev-Team Blog - redsn0w iOS5beta

    Edit: I see that you did update it. Sorry.

    I personally haven't jailbroken beta 4 yet but it seems it would be the same procedure as jailbreaking beta 3.

    http://www.iclarified.com/entry/index.php?enid=16178
    Last edited by ihappy; 2011-07-23 at 05:17 PM.
    2011-07-23 05:09 PM
  3. sLi's Avatar
    I have successfully JB all previous versions. including starting with the phone in restore mode before running latest redsn0w.

    I think I may have done some deeper damage that restoring in itunes can't fix (along the lines of a second recovery partition present at all times [I have no clue really, but something like this?]) or a bug with the latest redsn0w release.

    I suspect its my fault however - as no one else is experiencing it
    2011-07-23 05:22 PM
  4. ihappy's Avatar
    I have successfully JB all previous versions. including starting with the phone in restore mode before running latest redsn0w.

    I think I may have done some deeper damage that restoring in itunes can't fix (along the lines of a second recovery partition present at all times [I have no clue really, but something like this?]) or a bug with the latest redsn0w release.

    I suspect its my fault however - as no one else is experiencing it
    I have only jailbroken beta 1 and didn't like it because it was way too buggy and wasn't fully functional. I have yet to jailbreak any other beta version as the firmware itself isn't entirely stable and having it jailbroken just adds to more unstability IMO.

    Sorry I can't be much more help. My advice would be to just try and start over. Usually nothing beats a good ol' restore
    2011-07-23 05:27 PM
  5. sLi's Avatar
    Does anyone else have any insite into this. currently redownloading the beta4 ispw (although I doubt this will fix anything as it successfully restored many times before in itunes, and redsn0w was able to use it) will update upon completion

    Edit:
    after re-downloading ios5 b4 & restarting my mac.
    -this time redsh0w allowed me to press the combo to put into recovery mode, however after being placed into recovery mode, I again received an unexpected error while redsn0w was waiting for device to reboot.
    Last edited by sLi; 2011-07-23 at 09:32 PM. Reason: Update
    2011-07-23 08:56 PM
  6. sLi's Avatar
    Resolved: I believe its an issue relating to OSX Lion / various combination of running/installed apps - compatibility with redsn0w.

    I jailbroke my device using a windows PC
    2011-07-25 02:19 AM
  7. ihappy's Avatar
    Glad you got it all worked out
    2011-07-26 02:59 PM
  8. everythingelse's Avatar
    After upgrading to ios5 b4, via itunes, downloading redsn0w update etc.
    -usual procedure-

    no idea if this had any effect, but on the first attempt I turned my phone off, put it in recovery mode, ran redsn0w - which failed with an "Unexpected error" (no further explanation)

    rebooted changed usb port etc. tried again, this time waiting for it to ask me to put it in recovery mode. however redsn0w (despite it being 'off') thought it was already in recovery mode and failed again.

    after various restores setting up as new phone & restoring from back up etc. I cannot get it to jailbreak.

    the closest I can get is: expoliot with limera1n, uploading first stage, uploading second stage - it then waits for device to reboot and then fails with an "unexpected error"

    EDIT: This is one phone:
    IOS5 Beta4 JB fails-nchjw.png

    Any other suggestions/solutions would be very much appreciated!
    bro im experiancing the exact same problem im on a windows computer and it says its encountered a error and needs to close everytime i try to reboot ios 5b4 in a tethered state. i cant use safari or cydia and it sucks. please somebody help me. actually im freakin desperate leave a message here if u can help. facebook.com/jeremymichael
    2011-08-01 05:57 AM
  9. sLi's Avatar
    I have not yet tryed to boot tethered on my mac - but I read elsewhere that if you reboot before running redsn0w it should successfully work.

    try this on windows.
    restart pc
    restore ios5b4
    restart pc
    (possibly may help: close ituneshelper.exe from taskmanager -> processes)
    run redsn0w (in XP sp3 compatibility mode)

    if this fails again, try using another pc in your household/a friends pc
    2011-08-01 07:19 PM
  10. everythingelse's Avatar
    thanx bro For taking the time to help. il try that I relly appreciate it.
    2011-08-02 03:33 AM
  11. sLi's Avatar
    Did that make any difference?
    2011-08-02 03:55 AM
  12. Hossinator96's Avatar
    i jailbroke on beta 4... it was wayy to buggy... i just ended up restoring, just wait for iOS 5 final, and then jailbreak. cuz then, the packages will all be updated for iOS 5!
    iPhone 4 gsm
    iPod Touch 4
    iPod Touch 2
    2011-08-06 04:31 AM
LINK TO POST COPIED TO CLIPBOARD