1. Clayton Clark's Avatar
    iPhone 3g 8gb 4.2.1 redsn0w 0.9.6b6.

    Redsn0w finishes and says the rest of the process takes place on your device.The code starts rolling on the phone, but after the part where the code shows the mac address of the iphone, it just says please wait... please wait... please wait... on and on until it reboots. Itunes wont restore the phone either, error 28. I have disassembled the phone because this error was taking place, and took the motherboard off the power supply for 2 hours in hopes to clear the cache or whatever it is called, still didn't work. I have googled this a lot and I know that this is possibly a hardware issue but thats confusing to me, as the phone seems to work well with no issues, it just wont restore... no water damage either. Picked it up for 40 bucks off craigslist, usually don't have much trouble after googling around with the other iphones iv done, but this one has me stumped. Could possibly be problem with the charging port?? Thats also what iv seen... if so I could replace it for 5 bucks off ebay, but how do you really know what the issue is?

    Thank you!!!
    Attached Thumbnails iPhone 3g Stuck on Please wait... on device after redsn0w finishes-img_20120528_225533.jpg   iPhone 3g Stuck on Please wait... on device after redsn0w finishes-img_20120528_225547.jpg   iPhone 3g Stuck on Please wait... on device after redsn0w finishes-img_20120528_225541.jpg  
    2012-05-29 06:01 AM
  2. iYeow's Avatar
    Have you tried redsn0w 0.9.6b8 to jailbreak your 4.2.1
    2012-05-29 06:25 AM
  3. Clayton Clark's Avatar
    Just downloaded it, same thing happened though. Thanks for the suggestion though! :P
    2012-05-29 06:35 AM
  4. iYeow's Avatar
    It is possible your dock connector could be faulty, replace it and see what happens.
    2012-05-29 06:40 AM
  5. Clayton Clark's Avatar
    It is possible your dock connector could be faulty, replace it and see what happens.
    I have heard that could be the issue, I'm just confused as to if it is faulty why that would alter the process since redsn0w already completed uploading everything through the connector, kinda leads me to believe that there might just be a short in the logic board, and in that case it'd probably be best just to sell for parts wish there was some type of hardware debugging/test software
    2012-05-29 06:53 AM
  6. EVO's Avatar
    I dont think its the charging port, but as mentioned most likely the logic board

    if you have twitter, you can try contacting one of the dev teams to see if they have any input, they usually respond pretty quickly
    2012-05-29 08:20 AM
  7. Clayton Clark's Avatar
    Yea, thats a good idea, ill go do that now.

    Thank you!!
    2012-05-29 08:00 PM
LINK TO POST COPIED TO CLIPBOARD