1. mariahorn's Avatar
    I got a new in box iPhone 4 that came with 6.0.1 installed on 04.12.02 baseband. I want to jailbreak but do not need to unlock. When I plugged it into tiny umbrella to save blobs it says the device is invalid and there are no blobs for it. I tried to retrieve them with redsnow with no luck either. How do I jailbreak it if tiny umbrella won't even recognize?

    One more thing to add...when I open redsnow and try to jailbreak, right after entering dfu mode I get the message "Error with SHSH blobs!"
    Last edited by mariahorn; 2013-01-26 at 12:55 AM.
    2013-01-26 12:51 AM
  2. Simon's Avatar
    Make sure you have the latest version of tiny umbrella.
    2013-01-26 12:55 AM
  3. mariahorn's Avatar
    I have latest version
    2013-01-26 01:08 AM
  4. Simon's Avatar
    2013-01-26 01:15 AM
  5. mariahorn's Avatar
    6.01.01 and when I check the log it says I am using the current version
    2013-01-26 01:18 AM
  6. Simon's Avatar
    Ya, that's latest. Very odd it's giving you that message. Have you tried the version before that one?

    Does iTunes see the phone normally?
    2013-01-26 01:21 AM
  7. mariahorn's Avatar
    Haven't tried the version before that. Have jailbroken a different iPhone 4 and iPad 2 with no problems before. iTunes recognizes phone fine
    2013-01-26 01:42 AM
  8. mariahorn's Avatar
    Any other ideas? I have tried all the steps on another computer just in case that was the problem (Windows XP and Windows 8) and still no luck. Phone works fine but can't jailbreak because it says there are no blobs and Tiny Umbrella says invalid device.
    2013-01-26 12:15 PM
  9. mariahorn's Avatar
    Still hoping someone can help me. I will pay whoever can make this happen!!!!

    After another 20 or so hours of googling, I found the iphone wiki page that lists each model, firmware, and whether or not it can be jailbroken. The iPhone 4 I got is the 8 gb model. I noticed on iPhone wiki page it only has ios 6.0 and 6.0.1 listed (though it was released prior to those coming out so I don't know why the other firmware files weren't listed like on all the other devices). It says it can not be jailbroken. I can not find any other website to verify or refute this info, but I did find some sites where people could jailbreak it on older iOS versions. So, one last plea...is there anyway I can get SHSH blobs and/or jailbreak this device?
    2013-01-28 10:00 AM
  10. Simon's Avatar
    You should be able to jailbreak it with redsnow, it will be a tethered jailbreak though. You don't need your SHSH blobs in order to jailbreak, they are only useful in regards to restoring.
    2013-01-28 02:28 PM
LINK TO POST COPIED TO CLIPBOARD