1. stevae's Avatar
    i first tried the lastest redsnow and 6.1.3. but i kept getting "usb communication problem". i tried everything, still didn't work. so now i am dl 5.1.1 to see if it will work. how do you know which version of redsnow will work with which ios? and has ANNNNNNNNNNNNNNNNNNNNNNNNNNNNNNYBODY found a fix for the dreaded, "usb communication problem"????????
    2013-04-18 05:33 PM
  2. stevae's Avatar
    Where are the experts on this forum????????? Still no answers?????????
    2013-04-19 06:41 AM
  3. King_O_Hill's Avatar
    Shhhhh, they are sleeping.

    Simon will check it in the morning bro. I'm not good with devices that old, sorry bro.

    Hang tight!

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2013-04-19 06:57 AM
  4. stevae's Avatar
    ok. thanks. sorry, i forget i'm on the other side of the world sometimes.
    2013-04-19 01:37 PM
  5. stevae's Avatar
    it seems everyone is still asleep in this place! very useful, glad i came...
    2013-04-21 04:29 PM
  6. i.Annie's Avatar
    You need SHSHs to restore to 5.1.1. Your USB connection problem is just that...evidently you have a USB connection problem. If you've never saved your SHSHs for 5.1.1, that is not an option for you to upgrade to. You'll have to upgrade to 6.1.3 or stay on 4.2.1. If you're wanting to jailbreak, if your 3GS is an old boot, the 6.1.3 jb is untethered. If it is new boot, it will be a tethered jailbreak.
    2013-04-21 07:32 PM
  7. stevae's Avatar
    my 3gs is the old br, as it had a date of 4-2008. so i figured this would be easy. yeah, riiiiiiiiiiight! i dl the ios firmware for 5.1, but it still won't work. i also dl the ios's for 6.0 and 6.1.3. but only get the usb problem in every version of redsnow i have tried. i even dl the 4.2.1 that was on it, but now it won't even allow me to put that one back. i have all versions of redsnow, is it that i am using the wrong version of redsnow with the wrong ios? i used 9.12b when trying to put back the 4.2.1.
    the only time i tried to save a backup through itunes, it gave me an error three times, and so i didn't end up doing it. so i have no backups. i am fine with it upgrading to 6.1.3, as there is now a redsnow jb for that. but itunes continues to act like it is upgrading the phone, but somewhere near the end it tells me that there is an error 1015, and can't restore it. what can i do about this?
    Last edited by stevae; 2013-04-22 at 06:01 AM.
    2013-04-22 05:56 AM
  8. Orby's Avatar
    Okay, something doesn't add up here... the 3GS was only manufactured starting in 2009. Any serial numbers that signify the device was made in 2008 (starts xx8, eleven characters in length) makes me think you've either got a device that isn't a 3GS or perhaps your device is using the new serial format (which will be twelve characters in length and the fourth character will always be a letter--that letter will tell us its manufacture date).

    Error 1015 usually comes from trying to downgrade from a higher baseband version via restore. If you're getting this error trying to restore to 6.1.3, the only thing I can think of is: do you have the iPad baseband on your iPhone? If so, then we'll need to downgrade that first (via redsn0w) or build a baseband-free IPSW via redsn0w or sn0wbreeze to restore to (then I'd recommend downgrading it).

    As for the USB communication error, if it persists, the easiest thing to try for a fix is "try a different computer and sync cable, or at least different USB port after rebooting."
    2013-04-22 06:14 AM
  9. stevae's Avatar
    by memory, when i checked, the redmond article said that the 40 week of 2009 was the cutoff. so when i checked it was the 40 week, but there was an 8 there instead of a 9. so i'm not sure what the deal is, but that is by my memory now. is there a way to check now that i am stuck in recovery mode? it is a 16gig not 8gig model, if that helps.
    update: so i just used the lastest version of redsnow to try to identify what it is, but the screen just went blank in redsnow, and nothing else. lolololololol!!! i swear i am about done with apple. i have never had any product give me this much of a problem. i clicked on extras, and then more extras, and there is a link to identify the phone. when i put it in dfu mode, then clicked next , the redsnow window changed and went completely blank, except for the back button and finish buttons at the bottom. when i clicked back, redsnow closed and disappeared.
    2013-04-22 06:27 AM
  10. Orby's Avatar
    That is correct, Apple started rolling out the new bootrom units during the week of October 4th, 2009 ("week 41;" if memory serves). Would you post the last four characters of your phone's serial number (PM me if you're more comfortable that way)? Also, your serial number is exactly eleven characters long? The serial number should be printed on your phone's SIM card tray (also it's readable in System Information on OS X in both normal and recovery mode, or the last iPhone plugged into iTunes serial number should be shown by holding down Control when clicking "About iTunes" in iTunes).

    I'd try the redsn0w process on another computer if you have one handy, I'm smelling USB problems on the machine you're using currently (or there are serious USB hardware issues on your iPhone's end)...
    2013-04-22 06:48 AM
  11. stevae's Avatar
    good tip on the itunes thing, although i had to use snippet to capture it as it moves by quickly. the last four characters are 0508. i hope that helps! at this point i will try anything. i heard it was damn near impossible to brick these things, but i need it up and running, as i am in a foreign country, and need the navigation gps to get around.
    well, my usb ports always have detected the phone when i have plugged it in to charge. and itunes has always popped up quickly. so i don't understand that.
    2013-04-22 07:57 AM
LINK TO POST COPIED TO CLIPBOARD