1. equivocal1's Avatar
    Hey there -

    I know where you are in the process. You're nearly there!


    Note: I am on Firmware 2.1. I have not upgraded to 2.2 yet...

    Here is the basic process, but the exact tools you need may not be ready yet. So... check out this process for 2.1 and you'll see where you are:


    1) Download iFuntastic for Mac, here: iFuntastic™ by bitSplit™ Enterprises - v 6.2


    (Note: Current posting says they are only up to Firmware 2.1, so you may have to wait a moment --- OR --- search for a way to edit your firmware the same way iFuntastic does.


    2) Once you have a text editor, you have to work through the iPhone's file structure till you get to the following:


    \Preferences\Library\Carriers\


    3) The main thing you need to do in this area is:

    a) Modify the carrier plist in the AT&T folder, replacing it from the carrier plist in the Unknown Carrier folder.


    4) Once you replace the existing AT&T file with the Unknown carrier plist, you reboot the phone and then add the word "proxy" in the settings/general/network/cellular data network. You leave user name and password blank.

    5) Once you have those settings in, MMode EDGE works great.


    NOW...

    Here are 2 points:

    1) Because iFuntastic does not work with Firmware 2.2, you'll have to search for another resource for modifying the carrier plist file.

    2) Good new is, if you can manage pwnage, you'll no doubtedly find a way to tap into the iPhone's file manager.


    ___

    OK ... that said, here is another reference on how to do the carrier plist swap. This example also uses iFuntastic so you'll get to improvise.


    http://www.modmyi.com/forums/t/25001...ml#post1573531


    Good luck! Hit me back when you nail it! Long live Mmode!!!
    2008-12-02 08:07 AM
  2. rat666's Avatar
    Thank you for that informative post. I've been messing around trying to find files and text editors and basically doing stuff i don't entirely understand ---
    and I've had my first disaster. My settings app has disappeared - well the icon has.

    I downloaded Poof and it sees it but the icon is not there and I don't know how to recover it.

    I also don't know if i now recover my phone entirely, do i have to go through the entire pwnage again?

    Trying not to panic, but one needs those setting. i have my data turned off so this is inconvenient. thanks for any advice
    2008-12-02 08:30 PM
  3. equivocal1's Avatar
    Hey there -

    Don't panic. Check out these forum pages where people have discussed downgrades from 2.2. I am not experiencing the same issue as you so I can't say exactly how to fix it -- but luckily, others here have been down that road.

    Check these links and see if they guide you in the right direction. You may also want to hit-up some of those guys who may know exactly what to do.

    Cheers, mate... you'll nail it! It gets easier as you go along! :-)



    http://www.modmyi.com/forums/general...2-2-2-1-a.html

    Downgrade iPhone Firmware 2.2 to 2.1



    Eq.
    2008-12-02 11:19 PM
  4. rat666's Avatar
    Eq, Thanks for the vote of confidence. Made huge progress today. But stuck at the last step.

    1) I option-restored to get my settings back (you calmed me back into practical mode). Aok there.

    2) I 'transmitted' the carriers plist from Unknown to ATT folder.
    (since i am currently in canada and am roaming with ROgers (ATT affiliate), I did the same thing with the Rogers file)

    3) I got stuck on number 4 - where to add the word 'proxy'. I see 'Rogers' under my network but no place to modify it. touching it just toggles a check mark onto it.

    I still get 'no data plan' when i try to use data. If we think this is a canada-roaming problem, i'll be back in the US later in the week, but I still worry I didn't follow the final instructions properly. I need this to work in canada.

    I didn't find a plist editor - i just moved the whole files - was this correct? i downloaded the entire XCode packege to get plist editor but it wouldn't mount, just to add to my crisis.

    meantime phone and text are working fine on 2.2 and purchased movies which stopped playing on 2.1 are all working again.

    thanks for all your patience and goodwill and assistance. Feel like I'm getting closer....

    the rat-
    2008-12-03 06:24 AM
  5. rat666's Avatar
    Help again please - i'm still struggling with this and wonder if i've royally screwed something up.

    I altered my preference.plist and my carrier.plist and replaced as instructed. But when i go on the phone to
    Settings/General/Network

    all I get is "Data Roaming" (on/off)
    "VPN" (not configured)
    "WiFi" (On/off)

    No sign of any networks. The phone is working fine and the network is listed under "Carrier"

    Still no sign of getting MMode working, however. Do I need to reconfigure again?

    thanks for any hints/help.

    Oh, wow, it's now working. I certainly can't explain what happened, but I'm in canada and i am getting full data service (being careful with my roaming charges now) - along with everything else. Thank you everyone on this forum for all the information!!

    mMode lives.
    Last edited by rat666; 2008-12-14 at 03:03 AM. Reason: Automerged Doublepost
    2008-12-14 03:03 AM
  6. endriti's Avatar
    BLUE ATT MMODE SETINGS ON 2.2

    Hello everyone.
    The old fashion way works like a charm.

    Apply preferences.plist to this directory Library/Preferences/SystemConfigurations

    Apply the Proxy.pac file still on the same folder Private/var/root

    PS: 3G works like a charm. How? I have no Clue, but you can get 3G without paying for it
    Tested it, I can download at a rate of 130Kbp/s under 3G
    Last edited by endriti; 2009-01-15 at 02:15 AM.
    2009-01-07 01:07 AM
  7. paldiel's Avatar
    This is driving me crazy, I had the thing working great on 3G! with the 2.2 version jailbroken and unlocked. I did the stupid thing today and pulled out the sim card to try a friends sim card on my phone and then EDGE stopped working when I went back to my sim card. Now every time I edit preferences.plist and save it into var/preferences/SystemConfiguration, restart my phone I still get error connection, checked my preferences.plist file and the darn file went back automatically to the old file where cingular is listed again. Help I'm going nuts over this. What else can I do?
    2009-01-22 10:57 PM
  8. phattbam's Avatar
    go to
    Settings > General > Network > Cellular Data Network > make sure APN is = proxy
    2009-01-23 01:43 AM
  9. paldiel's Avatar
    I went to Setting>General>Network all I have there is Enable 3G set to Off, Data Roaming set to Off, VPN set to Not configured and WiFi set to my wifi at home. Where is APN?

    Thanks for trying to help by the way
    2009-01-23 02:05 AM
  10. phattbam's Avatar
    hmmm. I thought the 3G menus might be similar. I'm not sure where it is.
    2009-01-23 02:16 AM
  11. paldiel's Avatar
    Strange, went to work, opened Mobile Finder, replaced preferences.plist with a copy of the edited preference.plist and now it all works! The only thing that changed from yesterday was the location and date. I don't get it but I am glad that I now have a working 3G on the MMode plan.
    2009-01-23 04:32 PM
  12. phattbam's Avatar
    good to hear. glad things got sorted out fast instead of having to restore it.
    2009-01-23 05:04 PM
  13. paldiel's Avatar
    Thanks, by the way, I even tried restoring the phone the night before. Strange that it just decided to work the next day, maybe the location did something although I am not sure.
    2009-01-23 11:15 PM
  14. rat666's Avatar
    2 new questions:

    I finally had everything working, then I went to the UK and changed Sim Cards (for my Virgin Pay-Go card, where the data didn't work at all, but i didn't get into that!)
    and when I came back, now my ATT data isn't working again. Anyone know why? I assume I have to restart the process, which i feel i lucked into - so here we go again....

    However -- question 2 - when i did have the old blue data plan working, even when it was all turned off - email push, data roaming, etc, whenever I opened my Mail Program, it still grabbed the mail - so if there was no WiFi, it was grabbing it off ATT even if i didn't want it to. Any ideas?

    Btw, does anyone use a different Email program from Mail - which i find is really limited in the amount i can control it?

    thanks.

    yes, i realize I asked 3 questions in the previous email = sorry.

    I just replaced the preference.plist with the edited one and it's all working again. Thanks to everyone in this forum!
    Last edited by rat666; 2009-01-27 at 08:59 PM. Reason: Automerged Doublepost
    2009-01-27 08:59 PM
  15. nighserenity's Avatar
    Can anyone shed some light on my problem: I am on old ATT blue service, from what I am reading it seems like I should be able to use the old blue sim card in an unlocked 1st generation iphone. Is this correct?

    I don't have mmode or any data plan, and I am not looking to be able to have it. If I need any sort of internet I can just connect to a wifi network. I just want to be able to use the iphone as a phone. I posted details of what I have done here: http://www.modmyi.com/forums/ilibert...-iliberty.html

    Anyone else on ATT blue, how did you unlock your phones? This is the quote from my post that I linked to above:


    I have a similar problem but I do not think it was 2.1 firmware originally because I got it from someone who upgraded to iphone 3g as soon as it came out. And the one I got was fresh restored.

    I used iliberty+ to jailbreak and unlock, but I don't think it has unlocked it. I can do everything on the phone but use it as a phone, it't like an itouch right now.

    I have at&t, but I am on the old grandfather at&t blue sim cards. I installed 1.1.4 successfully on the iphone via itunes 7.6, and ran iliberty+ with all the original payloads checked. Like I said it seemed to go smoothly, but when I put my sim card in I don't get any signal. For a while I see the very smallest bar, but then it goes away and says "no service". It doesn't show the carrier either.

    Do I need to have the sim card in when I unlock? Could this be an issue with my old sim card? The faq of George Zhu's blog says most of the original payloads are safe to run multiple times. Can I just run iliberty+ again with only "unlock" checked?
    2009-02-16 03:39 AM
  16. DanielNTX's Avatar
    FYI... this still works on the iPhone 2g running 3.0 after switching the default AT&T carrier.plist with the unknown bundles' carrier.plist and setting it as the APN to "proxy".

    This also works on an iPhone 3G running 3.0 and unlocked via ultrasn0w. Even with an AT&T blue sim it switches to 3G service. Verified 3g speeds with the speedtest.net application.
    2009-06-23 09:27 AM
  17. amm151's Avatar
    FYI... this still works on the iPhone 2g running 3.0 after switching the default AT&T carrier.plist with the unknown bundles' carrier.plist and setting it as the APN to "proxy".

    This also works on an iPhone 3G running 3.0 and unlocked via ultrasn0w. Even with an AT&T blue sim it switches to 3G service. Verified 3g speeds with the speedtest.net application.
    There's actually a faster method using WiFi.
    On your phone head to www.unlockit.co.nz


    Choose Custom APN; APN = proxy, leave username and password blank & create profile!!!

    Takes about a minute and your done!
    2009-06-26 08:46 AM
  18. DanielNTX's Avatar
    I just got MMS working on the 2g iPhone using the following settings:



    MMSC URL: http://mmsc.mobile.attwireless.net
    MMSC Proxy: 010.250.250.100
    MMSC Port: 9201

    Other possible settings besides what I used includes:
    MMSC URL: http://mmsc.mobile.attwireless.net
    MMSC Proxy: 010.250.250.055
    MMSC Port: 8080

    MMSC URL: http://mmsc.mymmode.com
    MMSC Proxy: 010.250.250.100
    MMSC Port: 9201

    MMSC URL: http://mmsc.mymmode.com
    MMSC Proxy: 010.250.250.055
    MMSC Port: 8080
    Attached Thumbnails old at&t blue mmode settings on iphone-photo-3-.jpg  
    2009-06-30 12:01 AM
  19. Johndoe01's Avatar
    How did you get that screen?! Did you use unlockit or carrier.plist. Unlockit seems straight forward and easier for me to change the setting to use my old blue sim card and maybe that's why I don't have that setting screeen? Also, how do you get that battery meter percentage?
    2009-08-20 08:51 AM
  20. endriti's Avatar
    mMode Settings for 3.1

    Make it as simple as you can.
    Go to Settings/General/Network/Cellular Data Network

    Under CELLULAR DATA enter:

    APN: proxy
    USERNAME: leave empty
    PASSWORD: leave empty
    2009-09-26 02:17 PM
80 ... 234
LINK TO POST COPIED TO CLIPBOARD