1. istorm's Avatar
    Here is the exact status message: "iPhone USB has a self-assigned IP address and will not be able to connect to the Internet."

    I was able to tether 3G network to my Mac before, but now it wont connect to internet anymore. Both USB and Bluetooth. On the bluetooth tethering, it shows IP of 169.xx.xx.xx Subnet mask is 255.255.0.0

    Thanks in advance!

    Im on 3.0 jailbroken!
    iPhone 4 32GB. Jailbroken!
    2009-09-28 10:45 AM
  2. mull3t's Avatar
    istorm,

    Do you happen to have PDAnet installed? I do and when I checked it to see if it was causing my issues it turned out that it was. It was turned on by default and upon shutting it off, now I can tether properly.

    Just thought that might help.

    ~mull3t
    Last edited by mull3t; 2009-09-29 at 04:25 AM. Reason: Automerged Doublepost
    2009-09-29 04:23 AM
  3. istorm's Avatar
    Anyone?
    iPhone 4 32GB. Jailbroken!
    2009-09-30 04:46 PM
  4. gQstatus05's Avatar
    Follow these instructions:

    Click on Airport Prefs and Delete Airport and anything else you have listed in that box. You can just click the + sign and add airport once again. Once you do that press click on Advanced and delete any preferred networks. Click on proxies tab and make sure it's set to Manually. After wards:

    Hit Go, Utilities

    In utilities look for Keychain Access and delete your Wifi Networks by right clicking (if you have that enabled on your mac) Delete anything that looks network related as far as SSID's. Whenever you connect to a Wifi Network and you tell the Mac to store the WEP key it stores it in Keychain. After you do that attempt to connect again and if you look under network prefs you should see your IP address listed. Attempt to browse.

    Make sure you test Safari browser and Firefox browser. If one of them doesn't work let me know.
    Android user suffering from iPhone withdraw.
    2009-10-02 09:16 PM
  5. LuckyLuke71's Avatar
    this worked for me. thanks
    2009-10-23 12:15 AM
  6. gQstatus05's Avatar
    Cool man. Glad it worked. Let me know if you run into another issue.
    Android user suffering from iPhone withdraw.
    2009-10-29 08:18 PM
  7. GIRLLLLLLLLLLLLLLLLL's Avatar
    You didn't notice he thanked the person suggesting PDAnet was and is the problem?

    Lovely

    Not
    2009-10-30 05:42 AM
  8. gQstatus05's Avatar
    His issue indicates he was using the native iPhone tethering. The issue he's gotten has been an issue I've encountered in the past. He never stated he was using PDANet or had it installed. By the way why are you always in the AT&T section of the forum when you bash the carrier and you're on T-Mobile. Stay in your lane and hop off.
    Android user suffering from iPhone withdraw.
    2009-11-03 11:34 PM
  9. s8n666's Avatar
    Had this exact problem too, and was fixed with the removal of pdanet. Thanks!
    2010-01-31 06:26 AM
  10. orthorim's Avatar
    Thank you so much, I had PDANET installed and had this exact issue. I couldn't tether my phone and had a self-assigned IP address on the Mac. I turned PDANET off in the PDANET settings, and bingo, tethering worked like a charm. I then uninstalled PDANET.

    Can't believe that PDANET does something like this - if not for this forum, I don't think I'd have figured this out, I'd have re-installed the OS.
    2010-04-06 02:43 AM
LINK TO POST COPIED TO CLIPBOARD