User Tag List

  1. posrjak's Avatar
    Ok I am in need of some help. I have the new iPhone 4 and At&t service but I am on my company's Blackberry plan. Since I have no access to account I had to cut down my old sim card to get it to fit in the mini sim tray of the iPhone 4. Now when I go to phone and then to voice mail it doesn't work. I have never had visual voice mail in pervious iPhone models but now it has gotten worse.


    1 does anyone else have this issue?
    2 do you know if cutting the sim card down has anything to do with it? Everything else works great, phone and data all work just fine.
    3 Anybody now of a way active the mini sim card with At&t without going into At&t. I have tried and since it is a cooperate account I have not access, and my work doesn't support using personal devices on Company accounts. (bummer)

    I have searched (Google was not my friend) and haven't gotten any luck. I believe it has to do with the sim card but looking for some confirmation. If I call my number from my phone it goes right into voicemail...maybe I am missing a setting? When I go to the voice mail is only gives me the option of calling AT&T.

    Attached Thumbnails iPhone 4 not calling viocemail-photo.png  
    2010-06-30 07:26 PM
  2. ianbroste's Avatar
    Since you aren't on an iPhone plan you won't have the visual voicemail. On another note AT&T will sooner or later know you are on an iPhone and start charging your company for an iPhone plan.
    Have they released the jailbreak in the app store yet?
    2010-06-30 08:12 PM
  3. posrjak's Avatar
    Thanks for the info, I believe the cooperate account is the same price as the unlimited iPhone plan, so if the did switch it shouldn't be a big deal.

    I have never had visual voicemail and that never bothered me. But on older iphones with a the full sim card it would call the voicemail number.
    2010-06-30 08:23 PM
  4. ianbroste's Avatar
    In your original post you said "If I call my number from my phone it goes right into voicemail" at the end so I assumed you were still able to access your voicemail just not visual voicemail?
    Have they released the jailbreak in the app store yet?
    2010-06-30 10:08 PM
  5. posrjak's Avatar
    Sorry for the confusion, if I go into the phone app and hit the key pad and dial my own number it goes striaght to voicemail. If I hit the voicemail button it goes to the screen shot, when it use to call my voicemail.
    2010-07-01 01:03 AM
  6. KoolMan0's Avatar
    im interested in this I have a family plan set up i have had the iphone 2g, 3g, and 3gs and have not had any issues with the data plan. im on the media net and all i have to do is add a different apn so that i can get online.
    Att has sent me emails and text i even called them and told them that i "Tested my sim in a friends iphone" but they did not go any further. I have gone into the apple store and exchanged iphones that i bought on CL and had no issues.
    I dont have visual voice mail currently on the 3gs. i touch the voice mail and it it just sends me to the voicemail box. is the 4 doing this on all Voice mails?


    Try thi out
    iPhone: How To Activate/Deactivate/Enable/Disable (Visual)VoiceMail Tap! 3mr (3 means A!)
    See what happens
    Last edited by KoolMan0; 2010-07-02 at 09:40 PM. Reason: Automerged Doublepost
    2010-07-02 09:40 PM
  7. mgregor's Avatar
    I had the same screen but I cut my sim from my 3GS. I just called ATT and they said my visual voicemail somehow got disabled. They fixed it and I'm good to go. I think you have to call them to fix.
    2010-07-03 08:42 AM
  8. posrjak's Avatar
    Yes mine works now too! Thanks for the help!!!
    2010-07-03 08:48 AM
  9. KoolMan0's Avatar
    so you guys had to call att and have them activate the vvm?
    are you guys on the official iphone plan?
    2010-07-03 09:27 AM
  10. posrjak's Avatar
    No I didn't have to call, not really sure why mine started to work. I think it might have been because I called my own number on my iPhones key pad. I am not on an official iPhone plan.
    2010-07-03 10:05 AM