1. sbimos's Avatar
    We never got it to work right on the old plan, with alleged "new" SIM, but she finally decided to go in and update her plan early, and to officially tell #ATTfail she was on a 3GS, and make them give her a SIM on the spot that would work. After much yelling, she managed to get a new plan for iPhone without having to get the data plan.

    I Pwnagetooled a 4.3.1 (unactivated) for her, and she went in with it installed. #ATTfail couldn't get it to activate no matter what they tried, and they sent her home with yet another allegedly "good" SIM card.

    We Pwnagetooled a 4.3.1 (activated), and that didn't work either. We didn't try 4.3.1 legit, because we still wanted to preserve the older baseband, even if it's not unlockable. If I recall correctly:
    4.3.1 unactivated results in "No Service" in upper left corner.
    4.3.1 activated results in 1 bar, and no carrier logo.
    Neither gave potential activation message, and subsequent activation like you would expect.

    Out of frustration, we fired up TinyUmbrella, and installed 4.2.1. WTF?!?!?! 4.2.1 stock works. We Pwnagetooled a 4.2.1 (unactivated), and that works too.

    Why the heck does PT'd 4.3.1 (unactivated) NOT work, but PT'd 4.2.1 (unactivated) will?
    2011-04-12 09:56 AM
  2. GenesisDH's Avatar
    It might be a bug in the version of PwnageTool you're using.

    If you're getting 4.2.1 to work and you're already on the 'not unlockable' baseband, might be worth updating to stock 4.3.1 and jailbreaking with redsn0w post-update. That's if you're wanting the latest iOS. Not saying that you do...

    There's no guarantee an unlock will be available for any 4.1+ 3GS baseband now, as the 6.15.00 'hack' is still available for any 3GS user and the Dev Team will [eventually] look into making a baseband downgrade tool for those wanting a baseband other than 6.15.00... then adding in the IMEI unlock people are talking about in the last couple days.... using PT to keep that 4.1-related baseband has basically no purpose for you now.
    Member of the hackint0sh forums.
    HowardForums Member: Haas_Dave
    2011-04-13 03:16 AM
  3. sbimos's Avatar
    It's actually on the 4.2.1 BB. If we hadn't gotten 4.2.1 to work, i would have considered 4.3.1 stock. I was hoping someone here would have read something I missed regarding Pwnagetool & 4.3.1 no working.

    I've been waiting for that BB downgrade tool forever, before I touch the iPad BB unlock trick.

    Now that we know we can do 4.2.1 stock, and 4.2.1 Pwnagetool (unactivated), we are going to try 4.3.1 Pwnagetool (unactivated) again. Just in case we had a bad file (although I doubt it), we redownloaded the IPSW.
    2011-04-13 04:49 AM
  4. sbimos's Avatar
    I Pwnagetooled a 4.3.1 (unactivated) for her, and she went in with it installed. #ATTfail couldn't get it to activate no matter what they tried, and they sent her home with yet another allegedly "good" SIM card.

    Out of frustration, we fired up TinyUmbrella, and installed 4.2.1. WTF?!?!?! 4.2.1 stock works. We Pwnagetooled a 4.2.1 (unactivated), and that works too.

    Why the heck does PT'd 4.3.1 (unactivated) NOT work, but PT'd 4.2.1 (unactivated) will?
    It's actually on the 4.2.1 BB. (05.15.04).

    Now that we know we can do 4.2.1 stock, and 4.2.1 Pwnagetool (unactivated), we are going to try 4.3.1 Pwnagetool (unactivated) again. Just in case we had a bad file (although I doubt it), we redownloaded the IPSW.
    Okay, we redownloaded the 4.3.1 ISPW from a different source. We remade the 4.3.1 unactivated IPSW. Option-Restored, and somehow it works this time! I have no idea why it wouldn't before.
    2011-04-14 07:04 AM
24 12
LINK TO POST COPIED TO CLIPBOARD