1. nycmilkshake's Avatar
    I have a carrier-unlocked iPhone 3G running iOS 4.2.1 and firmware 05.15.04 which I successfully set up to use with a GoPhone SIM in January (using the unlockit.co.nz tool).

    On Saturday my data stopped working. It still shows 3G or E but when trying to send/retrieve data it fails (depending on the App, I get some sort of message saying connection to server wasn't successful).

    My phone was jailbroken when I started using GoPhone but I removed the jailbreak (restored) a couple months ago to improve performance. I hadn't done anything (installs, backups, etc.) on Saturday that I can remember.

    I have tried reseting Network Settings, removing and then reinstalling the unlockit.co.nz provided APN settings, and rebooting numerous times, all with no success.

    Every once in a while, it seems to connect, but I cannot be certain that it isn't finding wi-fi nearby when it does.

    Any thoughts on what the cause could be and how I can rectify? I haven't yet tried restoring from backup or reapplying a jailbreak (would rather not if I can help it, but am prepared to try).

    Many thanks!
    2011-09-30 08:09 PM
  2. nycmilkshake's Avatar
    No ideas?

    I have tried jailbeaking, restoring OS, and still nothing...

    No one else having problems?
    2011-10-10 02:54 PM
  3. digitalreflex's Avatar
    I've got a 3gs running 4.3.3 and using as a gophone as well.
    I had it on t-mobile for a while and just 3 weeks ago switched over to at&t, but have not had a problem w/ data in that limited span.
    2011-10-10 03:54 PM
  4. GenesisDH's Avatar
    OP: Were you using an officially labeled smartphone plan (like the ones for the LG Thrive) w/ an applicable data pack? If not, it's possible that at&t has finally determined that you're using a smartphone and blocked data use until you switch to a smartphone GoPhone plan (yes, they do have a 'smartphone' GoPhone plan, but it typically isn't mentioned until you try using the unlimited talk/text/web GoPhone option with a smartphone).
    2011-10-10 09:09 PM
  5. nycmilkshake's Avatar
    Well, it's working again, but I'm not certain what the problem was.

    It took a call to customer service who, after reminding me that my iPhone wasn't officially supported, spent quite a bit of time trying to diagnose the problem. Embarrassingly, we realized that my account had run out of data allowance, which surprised me as I had a few hundred MBs when the problem surfaced.

    So my best guess, after looking at my online consumption history, is that for some reason on that Saturday, my service stopped, but kept draining my data allowance (at a higher rate than usual) and a couple days later this was down to nothing. All efforts to restore after this were fruitless as, unknown to me, I no longer had any data left to use.

    I've written AT&T to ask for that data back -- we'll see what happens.

    2011-11-21 09:45 PM