1. t&co's Avatar
    hi all, i wasn't sure if anyone else has experienced this strange behavior. try restarting your freshly unlocked 1.1.1 iphones and see if you lose your EDGE settings...here's my story:

    using a combination of virginator_10 script and poetic_follly's new guide, i re-unlocked 3 previously unlocked 1.0.2 iphones (that were unlocked per poetic's old 1.0.2 guide) on the t-mobile usa network. 2 use t-mo's $19.99 total internet plan, 1 uses t-mo's $5.99 t-mobileweb proxy hack method.

    using 1.0.2 unlock, rebooting these iphones maintain all settings...edge settings appear as they should and never disappear. perfectly functioning!

    using 1.1.1 unlock, rebooting these iphones maintain all settings EXCEPT EDGE settings disappear and have to be reinputted after each reboot.

    any thoughts?
    2007-10-26 02:42 PM
  2. acaijr73's Avatar
    i jus posted that very same problem this morning and nobody has ans.... im checking through the files on my phone to see if theres a file mod that can be done... if i find anything ill let u kno
    1) 16Gig 1ST GEN IPHONES 3.0 Unlkd /PWND/BNeutered

    1) 16Gig 3G IPHONE BLK PWND, 3.1.2 F/Unlkd

    1) 32Gig 3G(s) IPHONE 3.1.2 F/Unlockd/Blackra1nd
    2007-10-26 03:02 PM
  3. macmanrc's Avatar
    Hi, the answer to setting edge can be found on iNdependence 1.2.5 site, then click issues 113 and you will see where fruiteatingbear answered my ?s.But I need step by step instructions to get thru this. So here is partof answer and maybe you can help me figure how to tackle it.
    2007-10-26 03:58 PM
  4. ktula's Avatar
    hi all, i wasn't sure if anyone else has experienced this strange behavior. try restarting your freshly unlocked 1.1.1 iphones and see if you lose your EDGE settings...here's my story:

    using a combination of virginator_10 script and poetic_follly's new guide, i re-unlocked 3 previously unlocked 1.0.2 iphones (that were unlocked per poetic's old 1.0.2 guide) on the t-mobile usa network. 2 use t-mo's $19.99 total internet plan, 1 uses t-mo's $5.99 t-mobileweb proxy hack method.

    using 1.0.2 unlock, rebooting these iphones maintain all settings...edge settings appear as they should and never disappear. perfectly functioning!

    using 1.1.1 unlock, rebooting these iphones maintain all settings EXCEPT EDGE settings disappear and have to be reinputted after each reboot.

    any thoughts?
    Try this:
    http://ktula.com/2007/10/20/solution...-carriers-apn/
    2007-10-26 08:11 PM
  5. t&co's Avatar
    thank you all for your contribution! it might appear that this is a sporadic issue. i can affirm that one of the 3 iphones now correctly displays apn information without tweaking pref files.

    @ ktula & macmanrc:
    thanks for the links. i followed the instructions for both links, but the iphone still forgets the edge network settings.

    i also tried the method of installing Services application via installer.app, but that didn't work either.

    i'll keep trying...but i've gotta go. if i stumble across anything, i'll post here....thanks!
    2007-10-26 09:13 PM
  6. JokerX's Avatar
    I used the guide and it worked perfect and still there after many reboots.
    8GB iPhone 1.0.2 Unlocked - Revirginized - Then 1.1.1 Jailbroken and Unlocked (Gone Bad - Traded In)

    8GB iPhone 1.1.1 OTB JB - Unlocked - Restored to 1.1.3 JB and Unlocked (SOLD)

    16GB iPhone 1.1.4 OTB JB / Activated / Unlocked - With iPlus2.0b (Current)

    5000 iPhone wallpapers click here]
    2007-10-29 05:53 AM
  7. hernz's Avatar
    my edge fields clear after reboot, but edge still functions as it should. so is this a mater of aesthetics for you guys with the problem?
    2007-10-29 10:02 PM
  8. savva's Avatar
    my edge fields clear after reboot, but edge still functions as it should. so is this a mater of aesthetics for you guys with the problem?
    I just checked mine, and indeed, the APN is empty. However, the EDGE is still functional, cool!
    Last edited by savva; 2007-10-30 at 07:01 AM. Reason: (using 5.99 plan)
    2007-10-30 07:00 AM
  9. truenorth's Avatar
    Thanks, ktula, that worked. Strange, hernz, when my EDGE setting disappears, my connection doesn't work. I always had to enter the APN. But thanks for the info.
    Last edited by truenorth; 2007-10-30 at 12:17 PM.
    Sydney, Australia
    If you received help, click on the Thanks button!

    2007-10-30 12:14 PM
  10. glustic's Avatar
    If you have installer.... Get the BigBOSS source, and download the apn fixer. One click fixes it all
    8GB 3G iPhone


    • Universal-Sim 5.5 Unlock
    • 2.1 Pwned with Pwnage Tool
    2007-11-07 03:37 PM
  11. fernandorinto's Avatar
    The solution to this is to SSH/SCP into the iPhone /System/Library/Frameworks/CoreTelephony.framework/Support/ and transferred the UnknownCarrier.plist file to you desktop and edit with TextEdit on mac, or note pad on windows.

    Just look for the section that specifies the APN settings and fill in the blanks appropriately, for example:

    Code:

    <array>
    <dict>
    <key>apn</key>
    <string>internet.com</string>
    <key>password</key>
    <string>wap</string>
    <key>username</key>
    <string>wapuser1</string>
    </dict>
    <dict>
    <key>apn</key>
    <string>internet.com</string>
    <key>password</key>
    <string>wap</string>
    <key>username</key>
    <string>wapuser1</string>
    </dict>
    </array>

    (The above settings are for Rogers Wireless -- obviously if you're on another carrier you will need to enter the APN settings appropriate for your carrier).


    Than uploaded back to the same place and override the original but first make a backup just in case than reboot your iPhone

    /System/Library/Frameworks/CoreTelephony.framework/Support/

    Hope this Help.
    Last edited by fernandorinto; 2007-11-08 at 12:41 PM.
    2007-11-08 12:39 PM
  12. frnkied's Avatar
    this is REALLY EASY to fix. just go to ur installer and then sources, add this as a source, "i.unlock.no" then hit ok. once ur installer recognizes it as a source, then go to "install" and then u'll see u have new category, just install the "EDGE" something and ur good. the option where u edit ur APN settings will appear under SETTING>GENERAL>NETWORK>EDGE. just input ur APN setting and u won't loose it ever again, no matter how many times u reboot ur iPhone.
    ░▒▓█ Working iPhone v2.0.1 with T-Mobile
    ░▒▓█ Call In/Out ► Yes/Yes
    ░▒▓█ SMS In/Out ► Yes/Yes
    ░▒▓█ WiFi/EDGE ► Yes
    ░▒▓█ YouTube App ► Yes
    ░▒▓█ Voicemail ► Yes
    ░▒▓█ iVolume v1.3 MOD ► Yes
    2007-11-12 06:10 AM
  13. leer100's Avatar
    I've been dealing with this for weeks. This worked perfect!
    2007-11-13 01:03 AM
  14. bbdc's Avatar
    I may need this explained to me like a 5 year old. I have an unlocked iphone (fresh out of box 1.1.1) which works great (except on edge). I have the blackberry unlimited data plan attached to my mobile number.

    I cant get the iphone to hold the apn value. After i enter it, i am immediatly returned to the home screen. I installed the fix conatained within the "i.unlock.no" but to no avail.

    Do i need to edit the UnknownCarrier.plist or is my issue different, since the phone wont even hold the setting regadless if i restart or not?
    2007-11-15 04:39 PM
  15. truenorth's Avatar
    bbdc, if the solution at i.unlock.no didn't work for you, here are several fixes that worked for different people.
    Sydney, Australia
    If you received help, click on the Thanks button!

    2007-11-15 11:42 PM
  16. krausz's Avatar
    Hi there, sorry to inform that Blackberry plans are not usable by the iphone, you have to get a REAL internet data plan, since the blackberry plans use blackberry.com as APN, and it canīt authenticate from the iphone....
    2007-11-23 08:15 AM
  17. kiepfeuphac's Avatar
    just unlock my v1.1.1 ...n having same problem with EDGE .. I did install EDGE fix from i.unlock.no but still not fix.
    2007-12-24 09:06 PM
  18. leshman's Avatar
    Hi there, sorry to inform that Blackberry plans are not usable by the iphone, you have to get a REAL internet data plan, since the blackberry plans use blackberry.com as APN, and it canīt authenticate from the iphone....
    This is wrong. I have two iPhones with the TMobile BIS plan and both work perfectly over EDGE. It may not work with the BES plan (I don't use BES so I don't know what APN it uses) but BIS uses wap.voicestream.com.
    2007-12-26 09:43 PM
  19. Qbcmtr's Avatar
    I have the $5.99 plan and have edge working even without anything in APN.
    2008-04-22 06:13 PM
  20. mobidate12's Avatar
    Hello everyone,
    This is Raj from Mumbai, just found this Mobile app, thought to share with you...
    Mobile Java Application | Mobile Social Networking | Free SMS, Voice Message | MobiYard.Com it lets you send free sms worldwide, free voice message, Instant messenger, Free mobile content and much much more..
    Compatible Mobile : www.mobiyard.com/compatibility.php

    Btw, Nice forum Skin, i' Loved it..
    2008-07-05 12:33 PM
24 12
LINK TO POST COPIED TO CLIPBOARD