1. Wildman94's Avatar
    Does the Total Internet Add-on for 19.99 enable EDGE to work for Safari, Email, and the such on the iPhone without any hacks??
    2008-04-21 01:19 PM
  2. jtesnani's Avatar
    yes. once you add that to your plan, go to settings, general, network, edge and for APN put in internet2.voicestream.com and leave username and password blank and everything is supposed to work when connected to edge
    2008-04-21 03:46 PM
  3. Wildman94's Avatar
    yes. once you add that to your plan, go to settings, general, network, edge and for APN put in internet2.voicestream.com and leave username and password blank and everything is supposed to work when connected to edge
    Do you have any idea about the speed of that??? And do I have to wait 24 hours after actually enabling it??
    2008-04-21 05:15 PM
  4. jtesnani's Avatar
    no you don't have to wait. it usually is enabled right away but there are always a few cases where it takes a bit longer

    i just did a test and i got about 52kbps. i could have sworn i got a higher speed before. not sure if being inside a building has anything to do with it, or that i'm actually running on wap.voicestream.com off a blackberry plan (but still connected to edge so that shouldn't affect it)
    2008-04-21 05:22 PM
  5. Wildman94's Avatar
    I just did as you said right now, turned off wifi (so I could use only EDGE), and tried going to google.com. As I was trying to, it told me that I did not subscribe to EDGE. maybe should I try using wap.voicestream.com as the APN instead of internet2.voicestream.com??
    2008-04-21 05:33 PM
  6. jtesnani's Avatar
    you can always try, but if you had just signed up maybe you want to wait a bit
    2008-04-21 05:40 PM
  7. Wildman94's Avatar
    I'll try again later then...


    EDIT: It works now, but its sorta slow. W/e i guess. Thanks soo much!!
    Last edited by Wildman94; 2008-04-21 at 07:13 PM.
    2008-04-21 06:50 PM
  8. french bum's Avatar
    it took mine 56 hours to work. And it's fast.
    2008-04-21 09:33 PM
  9. Neobond's Avatar
    i get about 150kbps with total internet
    2008-04-22 02:48 AM
  10. Qbcmtr's Avatar
    I did this mod, reset my phone, and it still works without anything under the APN. Is this normal?
    2008-04-22 06:11 PM
LINK TO POST COPIED TO CLIPBOARD