1. krazeazn's Avatar
    hello everyone,
    is anyone having a problem with their voicemail alerts?
    I am on a iphone 1.1.1 unlocked with anysim1.1p running on t-mobile USA

    problem is -
    1. voicemail alert (red dot) comes up everytime i reboot the iphone.
    2. the alert does not go away when i check my voicemail.
    3. the alert will only disappear if i listen to a brand new voice message.
    4. it seems to be a sim card issue, since my girlfriend is also on tmobile unlocked to 1.1.1 has alert (red dot) issues.

    does anybody have or know of a fix for this without obtaining a new sim card replacement?
    2007-11-11 07:18 AM
  2. horatio0's Avatar
    how did you get voicemail to work? i have tried everything. i have t-mobile US.
    2007-11-12 05:10 AM
  3. krazeazn's Avatar
    how did you get voicemail to work? i have tried everything. i have t-mobile US.
    i did not have a problem getting voicemail to work.
    i jailbreaked using firmware 1.1.1 from jailbreakme.com
    then ssh anysim 1.1.1p,unlocked, and everything works.
    2007-11-12 05:34 AM
  4. jim0068's Avatar
    Mine has worked from normal from day 1 unlock.

    I unlocked using the jailbreakme.com method along with AnySim unlock and haven't had any issues with voicemail or the red dot.
    2007-11-15 06:32 AM
  5. rotero's Avatar
    The red dot indicates that you have voicemail in the system, either saved or new. You probably have a saved voicemail, that is why on reboot you get the dot. I have yet to find a workaround for it.
    2007-11-15 04:30 PM
  6. tarponfly49's Avatar
    I haven't had a problem with the dot not going away, but from day one with my old (three different) windows mobile 5 phones and now my iphone, it always says new voicemail but never a number (when I had cingular it would always read the number of voicemails) Does anyone else's phone tell the the number of voicemails? I know it has to be a system problem or a sim problem since it's been the same across platforms....Thanks
    2007-11-15 04:53 PM
  7. paragongja's Avatar
    I have had the same problem, Power on or come out of flight mode and the red button for voice mail pops up. Even when there are no messages, old, saved or new in my voicemail.
    2007-11-16 02:30 PM
  8. itsmistergreg's Avatar
    you need to upgrade your sim to a new 64k sim. the SKU (top barcode) on the back of the sim should end in 20, not 10.
    2007-11-18 08:25 PM
  9. Kyle Matthews's Avatar
    Yup, old sims do that. New sims don't.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-11-19 03:08 AM
  10. paragongja's Avatar
    How does one update their sim card?
    2007-11-20 11:13 PM
  11. abdelkweli1's Avatar
    you go to a t-mobile store and pay $19 for a new sim card. All the new have the newer "system updates". Good luck
    You might as well get one free if you go there say your sim doesnt work on your phone anymore, they might give you a free one. I've realized if you tend to bring your iphone, they love you even more for staying on the t-mobile network, so go try your luck!
    2007-11-21 04:13 PM
  12. Munzo's Avatar
    I've got the same problem only I am with Rogers and my last 2 numbers are; 30
    2007-11-22 12:50 PM
  13. RobbyLam's Avatar
    yea, when i brought my Moto a1200 Ming and i told the t-mobile rep, that my phone kept turning off and saying invalid sim, they just looked up my info and gave me a new sim for free.. took less than 5 minutes.
    2007-11-24 03:38 PM
  14. krazeazn's Avatar
    I can also confirm that it is a sim card problem! i brought my iphone in a official t-mobile store and told them i'm having problems with my voicemail notification showing up that i have one when i don't...the lady replaced my sim for free and it solved my problem. thanks everyone for all your help!
    2007-11-24 10:13 PM
  15. Munzo's Avatar
    Can anyone help me?
    2007-11-27 11:38 PM
  16. Kyle Matthews's Avatar
    If Rogers has 64k SIM cards, then you're good to go. If not, no solution yet.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-11-28 12:02 AM
  17. Penduboy's Avatar
    I am rogers as well but I have no issues with my voice mail for last month or so but last week I was unlocking one of my friends iphone and I put my sim card in his iphone to run Anysim 1.1 and after that I won't get RED DOT on my voice mail icon right away. Sometimes this red dot appears after few hours of getting new voice mail and some times its not appearing at all.

    But this is not a big issue for me as I check my voice mails regularly but its nice to have every thing in order.

    Please advise if you have any solution to that.

    Pendu
    2007-11-28 05:35 AM
  18. Ridge's Avatar
    I am rogers as well but I have no issues with my voice mail for last month or so but last week I was unlocking one of my friends iphone and I put my sim card in his iphone to run Anysim 1.1 and after that I won't get RED DOT on my voice mail icon right away. Sometimes this red dot appears after few hours of getting new voice mail and some times its not appearing at all.

    But this is not a big issue for me as I check my voice mails regularly but its nice to have every thing in order.

    Please advise if you have any solution to that.

    Pendu
    http://modmyi.com/forums/showthread.php?t=18619
    Last edited by Ridge; 2007-11-29 at 01:31 AM. Reason: wrong link

    If I helped you in anyway, show some love! hit the thanks button!
    2007-11-29 01:05 AM
  19. Penduboy's Avatar
    Thanks a lot. I will try it tonight but I am going to press THANKS button now for you and thanks once again.

    Pendu
    2007-11-29 03:52 AM
  20. Ridge's Avatar
    Thanks a lot. I will try it tonight but I am going to press THANKS button now for you and thanks once again.

    Pendu
    So much pressure for me to deliver now!!! Let me know if it works mate... thanks again!

    If I helped you in anyway, show some love! hit the thanks button!
    2007-11-29 03:59 AM
30 12
LINK TO POST COPIED TO CLIPBOARD