1. rapidj's Avatar
    I bought an 8GB older version several weeks ago and succesfully pwnd it using 2.0. Flawless. I was able to use my T-Mobile account and got the 5.99 data plan. No problems. Today while at work, went to make a call and it would connect any calls. The little e in a box at the top was gone and replaced by a little dot in a box. I assume it means im not getting the wireless data. Tried several calls but no connection, went outside tried a few more. It says T-Mobile at the top and Im getting plenty of bars, but no connection and no email connection. After a few more tries, I finally got it to dial my home number and talked with my wife briefly. also called my desk phone with no problem. After that however, it was back to nothing. Any thoughts? Now there is no dot in a box and no e in a box.

    The only thing I did differently was to plug the phone into my PC at work to charge. Never done this before. It always charges on my Mac at home. Dell at work brought up iTunes, but I didnt' click anything like upgrading software. Just charged it

    Just restarted a few moments ago. First it said ATT up in the corner (I don't have that service), then it said no service, then it said T-Mobile and I got bars. Still not able to make a call. I can text and recieve texts. How can that be?

    Could I have done something simply by hooking it to the PC to charge?
    2008-08-14 11:55 PM
  2. Pcpro745's Avatar
    PC shouldnt have had any effect, Guess i would say to restore......
    2008-08-15 01:23 AM
  3. Kalvin_And_Hobbes's Avatar
    upgrade to 2.0.1 then unlock on that then try again it works fine for me on 2.0.1
    2008-08-15 05:42 PM
LINK TO POST COPIED TO CLIPBOARD