1. thebluecoat's Avatar
    I myself have been having many problems with T-Mobile edge settings.

    I have a first generation, that came stock with 2.0.1 firmware.
    When I took it home, I realized when I inserted ( wap.voicestream.com),
    into my GPRS/EDGE settings, it failed to connect to any websites saying "I was not subscribed to EDGE".

    It always worked when I had a previous iPhone with 1.1.4 firmware, so I reverted. From that moment on (wap.voicestream.com) worked fine.

    BUT, I could do everything except connect to AIM with Agile Messenger (big problem with me), and sometimes my Mobile Scrobbler application wouldn't function because of internet connectivity issues so I thought to myself "port problem"

    After doing much research I learned that (T-Zones) and its settings are (wap.voicestream.com), so if you are paying the $19.99/mo and have this settings, you are limiting yourself to slower speeds and more blocked ports (from what I have read).

    So, there is advice out there that if you have the Total Internet Plan, for $19.99/mo that you need to switch your EDGE APN to either internet1.voicestream.com or internet2.voicestream.com, which seems for some to restore network functionality.

    However, internet1.voicestream.com and internet2.voicestream.com wouldn't work for me, and I thought to myself something is wrong with my account.

    T-Mobile when I signed up placed me on the Total Internet VPN Package, which is the same price $19.99 a month, but apparently has VPN functionality enabled.

    So after further research on the internet I found the corresponding GPRS/EDGE settings for those who MAY have this data plan and not know it until they call and talk on the phone for an hour like I did.

    Turns out the corresponding EDGE settings for my package are:

    internet3.voicestream.com

    AIM now functions and signs on EVERY time. Mobile Scrobbler now works perfectly, and im in the process of testing the settings on the new 2.0.2 firmware.

    So, for those of you out there that still can't get internet1.voicestream.com and internet2.voicestream.com to work or even wap.voicestream.com try:

    internet3.voicestream.com

    You may find that your problem has been solved like me.

    Goodluck,
    thebluecoat
    2008-09-05 06:09 PM
  2. 1lapilot's Avatar
    That must be what I'm on cause when I signed up the rep told me to use internet3.voicestream.com. The only issue I still have is STAYING connected to EDGE. Do you have to configure the VPN?
    2008-09-05 06:46 PM
  3. thebluecoat's Avatar
    I do not use the VPN portion of my service, it was their mistake they put me on it, instead of the "non-vpn total internet" which is what they generally put customers on.

    They something around the area of "we have two internet packages, one is sort of an old one that we dont use anymore (mine apparently), and the total internet package"

    As soon as I changed my APN to : internet3.voicestream.com, I have had no problems with anything.
    2008-09-06 02:47 AM
  4. Muggz5's Avatar
    What I find odd is that I'm pulling 250 to 300 KBps but not a consistent basis. So I switched from the wap.voice.... to internet2 and rebooted and left it alone for about 36 hours. No connection could/would establish on the phone. now im back to wap. but I feel like im missing some speed so maybe your internet3 theory will work. I will post results.

    Update: Well I'll give it 24 hours, but as of now between rebooting and countless refreshes still not able to establish a connection using the internet3 Im going to call TMo see which of the 2 im on.

    Update (following day) : I called tMobile and 1 rep. after another all tell me Im on the total internet package and say I should be using (internet2 ,internet3) After a little back and forth I asked to speak with an upper classed rep. or a supervisor. after a grueling 30 minutes I finally get connected to him. Come to find out im on the Unlimited GPRS package not Total Internet!!!! VOILA (cue the Choir!!) Anyway so I switch to the total internet package and my speed is the same granted im using internet2 + ports but its still not any faster than the 250-300. So again to all of you out there make sure you are on the total internet package and cross and double check to make sure that way you know your access point.
    Last edited by Muggz5; 2008-09-07 at 01:47 AM.
    2008-09-06 02:52 AM
  5. treaty's Avatar
    Well... my bill says "Total Internet Adon" for $19.99 a month. The only APN setting that will work for me is wap.voicestream.com... internet1,2 or 3 just don't work. I think it's more likely that the APN that works for you is based on your location... or what part of the country you purchased your service agreement in or something. I'm in Seattle.
    2008-09-07 04:26 AM
  6. Muggz5's Avatar
    Well... my bill says "Total Internet Adon" for $19.99 a month. The only APN setting that will work for me is wap.voicestream.com... internet1,2 or 3 just don't work. I think it's more likely that the APN that works for you is based on your location... or what part of the country you purchased your service agreement in or something. I'm in Seattle.

    So i thought as well. You need to call them and verify you dont have the package I was referring to.
    wap.voicestream.com was the ONLY setting that worked for me and I couldnt figure it out.. So I called and it turns out I was on the wrong total internet package. Same price but wrong plan. that package you are referring to is the unlimited GPRS BB package with unlimited messaging which is what I was on from my previous blackberry. My wife called and asked for the total internet package when we got her an iphone a year ago and they gave her the same plan as mine assuming this is what she intended. Now we are with the correct plan and use the internet2 settings.
    2008-09-07 08:09 AM
  7. thebluecoat's Avatar
    Thank you everyone for posting some feedback on your findings, I think we are all onto something here. Tons of people complaining about blocked ports / slow speeds. Tons of people collaborating and finding out they are on the wrong internet package (go t-mobile)


    edit: but it is wierd that both wap.voicestream.com and internet3.voicestream.com work for me. However internet2.voicestream.com does not.
    2008-09-07 11:50 PM
  8. Muggz5's Avatar
    Yeah the reason the wap apn works for you is because the ports are still enabled. The Total Internet Package opens up the upper ports and gives access to all of them. I think Internet1,2,3 are related to your location.
    2008-09-08 07:16 AM
  9. treaty's Avatar
    that package you are referring to is the unlimited GPRS BB package with unlimited messaging which is what I was on from my previous blackberry.
    I don't think so because I dont get unlimited messaging at the moment... but you've convinced to call T-mo and quiz them on which "total internet" plan I've got... I'll post back later if I dig anything up... thanks for the info.
    2008-09-09 08:30 AM
  10. 1SickVeilsideZ's Avatar
    I just got my 3G unlocked and everything works great, but I lost my Edge!! WiFi obviously works, but my phone no longer gets Edge! My previous iphone was great, but I broke it and didn't want to spend a lot of $$$$ money for another one, so I went and get this one.... My friend unlocked it for me and everything works great, but we can't figure why the Edge is not working for it anymore? Anyone have an idea on what I can do to fix it? Again this is a new 8g with 3g and it is unlocked for Tmobile, but no Edge service. Any help would be great! Thanks guys!
    2008-09-10 01:51 AM
  11. Haydeepooh's Avatar
    Thank you so much! This fixed my problem with getting on the internet with Edge. The internet2.voicestream.com worked like a charm!!! You are so awesome!!!
    2008-10-01 04:04 AM
LINK TO POST COPIED TO CLIPBOARD