1. joechka's Avatar
    Sincere thanks to you and to everyone who contributes to this and other forums.. if it weren't for you, novices like myself would be absolutely screwed. Here is my issue:

    I have a 1st generation Iphone running 2.0.2 with Itunes 7.7.x? I jailbroke and unlocked it last week using WINPWN and have been using it with a T-Mobile sim card now for 6 days. Everything functions perfectly EXCEPT yesterday my SMS suddenly quit. Now I am unable to receive any messages and every attempt in sending results in this: "ERROR SENDING MESSAGE." I have a tried sending/receiving messages to/from every other carrier and none work. A friend of mine also has t-mobile with his Iphone and his SMS is fine (he is still running firmware 1.1.4 though). Is there a fix for this? If I have to restore my iphone through itunes will I need to WINPWN it again? If so, will my T-Mobile service be affected?

    Any and all advice and directions are GREATLY appreciated! I apologize if there is already a solution to this problem posted, but I searched the forums and was unable to find it. Thanks again.
    2008-09-15 08:04 PM
  2. cartman13's Avatar
    Sounds like your data connection isn't active. Are you sure your APN is set correctly?

    Might want to call t-mobile to let them help trouble shoot. But i would check your APN first. (should be set to wap or internet2 .voicestream.com)

    i'm using 2.1 on t-mo and sms is fine. worked fine for me on every firmware before 2.1 as well.
    If i say something stupid I apologize. If i say something smart: "RESPECT MY AUTHORITAH".
    And if i help you, please hit the Thanks!
    2008-09-15 09:12 PM
  3. joechka's Avatar
    Thanks cartman! I did actually hash it out with T-Mobile.. turns out it was simply a technical problem on their end and their system incorrectly showed I had maxed out my plan 1000 text messages in only 5 days. Problem solved. Thank again.
    2008-09-16 05:13 AM
LINK TO POST COPIED TO CLIPBOARD