1. itaintrite's Avatar
    Anybody what's wrong with it? I have the data roaming option on. Installed the t-zone hack. Checked apn to make sure it has wap.voicestream.com.

    Still nada. The EDGE icon doesn't even show up next to carrier logo.

    Any suggestion would be appreciated. Thanks.
    2008-09-25 04:53 AM
  2. teeboz's Avatar
    I am having the same problem did you get this resolved?
    2008-10-03 06:24 PM
  3. jamba's Avatar
    I think I have found the fix. Good news and bad news.

    Good news it requires no finicking with SSH, carrier settings, or anything else in the IPhone.

    Bad news is you need to have another "regular" phone that the t-mobile SIM works in and can access TZones or internet with.

    1) Take the T-Mobile SIM and put it in to the "other/regular" phone.
    2) Turn it ON, and access Tzones/Internet.
    3) Browse around for a while.
    4) Remove SIM from "other" phone.
    5) Put T-Mobile SIM + Turbo SIM into IPhone (don't forget to turn off 3G).

    EDGE turned on right away after I did this.

    There must be some sort of "activation" of data access on the SIM that the IPhone with the Turbosim can't do. Hope this helps!
    2008-10-17 12:02 PM
  4. Nasp30's Avatar
    what jamba said actually works, just use another phone, play around with t-zones, then place it bak in the iphone 3G with the turbosim and u should see the "E" come out.... make sure 3G is off, add wap.voicestream.com to your APN, and have data roaming on (im not sure if the data roaming ON/OFF makes a difference but thats how i have it and it works).
    2008-10-18 09:34 AM
  5. lolote's Avatar
    on my-tmobile, it doesnt even say t-zones, it says t-mobileWeb. is that the same? is it unlimited? i'm about to get my turbo sim, so i want to mak sure i know what to do in case this happens...
    2008-10-18 10:43 AM
  6. kazach's Avatar
    This is completely true .
    Does anybody now why ??
    I how to get around this ?
    I don't want to carry to phones so i can have internet.
    Thanks
    2008-11-19 11:06 PM
  7. X-ception's Avatar
    when your edge goes away try turning roaming on and off ... reeboot your phone once every night ...

    i've been using turbosim for 4 months now and only once had to take out the sim and use in another phone for internet and that was after when i went abroad and my phone was off for 2 weeks ... and sometimes just pop the tray out dont even take it out all the way just pop it out and put it back in and it works too ...
    2008-11-21 01:20 AM
  8. infamous12550's Avatar
    I'm confused... I have a 3g jailbroken/isim unlocked & have never had an "edge icon" but have no problem connecting to the Internet w/ t-zones proxy hack. I use epc.tmobile.com as my apn & everything works, even youtube. I installed the package for "old edge icon" via Cydia for cosmetic purposes, because the 3g phone is not supposed to have an "edge icon". Its supposed to be "3g". So I don't think not having the icon has anything to do with being connected...
    "Win or lose, I promise you violence"

    Wanderlei Silva
    2008-11-22 04:08 PM
  9. itaintrite's Avatar
    Perhaps there are different versions of turbosim. And one might work better than another. Same thing happens to me once in a while (sometimes days, sometimes weeks). And rebooting won't help. Just have to remove sim and use it on another phone. Then insert it back into iphone.

    This will fix "no service" too.

    I'm confused... I have a 3g jailbroken/isim unlocked & have never had an "edge icon" but have no problem connecting to the Internet w/ t-zones proxy hack. I use epc.tmobile.com as my apn & everything works, even youtube. I installed the package for "old edge icon" via Cydia for cosmetic purposes, because the 3g phone is not supposed to have an "edge icon". Its supposed to be "3g". So I don't think not having the icon has anything to do with being connected...
    This is very interesting indeed. I never have to install the tzone proxy hack to get my Edge to work. I just have to set apn to epc.tmobile.com and it'll work right away. Whenever the Edge icon disappears, I lose internet since the phone will say that I'm not connected to the internet. Perhaps if you install the proxy hack, it won't matter if the Edge icon is on or not. I'll have to try this
    Last edited by itaintrite; 2008-11-23 at 08:39 AM.
    2008-11-23 08:36 AM
  10. tattoojack's Avatar
    I'm confused... I have a 3g jailbroken/isim unlocked & have never had an "edge icon" but have no problem connecting to the Internet w/ t-zones proxy hack. I use epc.tmobile.com as my apn & everything works, even youtube. I installed the package for "old edge icon" via Cydia for cosmetic purposes, because the 3g phone is not supposed to have an "edge icon". Its supposed to be "3g". So I don't think not having the icon has anything to do with being connected...
    ARE YOU KIDDING ME????

    edge icon is on the 3G phone silly.
    it shows up when you turn 3G off or u are in an area with no 3G coverage.
    but there is defiantely edge in 3G phones.
    and there is an edge icon too.
    i see it all day.
    2008-11-25 04:33 PM
  11. rsw3284's Avatar
    I had the edge icon disappear on me as well, and changing sim card between phones can be quite a hassle. After googling a bit, I found a post suggesting to remove the T-zones hack from cydia if you have T-mobile's total internet plan -- I uninstalled T-zone hack, rebooted, and voila.. my edge icon returns -- I did notice that my APN (internet2.voicestream.com) got cleared after I removed the hack and rebooted, but this was a 10 second fix.

    I suppose those that require t-zones hack could possibly uninstall the hack, reboot and re-install it -- but this would require being near a wifi source, so not exactly an optimal solution for those who are out and about.

    Phone Info:
    8Gb Iphone 2.1 jailbroken / turbosim
    T-mobile / Total internet plan
    Last edited by rsw3284; 2008-12-10 at 01:02 AM.
    2008-12-10 12:53 AM
  12. seh6183's Avatar
    DO this if you lose edge:

    This is for a 3G (most likely applies to 2G's. But who uses turbo sims for 2G's these days?)

    I have been having a ton of trouble lately with my turbo sim, so have about 6 other people that I know. I have discovered a way that you can restore service and edge at anytime without a computer or cables or anything. All you have to do is follow these directions in the EXACT order posted below.


    When you notice loss of Edge or your phone is constantly looking for service or dropping calls, do EXACTLY the following:



    1.) Reset network services
    2.) IMMEDIATELY put phone into airplane mode
    3.) Go to Settings>General>Network settings> and turn on Data Roaming and disable 3G
    4.) click Cellular Data Network and type in the apn (Tmobile: epc.tmobile.com)
    5.) Restart the phone and let it boot up completely
    6.) Remove Airplane mode


    Phone should now be working perfectly as soon as it finds service. Repeat as necessary.




    Alternatively you can do the following to restore service without edge (sometimes the phone just wont work with edge)


    1.) Reset network services
    2.) IMMEDIATELY put phone into airplane mode
    3.) Enable wifi
    4.) Go to cydia and download sbsettings by big boss
    5.) open the sb control panel and disable Edge
    6.) Go to Settings>General>Network settings> and turn OFF Data Roaming and disable 3G
    7.) Go to Settings>General> turn OFF Location services
    8.) Restart the phone and let it boot up completely
    9.) Remove Airplane mode



    There it is. Hopefully this can help a bunch of people who are struggling with their turbo sims.

    Im thinking maybe this should be moved to another section, like unlocking or tmobile specific.
    2008-12-11 12:08 AM
  13. THE TECH's Avatar
    DO this if you lose edge:

    This is for a 3G (most likely applies to 2G's. But who uses turbo sims for 2G's these days?)

    I have been having a ton of trouble lately with my turbo sim, so have about 6 other people that I know. I have discovered a way that you can restore service and edge at anytime without a computer or cables or anything. All you have to do is follow these directions in the EXACT order posted below.


    When you notice loss of Edge or your phone is constantly looking for service or dropping calls, do EXACTLY the following:



    1.) Reset network services
    2.) IMMEDIATELY put phone into airplane mode
    3.) Go to Settings>General>Network settings> and turn on Data Roaming and disable 3G
    4.) click Cellular Data Network and type in the apn (Tmobile: epc.tmobile.com)
    5.) Restart the phone and let it boot up completely
    6.) Remove Airplane mode


    Phone should now be working perfectly as soon as it finds service. Repeat as necessary.
    Did this work for anyone else? It didn't work for me.
    2008-12-16 05:12 AM
  14. seh6183's Avatar
    Unfortuantely if this is not working for you then its because the sim needs to be put into another phone that has working edge. Use the edge for a few minutes and then put the sim (and adapter) back into your 3G and repeat the steps as nescessary.
    2008-12-16 06:16 AM
  15. olsen_b's Avatar
    I had this problem as well what I had to do was turn the phone off and call customer care and tell them to reactivate the towers because I am not picking anything up.. It is still very spotty though.. I am going back to the old 2g..
    2008-12-16 08:45 AM
  16. THE TECH's Avatar
    Unfortuantely if this is not working for you then its because the sim needs to be put into another phone that has working edge. Use the edge for a few minutes and then put the sim (and adapter) back into your 3G and repeat the steps as nescessary.
    Any idea what the reason for this is? It was working before. What would stop it from working??
    2008-12-16 03:38 PM
  17. seh6183's Avatar
    Reason: Sim adapters cost 30 cents to make. Just hold out for the software unlock that will be released in the next few weeks.
    2008-12-16 10:22 PM
  18. THE TECH's Avatar
    Reason: Sim adapters cost 30 cents to make. Just hold out for the software unlock that will be released in the next few weeks.
    Guess I'll just have to hope that it comes sooner than later.
    2008-12-16 10:28 PM
  19. seh6183's Avatar
    Ok this morning I lost edge for the first time in a while. I tried my OWN procedure to get it back and I could not. I tried 3 times and nothing. So I made a small change to the order in which I did things and got it back.


    TURN OFF DATA ROAMING

    Reset network settings and immediately put into airplane mode

    set apn

    restart phone completely

    take off airplane mode and while the phone is searching for service switch data roaming on and off repeatedly until you see the blue E pop up.




    Sounds ghetto but it worked. Don't worry a software unlock will be available on Dec 31st and you can throw your sim adapter away.
    2008-12-17 10:39 PM
  20. infamous12550's Avatar
    Ok this morning I lost edge for the first time in a while. I tried my OWN procedure to get it back and I could not. I tried 3 times and nothing. So I made a small change to the order in which I did things and got it back.


    TURN OFF DATA ROAMING

    Reset network settings and immediately put into airplane mode

    set apn

    restart phone completely

    take off airplane mode and while the phone is searching for service switch data roaming on and off repeatedly until you see the blue E pop up.




    Sounds ghetto but it worked. Don't worry a software unlock will be available on Dec 31st and you can throw your sim adapter away.
    Ok so Ive heard both the diff variations of this, but I have a question... How are you guys resetting your network settings & then immediately putting your phone into airplane mode? Do you mean after it reboots? My phone instantly reboots after I choose the second (red) prompt asking me of I want to reset the network settings.
    "Win or lose, I promise you violence"

    Wanderlei Silva
    2008-12-18 12:21 AM
32 12
LINK TO POST COPIED TO CLIPBOARD