1. hien331's Avatar
    Go to Settings > General > Network > Cellular Data Network and type in exactly :
    Cellular Data=
    APN: epc.tmobile.com
    Username:
    Password:

    MMS=
    APN: wap.voicestream.com
    Username:
    Password:
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size:
    MMS UA Prof URL:
    Exactly what i did! It worked both receiving and sending pretty well. You must restart your iphone when you add all the above!
    2009-06-24 02:45 AM
  2. i.Annie's Avatar
    APN: wap.voicestream.com
    Username:
    Password:
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size:
    MMS UA Prof URL:

    Once settings are entered restart ur phone and the little camera icon should show in the Messages...let me know if this helps anyone!

    I have factory unlocked 3G iphone on tmobile USA!!!
    Works great now.
    THANK YOU FOR THE INFO. It's awesome and works, well I didn't try sending yet but the camera icon showed up, yay!!

    Oh, just FYI for some people who might be a little lazy or slow like me, don't respring your phone. Actually shut down then turn on your phone. I retyped the darned things over and over 4 times and resprang before I decided to restart my entire phone instead -.- bah, lol I feel dumb.
    2009-06-24 03:11 AM
  3. Thepogcbr900rr's Avatar

    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size:
    MMS UA Prof URL:

    were do u enter these settings? I do not have them under general/network
    thanks
    Last edited by Thepogcbr900rr; 2009-06-24 at 04:25 AM.
    2009-06-24 04:03 AM
  4. chinh's Avatar
    Go to Settings > General > Network > Cellular Data Network and type in exactly :
    Cellular Data=
    APN: epc.tmobile.com
    Username:
    Password:

    MMS=
    APN: wap.voicestream.com
    Username:
    Password:
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size:
    MMS UA Prof URL:
    2009-06-24 04:10 AM
  5. xgus69's Avatar
    Cellular Data Network is missing in my menu.. I cant find it.. and I googled around for it.. other people are having that issue as well
    2009-06-24 04:26 AM
  6. aurena's Avatar
    where do i enter my number

    Go to Settings > General > Network > Cellular Data Network and type in exactly what the OP states.
    Then, restart your phone to apply the new settings. The Messages app will ask you to type in your phone number in the appropriate place to work. Everything should work flawlessly now

    btw I am using a iPhone 3g with ultrasn0w unlock on OS 3.0

    Thanks OP for the setup info.

    Now on to tethering :X
    where do i enter my number??
    Last edited by aurena; 2009-06-24 at 05:14 AM. Reason: Automerged Doublepost
    2009-06-24 05:14 AM
  7. d3athrac3r's Avatar
    where do i enter my number


    where do i enter my number??
    when you go to messages it should ask you to enter your number, but it might not. it did ask me but it does not seem like everybody has to do this not sure.
    2009-06-24 07:58 AM
  8. tekwiz's Avatar
    Cellular Data Network is missing in my menu.. I cant find it.. and I googled around for it.. other people are having that issue as well
    I had this same issue. I used a cydia app called "APN Settings" which made it show up to edit. Edit then reboot and good to go.
    2009-06-24 08:03 AM
  9. wcushy's Avatar
    hi

    if anybody is interested, here are the settings for t-mobile in the UK for the Iphone on OS 3.0

    Cellular Data


    APN – general.t-mobile.uk
    Username - user
    Password - pass


    MMS

    APN – general.t-mobile.uk
    Username – t-mobile
    Password - tm
    MMSC – http://mmsc.t-mobile.co.uk:8002
    MMS Proxy – 149.254.201.135:8080
    MMS Max Message Size - 30000
    MMS UA Prof URL
    2009-06-24 12:23 PM
  10. gumby579's Avatar
    Anybody figure out anything for the incoming picture quality yet? I know there has to be some fix for it
    2009-06-24 04:45 PM
  11. ayala421's Avatar
    Anybody figure out anything for the incoming picture quality yet? I know there has to be some fix for it


    2x's on that....im sure theres a setting/fix for it.

    im trying to figure this out as well.
    2009-06-24 06:01 PM
  12. Oliver350Z's Avatar
    Can somebody please confirm if MMS works without having a Data Plan?

    Thanks...
    Housekeepin'?
    2009-06-24 07:01 PM
  13. fsdpmc's Avatar
    Hi my mms is not working on the above settings..... goes out about 90% amd than red ! appears......i checked 2 times setting these are the same as above....i am on 3G with OS3 JB with Ultrasnow......every thing works except the MMS......please help.....
    Cellular Data=
    APN: epc.tmobile.com
    Username:
    Password:

    Visual Voicemail=
    APN: wap.voicestream.com
    Username:
    Password:
    MMSC: 216.155.174.84/servlets/mms
    MMS Proxy 216.155.165.50:8080
    MMS Max Message Size:
    MMS UA Prof URL


    thanks
    2009-06-24 09:06 PM
  14. reynolds8481's Avatar
    I reset all network settings and re-entered them 3 times, nothing works. The SMS does of course, but I don't even have the camera in the SMS icon. anyhow, just wondering if something had changed since Ultrasnow came out.

    Also, T-Mobile game me these setting for non-branded t-Mobile phones. This info cam driectly from TMO

    Camera Phone Picture Messaging Settings
    Picture messaging is Multimedia Messaging Service (MMS) optimized for T-Mobile Wireless. Picture messaging service is pre-configured on devices sold by T-Mobile. To use this service, you must be a valid T-Mobile customer.
    NOTE: T-Mobile Customer Care provides minimal support for phones not sold by T-Mobile USA. The following settings are provided for configuring non-T-Mobile branded mobile phones for use with picture messaging services.
    T-Mobile provides an over-the-air Wireless Configurator that allows you to easily configure the most popular phones for use with t-zones®/web2goSM. To begin setting up your phone, access the Wireless Configurator.
    If you are unable to use the Wireless Configurator to configure your phone, you may enter the settings manually using the information provided below. These settings are specific to T-Mobile USA and will only work with an active T-Mobile USA account.
    T-Mobile picture messaging settings

    WAP GW IP Address: 216.155.165.050
    APN Name: wap.voicestream.com
    Messaging Server: http://mms.msg.eng.t-mobile.com/mms/wapenc
    Data Mode: Connection Oriented
    2009-06-24 09:51 PM
  15. i.Annie's Avatar
    Mms doesn't work without data plans. If the receiver doesn't have a data plan or is on an iPhone without 3.0 fw your mms will not go through. If the camera icon doesn't show up make sure you have restarted your phone by powering down then turning back on not respring.
    2009-06-24 10:30 PM
  16. BarcaMagic's Avatar
    Doesnt work for me. Never mind i got it to work .3g ultrasn0wed with tzones .
    Last edited by BarcaMagic; 2009-06-24 at 10:42 PM.
    2009-06-24 10:34 PM
  17. reynolds8481's Avatar
    I have 3.0 FW, and unlimited sms/data. I have restarted w/out using the respring. I will keep trying though, it has to be something I am doing wrong. Thanks!
    2009-06-24 10:40 PM
  18. i.Annie's Avatar
    Reynolds, what you posted are those the only settings you entered? Did you follow what this thread has listed or just what tmobile told you? Just am a little confused about your previous post. The apn, mmsc, and mms proxy must be filled out. None of the other stuff you mentioned such as the messaging server or wap gw ip is necessary.

    Oh yeah, and is your apn settings for SMS set on epc.tmobile.com?
    Last edited by i.Annie; 2009-06-24 at 10:51 PM. Reason: Automerged Doublepost
    2009-06-24 10:51 PM
  19. reynolds8481's Avatar
    Sorry, let me clear it up a bit. I did not use TMO settings, this is just what they gave me for it but I figured that it wouldn't work with the iphone, I just posted that to maybe help someone tweet existing work arounds. I followed the other directions presicely. More than once.

    I reset all of my network settings then powered down the phone and turned it back on. I didn't respring the phone though. After I powered it back up I put the settings in as outlined, not what tmobile game me but the original settings posted. I powered the phone back down and then when I turned it on I could send and received SMS but couldn't do anything with the MMS. The camera icon did not appear either.

    I am running 3.0 fw on the 3g w/ ultrasnow. I did have to use an ipcc to unlock though. I don't know if this canged something.
    2009-06-24 10:55 PM
  20. i.Annie's Avatar
    Have you tried some of the recommendations by a couple of the other users? Like tethering or removing your sim then reinserting?
    SiNfuL iPhone Forums

    There's a link for a guide on tethering. I'm not sure if this is very helpful... Sorry!

    I'm sorry the link is dead. Try googling for iPhone tether sinfuliphone.

    Are you using 3G iPhone?
    Last edited by i.Annie; 2009-06-24 at 11:39 PM. Reason: Automerged Doublepost
    2009-06-24 11:39 PM
148 12345 ...
LINK TO POST COPIED TO CLIPBOARD