1. Dampachi's Avatar
    Just what the title says, I have a 2G iphone with Tmobile and just upgraded to the newest OS 3.0 and noticed there is one issue with the new OS.

    First of all, I can make all outgoing calls no matter which area code I am in, but I can't seem to receive incoming from the area code I am currently in. For an example, I am currently located in Arizona and I cannot receive phone calls or text messages from any Arizona phone area codes. But I do have an out of state number though.

    Any suggestions on what is going on here?
    2009-06-24 08:08 AM
  2. ryan206's Avatar
    Have you put your SIM in another phone and tried making/receiving calls?

    If anything, do a fresh 3.0 install and redo the unlock/jailbreak.
    2009-06-24 08:39 AM
  3. Dampachi's Avatar
    Unfortunately, I do not have a spare phone I can test this on. I can make any outgoing call to any number, it's just recieving texts and phone calls from any Arizona number doesn't work.
    2009-06-24 08:54 AM
  4. delusion950's Avatar
    Do the factory restore,, custom restore, and unlocking and jailbreaking because with modem, you can never be right. Little things make big problems.
    2009-06-24 09:16 AM
  5. Dampachi's Avatar
    Do the factory restore,, custom restore, and unlocking and jailbreaking because with modem, you can never be right. Little things make big problems.
    Already did that twice, restored it back to Factory Iphone 3.0 software, but after I did a custom restore, I didn't have to jailbreak it because before I updated to the OS 3.0, I was running a VERY old 1.1.2 with a turbo sim. I am wondering if the turbo sim is causing the issue?
    2009-06-24 09:37 AM
  6. delusion950's Avatar
    No, you wouldn't be able to make any calls if it was turbo sim. What redsnow version are you using or you're using PWN? I read that people have problems with 7.2. I have 7.1 no problems but i use 3G. i had problems not getting the WI-FI TO WORK. Another thing, where are you getting your custom firmware from and PWN programs? I could provide you programs from, AUTOIPHONEUNLOCKER i use them to do my jailbreking and unlocking, and i could email them to ask them why arent you receiving phone calls they reply pretty fast. On their website it also says make sure you're running 8.2 before you begin jailbreaking and unlocking.

    HERE IS ANOTHER CLUE I GOT SEARCHING GOOGLE.

    ""So I figured it had something to do with the push (constantly polling) email and push notifications. It turns out that push is the reason I can't receive phone calls. (Turn push email/notification on, can't receive phone calls, turn push off, receive phone calls/texts)."""

    This is partial solution. Maybe not, there's a lot of updates to be done with 3.0, it's full of bug i hate it, that's why i went back to 2.2.1
    Last edited by delusion950; 2009-06-24 at 10:05 AM. Reason: Automerged Doublepost
    2009-06-24 10:05 AM
  7. Dampachi's Avatar
    No, you wouldn't be able to make any calls if it was turbo sim. What redsnow version are you using or you're using PWN? I read that people have problems with 7.2. I have 7.1 no problems but i use 3G. i had problems not getting the WI-FI TO WORK. Another thing, where are you getting your custom firmware from and PWN programs? I could provide you programs from, AUTOIPHONEUNLOCKER i use them to do my jailbreking and unlocking, and i could email them to ask them why arent you receiving phone calls they reply pretty fast. On their website it also says make sure you're running 8.2 before you begin jailbreaking and unlocking.

    HERE IS ANOTHER CLUE I GOT SEARCHING GOOGLE.

    ""So I figured it had something to do with the push (constantly polling) email and push notifications. It turns out that push is the reason I can't receive phone calls. (Turn push email/notification on, can't receive phone calls, turn push off, receive phone calls/texts)."""

    This is partial solution. Maybe not, there's a lot of updates to be done with 3.0, it's full of bug i hate it, that's why i went back to 2.2.1
    I never used redsnow. My custom package was through PWN. After I installed the custom package through PWN, it automatically found my service provider and all I did was restore from my backup.

    Intially I had issues with connecting to WIFI, but I was able to restore network settings and that fixed the issue.

    Anyone?

    Another issue I am encountering.

    When I receive incoming text messages, I can view it without a problem, but once I lock my iphone and I check my text messages again, the newest one I receive dissapears. This is getting retarded...

    So I actually used redsnow on my iphone and jailbroke and unlocked it that way, but my new text messages are still disappearing. I am wondering if this a OS 3.0 issue with tmobile? Anyone would like to chime in?
    Last edited by Dampachi; 2009-06-24 at 08:01 PM. Reason: Automerged Doublepost
    2009-06-24 08:01 PM
LINK TO POST COPIED TO CLIPBOARD