1. delusion950's Avatar
    Here is the T-ZONES HACK file that is not available through Cydia, but it is here for those who have old data $5.99. Also works with $9.99 plan. T-zones hack file included below.

    Let's Begin:

    !!!Important Step!!! (((Please Turn of your WIFI so you can test it out))

    ""This is Tested on 2.2.1"" you could try it on 3.0 I didn't test it on 3.0 because of the bugs they have with 3.0 Firmware
    (i dont guarantee anything). If you do let me know the outcome.

    1. SSH into your iphone and drag the tzones_2.deb file into the window where you have Library and Media.

    2. In the WinSCP, open Terminal Window and type in or copy paste(if it works)

    a. dpkg -i tzones_2.deb (Make Sure You Type It Correctly) click execute.

    3. After it comes to this Last Message in open terminal when you click execute
    ----""Setting up com.bigboss.tzones (2.0)"" ------

    Installation is complete.

    4. Close it out Reboot your iPhone!
    ((You can always remove T-Zones Hack through Cydia, Manage, Packages))

    5. After Reboot and Upgrade Subcription Required message in Safari;

    a. --Close Safari and go to Settings, General, Network, Cellular Data Network, and type in epc.tmobile.com
    (For people with $5.99 data they use this one in the present time).

    Also works with $9.99 data plan, setting for this is internet2.voicestream.com not epc.tmobile.com. Thank you

    T-Zones Hack File DOWNLOAD
    !!!File Will Start To Download Automatically From The Link"



    After you've done these steps am hoping you're Surfing the internet now. Thank you and I hope this helped.


    After I put internet2.voicestream.com in Cellular Data Netowork.
    Last edited by delusion950; 2009-07-01 at 06:15 AM.
    2009-06-30 07:02 AM
  2. studioab's Avatar
    iPhone 3G 2.2, T-Mobile US, web2go package $9.99

    APN: internet2.voicestream.com

    Everything was working until yesterday. In Safary I'm getting message http://wipcore.t-mobile.com

    To connect to internet with this device you need to upgrade your plan ... blablabla.

    I've put my SIM to NOKiA 8801 and wap internet was working good. In iPhone it doesn't work anymore.

    I did everything as describe. NO SUCCESS.

    Please help me to figure out this. Thank you.
    2009-07-01 07:10 AM
  3. delusion950's Avatar
    Let's see. Before you installed this T-Zones hack were you able to get online without it, IF YOU DID, you should uninstall it because you get the same speed and you would with T-Zones hack.

    Try this remove T-Zones hack from Cydia and reinstall this package again and see if you can get online. BUT, when you uninstall it, try to get online without this t-zones hack and see if you are able. IF YOU ARE ABLE, than don't install this t-zones hack as it interferes.

    If you are using $9.99 plan, you do not need this T-zones hack. I was on 2.2 with the $9.99 data plan I didn't need this T-Zones hack. Than I updated to 2.2.1 and I was still able to use internet without T-zones hack with this settings internet2.voicestream.com

    You can remove the T-Zones hack through Cydia, Reboot your iPhone and in Cellular Data Network type in internet2......... you know the rest.

    I tested speed with this t-zones hack and without it, i get the same speed.

    This is mostly intended for those with old data $5.99, but since after installing this T-zones hack on my 3G, and using internet2, i was still able to use the internet under the same internet2 setting.

    Let me know how did you make out with things. Thank you
    2009-07-01 08:29 AM
  4. studioab's Avatar
    Thank you for fast reply.

    Here is the story.

    I was using EDGE internet (web2go $9.99) since Nov 2008 without T-Zone hacks. Few times I did change the APN address. The last working address was internet2.voicestream.com

    I didn't change any settings or so. Didn't upgrade to 3.0, yet.

    Yesterday when I tried to open web-site I was redirected to http://wipcore.t-mobile.com

    I still have EDGE data IP address on my iPhone.

    Looks like they're blocking me from internet by checking my IMEI code because I can get wap internet to work from my old NOKIA 8800.

    Any help will be very appreciated.

    P.S. Do you still have EDGE internet on your T-mobile iPhone?
    2009-07-01 08:42 AM
  5. delusion950's Avatar
    You're welcome.

    Don't upgrade to 3.o until they fix all the bugs. i plan on remaining on on 2.2.1 as it works great.

    CLEAR YOUR HISTORY in Safari, AND CLEAR INTERNET2.VOICESTREAM.COM from cellular data network. !!Reboot your iPhone!!. Open safari and just type in Google. If you get no cellular data network, go there and try to input epc.tmobile.com and go to Safari and try Google again if that doesnt work, which is wont, type in internet2..... and see what it does.

    Here is three pictures to show you that am able to use internet2. and when google is loading check the loading circle next to Edge that is loading and it's loading google.com. It's working without any problem.

    The problem you're having is very weird. It worked great until yesterday hmmmmm now it wont.

    You said you didn't change setting? you mean you didn't install t-zones hack or?? so you are just using plain setting with setting in cellular data network as internet2.

    Am not clear on, did you try t-zones hack that i put up on this blog? what exactly did you do?


    Are you prepaid tmobile user by any chance?
    Last edited by delusion950; 2009-07-01 at 09:42 AM. Reason: Automerged Doublepost
    2009-07-01 09:35 AM
  6. Oliver350Z's Avatar

    The problem you're having is very weird. It worked great until yesterday hmmmmm now it wont.

    No, it's not weird.
    I have seen reports from other people here at MMI with same issue.

    I am assuming that T-Mobile is beginning to block those WebPlans from being used on an iPhone, thus forcing us to upgrade our plans and pay more for basically the same service.

    How do they determine who to block?
    - Is it because you made a call to Customer Service using your iPhone (or had your SIM on one at the time)?
    - Is it because you are a heavy data user on a plan that is supposed to work on cheap phones? (Above 100MB I'd say)
    - Is it by Zone / Region / Area Code / State?
    - Is it random?

    Those are the key questions...

    I just try to stay on the "down low" to be safe, I avoid calling Customer Service with the SIM on my iPhone... and use EDGE only as necessary (Pandora + i<3Radio + App Downloads are a NO-NO).
    2009-07-01 05:53 PM
  7. studioab's Avatar
    I didn't change any settings until I lost my connection two days ago. After that I tried few other APN addresses, rebooting, clearing cach/history/coockies etc. Keep in mind I was able to get wap internet with this SIM card on my old Nokia phone.

    Than I found your post and I DID instal t-zone hack 2. Before that I didn't any t-zone hacks. No success.

    I did uninstall t-zone hack2 I followed up your step - doesn't work. I'm always getting warning redirect page from t-mobile (gmail, weather etc. don't work at all). My wap internet card still working in Nokia Phone.

    It seems that t-mobile somehow can get my IMEI code and block iPhone from internet. I'm sure I have connection but any web addresses rederecting to t-mobile warning page.

    Please help. Thank you.

    - Is it because you made a call to Customer Service using your iPhone (or had your SIM on one at the time)?

    I've never called to t-mobile rep even from iPhone.

    - Is it because you are a heavy data user on a plan that is supposed to work on cheap phones? (Above 100MB I'd say)

    I'm checking e-mail and using google maps.

    - Is it by Zone / Region / Area Code / State?

    Don't think so. I'm in Seattle, WA.

    - Is it random?

    No. I've no connection for two days at all.

    MAIN POINT !!! I DO HAVE INTERNET CONNECTION WITH THIS SIM ON MY OLD NOKIA. It means that I still have web2go availaible.
    Last edited by studioab; 2009-07-01 at 06:33 PM. Reason: Automerged Doublepost
    2009-07-01 06:33 PM
  8. delusion950's Avatar
    am looking into this. i read other people have the same issue am looking to see if there's a way to change the IMEI.
    2009-07-01 11:11 PM
  9. Oliver350Z's Avatar
    studioab, when I mentioned those questions I was not implying that you had done any of them.

    I was just wondering what is the criteria for T-Mobile to suddenly block an IMEI number from using web2go, as this is not a Nation-wide block... only a few people so far complained about losing their ability to use web2go with iPhone.

    It is still a mistery.

    By the way, have you tried "RESET NETWORK SETTINGS"?
    2009-07-01 11:44 PM
  10. studioab's Avatar
    Reset - didn't help at all. I've put internet2. ... and still getting redirect page from t-mobile. WIERD !!! I have ASUS phone with WinMo on board. It gives me the same redirecting page "You plan shold be upgraded". I've never put this SIM in ASUS before and I opened the network settings pane and WTF there are three web addreses stored on my SIM:

    wap.voicestream.com (default)

    I used all. Is there any way how to clear EDGE settings from my SIM?

    It 100% works in old NOKIA.

    Any Ideas?
    2009-07-02 12:11 AM
  11. delusion950's Avatar
    Since Resetting your Network Setting from General, Reset don't work, your iphone is bugging somewhere.

    If it works fine with your Nokia, than your iphone is bugging somewhere. Why don't you upgrade your iphone to 2.2.1? What iphone do you have 2G or 3G?
    I upgraded my 3G from 2.2 to 2.2.1 and downgrade your baseband with progz they have in Cydia if you can, if you can't dont touch anything. Just restore your iphone again with 2.2 give it a fresh start back it up before you restore it.

    I really have no idea, last night was actually first night i heard of such problem. i read also that people with G1 had the same problem and they're on T-MOBILE plan that they are suppose to be on. NOW THAT I DONT UNDERSTAND having their plan for G1 and still internet blocks out. Restore your iphone and see what happens.
    2009-07-02 01:06 AM
  12. studioab's Avatar
    As you mentioned - I did upgrade to 2.2.1, install yellosn0w. Put internet2.voicestream.com and get the same page redirect They're 100% blocking me somehow !!! Sim card works in old Nokia.

    My phone 3G/8g almost 1 year old. Modem 2.28

    Any ideas?

    I've been in T-mobile store and ask to replace my "lost" sim card They replaced it. Everything is WORKING !!! I've got working EDGE internet.

    Thank you!!!

    I've been in T-mobile store and ask to replace my "lost" sim card They replaced it. Everything is WORKING !!! I've got working EDGE internet.

    Thank you!!!
    Last edited by studioab; 2009-07-02 at 09:53 AM. Reason: Automerged Doublepost
    2009-07-02 09:53 AM
  13. mod_monkey's Avatar
    SWEET 5.99
    thanks work for me. After reboot I just added epc.tmobile.com as apn
    2009-07-02 12:19 PM
  14. delusion950's Avatar
    glad it helped
    2009-07-03 03:54 AM
  15. crouching's Avatar
    I'm a heavy data user and never had my service blocked or what not

    2009-07-04 02:08 PM
  16. delusion950's Avatar
    ir lucky as i mentioned before and now it's amazing every iphone user has different experience. i had no problems with my internet yet but some people without it for days. the other 2 ppl on managed to fix it.
    2009-07-04 05:24 PM
  17. dave868's Avatar
    I am in t-zones jail. I can only get to t-mobile sites and sites linked to from the t-zones homepage. If I try to goto another site, say yahoo or google, I get a redirect back to my t-zones homepage.

    Tried this patch, but no change.

    I assume that I am being blocked. Is there anything I can do?
    2009-07-17 06:24 AM