1. pldtboy's Avatar
    what about just on 4.0 i've been trying to read the forum but its like 113 pgs....i can't install the commcenter patch cause thats only for 4.0.1 and i can't updrade to 4.0.1 only to 4.0.2 cause apples signature thing.

    iphone 4 on 4.0 trying to get mms
    Does anybody have a solution for this? I'm in the same boat
    and can't upgrade to 4.0.1.Please help us..Thanks.
    2010-09-13 06:16 PM
  2. BigErn's Avatar
    I finally got mine working but it came through a method nobody has posted. I installed the commcenter patch, flashed spooky ET's bundle, which made tethering work but not mms. I then pulled my sim, and reinserted so that i would have access to the apn editing. From there i sshed into the phone and uploaded an edited plist for mms. MMS works, tethering doesn't...seems iphone 4 users can't have everything at the same time at this point.
    I detailed in my post a couple pages back how I got the Iphone 4 bundle installed enabling Tethering and with MMS working at the same time.
    2010-09-14 03:05 AM
  3. ThaNatrix's Avatar
    At this point I'm just frustrated...the fix I did earlier stopped working, I tried BigErns method as well...no commcenter patch, mms fix, or bundle combo solves the issue permanently. What's the deal?
    2010-09-14 06:46 AM
  4. F3nom3ni's Avatar
    Yeah man I'm in the same boat. Mine works 40% of the time.

    I'm getting to the point where I'm about to just switch to AT&T to have everything work like it should all the time.
    2010-09-14 04:28 PM
  5. SpookyET's Avatar
    I see a lot of frustrated iPhone 4 users. The bundles only provide settings. Thatís it. If MMS stops working forcing you to remove the SIM card or restart your phone, that has nothing to do with the bundles. Either Cydia crapware is interfering or there is something wrong with the CommCenter patch, ultrasn0w, or a combination of both. There are very few differences between the iOS3 and iOS4 bundles. Itís not the bundles that cause problems.

    You should never restore from backup, ever. Always set it up as a new phone.
    2010-09-15 04:42 AM
  6. gilbreen's Avatar
    iPhone Model: iPhone 4
    Carrier Bundle Used: T-Mobile US - T-Zones
    Voice Plan: Family Plan 1000
    Data Plan: T-Zones $5.99
    SMS: $9.99 Family Unlimited
    Time with T-Mobile: 7 years
    Last Plan Change: 11 months ago
    Problem: MMS will only work after a reboot after I eject and reinsert the SIM card. I have tried three different SIM cards. Have to agree with SpookyET that the issue lies elsewhere (CommCenter patch, ultrasn0w, etc.) and not with the bundles.

    I don't have a Cellular Data tab so not sure what the settings are nor do I think it really matters since data, SMS and MMS are all working.

    Happy to have it working even if it means ejecting the SIM card once and a while. Just adding another data point.
    2010-09-16 12:29 AM
  7. SpookyET's Avatar
    Missing Cellular Data Network menu is by design. If there were something wrong with the bundles, more than MMS would stop working. Does Internet and tethering still work? If yes, the problem is elsewhere. It's possible that MMS.app is crashing partially or completely; then when it restarts, it fails to read the settings from the bundle and reverts to default.

    Those wondering why I have not updated the first post with iPhone 4 instructions should read the last few posts; it will become apparent.
    Last edited by SpookyET; 2010-09-16 at 03:27 AM. Reason: Automerged Doublepost
    2010-09-16 03:27 AM
  8. gilbreen's Avatar
    Missing Cellular Data Network menu is by design. If there were something wrong with the bundles, more than MMS would stop working. Does Internet and tethering still work? If yes, the problem is elsewhere. It's possible that MMS.app is crashing partially or completely; then when it restarts, it fails to read the settings from the bundle and reverts to default.

    Those wondering why I have not updated the first post with iPhone 4 instructions should read the last few posts; it will become apparent.
    Internet is working but I have never used the tethering option since I only have EDGE speeds with T-Mobile. It is only MMS that doesn't work properly after a reboot until the SIM card is ejected and re-inserted.
    2010-09-16 09:02 AM
  9. SpookyET's Avatar
    I have added OMG! Simple Mobile carrier bundles to the first post. Simple Mobile is mobile virtual network operator (MVNO) using the T-Mobile network.
    2010-09-20 02:36 AM
  10. k1653d's Avatar
    Care to take a stab at h2o?

    https://www.h2owirelessnow.com/pageC...php?page=index

    You would be the first if you are able to get it to work.
    2010-09-21 03:15 AM
  11. SpookyET's Avatar
    Care to take a stab at h2o?

    https://www.h2owirelessnow.com/pageC...php?page=index

    You would be the first if you are able to get it to work.
    That's an AT&T based MVNO, and since AT&T's network is rubbish, they don't seem to allow MVNOs access to DATA/MMS, at least that one doesn't have the capability.

    I can do bundles for any carrier for a fee. It takes time to do it properly, and time is money.
    2010-09-21 03:41 AM
  12. nchall's Avatar
    I am tying to install the 2G Enable MMS etc. from Cydia on 3.1.3, but Cydia won't let me because it says 3.1.2 is a required dependency. Any ideas?
    2010-09-21 09:06 AM
  13. kmmxracer's Avatar
    iPhone Model: iPhone 4, 4.0.1
    Carrier Bundle Used: Simple Mobile-US 1.1.0
    Voice Plan: Pre Paid $50
    Data Plan: 100mb
    SMS: Unlimited Messages
    Time with Simple Mobile: 2 Days
    Last Plan Change: N/A
    Problem: I can send MMS just fine but can not receive MMS at all. Text and voice work fine. I have not tried teathering yet.
    Last edited by kmmxracer; 2010-09-22 at 10:23 AM.
    2010-09-22 10:19 AM
  14. greek.guy's Avatar
    I am tying to install the 2G Enable MMS etc. from Cydia on 3.1.3, but Cydia won't let me because it says 3.1.2 is a required dependency. Any ideas?
    Your answer is in your question,
    it needs firmware 3.1.2 to work and your running 3.1.3
    2010-09-22 05:31 PM
  15. nchall's Avatar
    I've reverted back to 3.1.2 and installed the "2G Enable MMS, Tethering, All Bluetooth Profiles" and everything works great, except I am not able to use AVRCP. Is this because it is not present in iOS 3.1.2 or has it been backported?

    Your answer is in your question,
    it needs firmware 3.1.2 to work and your running 3.1.3
    Actually on the front page it says 3.1.2/3.1.3:

    WARNING: A jailbroken iPhone 2G running 3.1.2/3.1.3 is required. You also have to have a clean CommCenter (i.e. if you already have an MMS patch installed, get rid of it) and a clean BTServer (i.e. if you already have A2DP Enabler, get rid of it).
    Last edited by nchall; 2010-09-22 at 05:54 PM. Reason: Automerged Doublepost
    2010-09-22 05:54 PM
  16. SpookyET's Avatar
    Updated Simple Mobile Bundles to version iOS3 1.0.1 and iOS4 1.1.1.
    Changelog:
    * Added localisation for English, British English, French, Spanish, Portuguese, Brazillian Portuguese, German, Italian, Arabic, Hebrew, Romanian.
    * Fixed logo.
    2010-09-24 06:34 AM
  17. theappaddicted's Avatar
    iPhone Model: 3G
    Carrier Bundle Used: none yet
    Voice Plan: Family 100
    Data Plan: T-Mobile Andriod Unlimited Web + Unlimited messaging
    Time with T-Mobile: 5 yrs
    Last Plan Change: 1 yr
    Problem: Not sure which bundle matches this plan. This is my daugther phone. She recently aquired this 3g. She changed from the G1. The 3g is JB with redsnow and unlocked with ultrasnow.

    Could any one let me know which bundle matches this plan, she driving me crazy for getting her mms back. Thnaks
    2010-09-25 06:07 AM
  18. kmmxracer's Avatar
    Updated Simple Mobile Bundles to version iOS3 1.0.1 and iOS4 1.1.1.
    Changelog:
    * Added localisation for English, British English, French, Spanish, Portuguese, Brazillian Portuguese, German, Italian, Arabic, Hebrew, Romanian.
    * Fixed logo.
    Does this update help with MMS receiving??
    2010-09-25 06:13 AM
  19. SpookyET's Avatar
    iPhone Model: 3G
    Carrier Bundle Used: none yet
    Voice Plan: Family 100
    Data Plan: T-Mobile Andriod Unlimited Web + Unlimited messaging
    Time with T-Mobile: 5 yrs
    Last Plan Change: 1 yr
    Problem: Not sure which bundle matches this plan. This is my daugther phone. She recently aquired this 3g. She changed from the G1. The 3g is JB with redsnow and unlocked with ultrasnow.

    Could any one let me know which bundle matches this plan, she driving me crazy for getting her mms back. Thnaks
    Try standard or legacy, whichever works.

    Does this update help with MMS receiving??
    Those updates are for Simple Mobile, not T-Mobile. What's wrong with your MMS?
    Last edited by SpookyET; 2010-09-25 at 06:50 AM. Reason: Automerged Doublepost
    2010-09-25 06:50 AM
  20. kmmxracer's Avatar
    I know they are for Simple Mobile. I posted my problem and set up on post #1713. I'm on Simple Mobile and I can send MMS just fine but I problems receiving them.

    At first I installed your ipcc and I could not receive MMS at all. Then I found a weird source for Cydia that has a "beta fix" for the issue and I receive MMS at random times. Like hours later.
    2010-09-25 06:57 AM
2,044 ... 3676848586878896 ...
LINK TO POST COPIED TO CLIPBOARD