1. dkhockey5's Avatar
    alright, so push works great. tested over and over again with IM+.

    i did a step by step test to try and narrow down the problem. here it is:

    1) sent myself an IM w/ wifi/edge on (PUSH WORKS)
    2) w/ wifi/edge on while using another app (PUSH WORKS)
    3) hit sleep/wake button to simulate me putting it in my pocket (PUSH DOES NOT WORK)
    4) hit sleep/wake button to wake it up, wait for wifi icon to pop up, send IM (PUSH WORKS)

    ...so clearly push works when wifi is active

    5) disabled wifi, left edge on.
    6) used SBsettings to verify that i have an edge ip connection
    7) send myself an IM w/ edge on (PUSH WORKS)
    8) hit sleep/wake button, sent IM (PUSH DOES NOT WORK)
    9) hit sleep/wake button to wake it up, w/o checking SBsettings for edge ip address, sent IM (PUSH DOES NOT WORK)

    ...it appears that my edge connection is "timing-out" after less than a minute of inactivity. how the heck is push supposed to work when i'm out in the world and not constantly "stimulating" my edge connection to stay active?

    does anyone know how to change edge time-out times? (perhaps set to "never")
    2009-07-06 05:53 PM
  2. Du Blex's Avatar
    yeah the same is happening to me sometimes... i think it has to do with the files provided to fix the push notification issue. Its probably modified to someone's phone and now we're using their settings or something. No idea. Hopefully the Dev-Team will have it all sorted out by the time 3.1 is released...
    ALL THEY DO IS DRINK, SMOKE DOPE, AND TELL JOKES TO THE OLD FOLKS
    2009-07-07 03:43 AM
  3. m600i's Avatar
    I have the same problem, doesn't work in standby which is totally pointless. All that does it let you get push as you're working on your phone but not actually in the app. Once it's in your pocket, no more push. I was so happy when I thought it was working correctly...
    2009-07-07 07:31 PM
  4. CoasterFuelPhil's Avatar
    yep, i've just noticed this is happening too. I thought it was working when I had it docked to charge, but when I took it off the dock it stops working
    2009-07-07 11:32 PM
  5. SuperflyJimmy's Avatar
    Is there a way to test the Push w/o having to pay for one of the IM programs?
    2009-07-08 02:13 AM
  6. westc0ast's Avatar
    wow your right .man that sux
    All information contained in my post came to me in a dream. I don't even own an iphone.
    Don't forget to hit the thanks button
    2009-07-08 02:15 AM
  7. CoasterFuelPhil's Avatar
    Is there a way to test the Push w/o having to pay for one of the IM programs?

    You can use AIM's free program, that has push as well
    2009-07-08 03:22 AM
  8. m600i's Avatar
    yep, i've just noticed this is happening too. I thought it was working when I had it docked to charge, but when I took it off the dock it stops working
    I have that exact symptom too, it was working on the dock (iHome) and off the dock in standby it does not work And when push doesn't work I just toggle the push notifcations off then on and they start working again, but again not in standby
    2009-07-08 05:37 PM
  9. dkhockey5's Avatar
    yup.. hooray for redsn0w jailbreaking/unlocking my iphone so i can play with OS 3.0 so quickly. But i'll take QuickPWN any day. when all else fails.. trust the name brands!

    any ideas when the official quickpwn is supposed to come out?
    2009-07-10 10:57 PM
  10. Decon Meiou's Avatar
    So this is a thread about push not working all the time and you decide it is a good idea to post about redsnow and quickpwn.

    Awesome.

    ON TOPIC I am experiencing the same problems as above. I've been trying to get info on how push is working for legit users but alas.
    2009-07-11 02:36 AM
  11. CoasterFuelPhil's Avatar
    Today I got one finally, phone wasn't in use or anything before hand and it just popped up. Only happened once though, the next message never got pushed. Have no idea why its doing it
    2009-07-11 05:04 AM
  12. danextbanks's Avatar
    Today I got one finally, phone wasn't in use or anything before hand and it just popped up. Only happened once though, the next message never got pushed. Have no idea why its doing it
    same here...i probably got a total of three notification and one incorrect notification from a different screen name on beejive since installing the push fix last week..i hope they get this fix soon
    2009-07-11 05:27 AM
  13. dkhockey5's Avatar
    i solved the problem.. took a lot of work and a couple weeks..

    ...

    ...

    ...

    ...

    I BOUGHT A 3GS!!!

    ..boy push is awfully useful
    2009-07-20 05:53 PM
  14. Pcpro745's Avatar
    i have it working on my phone no problem, but i activated my phone with a att sim not the dev team way. How did you guys get push activated?
    2009-07-20 06:12 PM
  15. lunercrab's Avatar
    yeah same here i tried the cydia way, i tried the manual way...nothing...i bought a unactivated att sim off ebay for like 3 bucks, activated my phone properly before i unlocked and push has been working perfectly ever since (at least with im+)...
    2009-07-21 03:54 AM
  16. jasonm253's Avatar
    what i did was restore my phone..popped in an ATT sim and did the whole process of rejail breakin..it was already unlocked..then instaldl the push fix and it worked!
    2009-07-22 02:11 AM
  17. LosoLx's Avatar
    The best way to get push working on a unlock iphone is to just redo the jailbreaking process and use a att sim card when activating..Then just go to cydia and download the ultrasn0w unlock....

    thats how i had fix my push.. working with some apps (beejive, im+,aim,boxcar) those the only apps i had test it out with that use push and it works
    Current Using: iPhone 3G 16GB White
    Firmware: 3.0
    Jailbreak: Pwnage Tool


    2009-07-24 10:11 PM
LINK TO POST COPIED TO CLIPBOARD