1. defmute's Avatar
    Here is the problem.
    -internet: Works
    -SMS Send: Works
    -SMS receive: Works
    -MMS receive: Works
    -MMS Send: ERROR. Gets to 90% and eventually times out.


    Ok i have
    -T-Mobile
    -Tzones 5.99 plan (everything works)
    -iphone 3g (fm: 3.0.1)
    -Jailbroken: you betcha
    -Unlocked: **** yeah it is
    -Settings:
    (Current)
    Cellular Data
    APN: epc.tmobile.com
    MMS
    APN: epc.tmobile.com
    Username: {BLANK}
    Password: {BLANK}
    MMSC: mms.msg.eng.t-mobile.com/mms/wapenc
    MMS proxy: {BLANK}
    MMS Max Message size: {BLANK}
    MMS UA Prof URL: {BLANK}

    Previous:
    APN: wap.voicestream.com
    username: blank
    password:blank
    MMSC:216.155.174.84/servlets/mms
    MMS Proxy: 216.155.165.50:8080
    the rest is blank

    I have tried other combinations and nothing seems to work that will allow me to send MMS's. I have even called them and had them drop me off the network and reconnect. Nothing. I can take my sim out and put it in another phone and there isn't a problem so I think it has to be a setting.

    I can't seem to find a definitive answer, Do you have similar settings as above (Mainly the T-Mo thing and t-zones) and have the ability to SEND MMS's?

    If so, what the hell am I doing wrong. Much help and lots of love,
    Grandma....wait....defmute.
    2009-10-05 03:43 AM
  2. ebl4287's Avatar
    Make sure the settings are correct.. If it still doesn't work, your best bet is to call tmobile. If you explain to them you have a iPhone with MMS problems, they will be happy to help you out and will transfer you to tmobile's iPhone department :-)
    2009-10-05 04:27 AM
  3. battlecrushr's Avatar
    How do u have the 599 plan on tmobile?
    2009-10-05 04:31 AM
  4. defmute's Avatar
    I actually did call T-Mobile and spent quite some time on the line with them with trying different settings. I am quite sure the settings are correct as everything else works and I have typed and retyped them over and over.

    5.99 t-zones plan: I have had it since a few months after the original iPhone came out. Everytime they tell me that I need to upgrade or it is unsupported I blatantly tell them it works fine for me as all I use it for is email and I plan on keeping it.
    2009-10-05 05:37 AM
  5. battlecrushr's Avatar
    Nice I have 3.1 but my mms doesn't work too so I think it's the firmware cause on 3.0 and 3.0.1 it worked for me
    2009-10-05 04:55 PM
  6. defmute's Avatar
    You could send mms?
    2009-10-05 06:43 PM
  7. battlecrushr's Avatar
    Ya I could on 3.0(.1) using the t-mobile postpaid in cydia from the mmi
    repo
    2009-10-05 09:23 PM
  8. steve-z17's Avatar
    I'm with the T on the 5.99 and my MMS is working great. I did that update thing through iTunes with the T-Mobile_US.ipcc and it started working! Here's the sticky. Hope it starts working!
    2009-10-05 10:49 PM
  9. battlecrushr's Avatar
    Steve are you on 3.1 firmware?
    2009-10-05 10:58 PM
  10. steve-z17's Avatar
    Steve are you on 3.1 firmware?
    Yes sir!
    2009-10-05 11:04 PM
  11. battlecrushr's Avatar
    Ok thx I'll try that
    2009-10-05 11:39 PM
  12. Mes's Avatar
    I'm on a 3Gw/3.0.1 (t-mo - $19.99/mo plan).

    MMS works using wap.voicestream.com (but tethering does not)
    Tethering works using internet2.voicestream.com (but MMS does not)
    (changes occur only in Settings/General/Network/Cellular Data Network/MMS APN)

    Crazy ... must change between the two and reboot.
    2009-10-05 11:45 PM
LINK TO POST COPIED TO CLIPBOARD