1. merllen's Avatar
    Hey Everyone having problem with the settings field showing under cellular data I just found a solution ,

    Do the following on Iphone open Safari and go to this site type in help.benm.at

    Then scroll down to bottom page select tethering and select country then select tmobile

    Reboot phone . All the settings for cellular data network , mms and tethering will now show.

    I have not put in actually settings yet to confirm mms working but can confirm settings will show and this does work.
    2010-06-24 01:11 AM
  2. gavakie's Avatar
    I was able to get the settings up by installing supreme prefs. Internet is working on edge.
    2010-06-24 01:23 AM
  3. xdviper's Avatar
    Merllen, I tried that, the phone gives me a error and won't install the profiles. I've tried making my own and tmobile one. Argh
    2010-06-24 02:01 AM
  4. jasonxoc's Avatar
    Gavaki: is that in cydia??
    --- Answered my own question... I tried to install that and it gave an error that says the iphone firmware < 3.0 ... So unless they have a source that gives updated apps that are in dev or beta... thats a no go.

    And i got safari could not install a profile due to an unknown error. when trying to do the help.benm.at solution

    so that sucks.

    And now that imhome I can put more focus into the problem. I had to ssh into the phone via my iPad and that's about as productive as pi$sing into a fan so I'll update soon
    Last edited by jasonxoc; 2010-06-24 at 03:50 AM. Reason: -
    2010-06-24 03:31 AM
  5. vimm's Avatar
    When I go to General, Settings, Network, All I see is

    Enable 3G (on/off)
    Cellular Data (on/off)
    Data Roaming (on/off
    VPN Not Connected
    Wi-Fi TCC> (TCC is my wifi lol)

    There is NO area I can go to put in the APN information etc.
    try to put sim card in maybe you will see apn.
    2010-06-24 03:50 AM
  6. 95bb2's Avatar
    Hey Everyone having problem with the settings field showing under cellular data I just found a solution ,

    Do the following on Iphone open Safari and go to this site type in help.benm.at

    Then scroll down to bottom page select tethering and select country then select tmobile

    Reboot phone . All the settings for cellular data network , mms and tethering will now show.

    I have not put in actually settings yet to confirm mms working but can confirm settings will show and this does work.
    Didn't work for me.
    2010-06-24 03:51 AM
  7. co-D's Avatar
    /first post/

    I experienced the same problem listed throughout this thread... no cellular data tab after restoring to iOS4 and unlocking via Ultrasnow. I have found a combination of multiple suggestions listed throughout this thread that have (seemingly) resolved this error on my 3G:

    Full restore in iTunes (set up as new phone)

    Jailbreak utilizing redsn0w_win_0.9.5b5-3 (instead of b5-4) and iPhone1,2_4.0_8A293_Restore.ipsw

    Establish wifi connection and navigate to help.BenM.at | BENM.AT and install US T-Mobile profile. NOTE: Utilizing b5-4 to jailbreak and/or attempting T-Mobile carrier bundles via Cydia prior to this step caused this install to fail (Unknown Safari error).

    Rebooted, and voila... the Cellular Data tab was restored! I then entered the Postpaid/Flexpaid T-Mobile APN settings. It's important to note that all of this was done prior to accessing Cydia and running Ultrasnow. Additionally, I too experienced the white Cydia icon after jailbreaking with b5-3 (this did NOT happen with b5-4), but once I allowed Cydia to load packages and changes, the icon was restored.

    Lastly, I ran Ultrasnow to obtain my T-Mobile carrier unlock. MMS appears (at least partially) functional and cellular data has been confirmed.

    I hope this helps some of you. Best of luck.
    2010-06-24 04:09 AM
  8. xdviper's Avatar
    /first post/

    I experienced the same problem listed throughout this thread... no cellular data tab after restoring to iOS4 and unlocking via Ultrasnow. I have found a combination of multiple suggestions listed throughout this thread that have (seemingly) resolved this error on my 3G:

    Full restore in iTunes (set up as new phone)

    Jailbreak utilizing redsn0w_win_0.9.5b5-3 (instead of b5-4) and iPhone1,2_4.0_8A293_Restore.ipsw

    Establish wifi connection and navigate to help.BenM.at | BENM.AT and install US T-Mobile profile. NOTE: Utilizing b5-4 to jailbreak and/or attempting T-Mobile carrier bundles via Cydia prior to this step caused this install to fail (Unknown Safari error).

    Rebooted, and voila... the Cellular Data tab was restored! I then entered the Postpaid/Flexpaid T-Mobile APN settings. It's important to note that all of this was done prior to accessing Cydia and running Ultrasnow. Additionally, I too experienced the white Cydia icon after jailbreaking with b5-3 (this did NOT happen with b5-4), but once I allowed Cydia to load packages and changes, the icon was restored.

    Lastly, I ran Ultrasnow to obtain my T-Mobile carrier unlock. MMS appears (at least partially) functional and cellular data has been confirmed.

    I hope this helps some of you. Best of luck.
    The verison of redsn0w you used, fuckes up iBooks, and I don't want to use that because I use iBook app. The new redsnow app does fix it, but also takes away the celluar data tab.

    The one you used redsnow, doesnt take away the celluar data tab. aerghhh

    Thank god for optimum wifi in my neighborhood, i can use wifi for free.
    2010-06-24 04:27 AM
  9. pgergen's Avatar
    I had the same problem, but I found a solution.

    Restored to iOS 4 in iTunes.
    Used Redsn0w 0.9.5b5-3 to jailbreak (brings up cellular data tab)
    Used Ultrasn0w to unlock
    Added Cellular Data Network Settings in iPhone (internet on edge works!)
    Used Redsn0w 0.9.5b5-4 (to fix iBook app!)
    Reset Network Settings (to make camera icon appear in messages)

    It worked for me!

    For some reason I could add my network settings after using Redsn0w 0.9.5b5-3...not when I used 0.9.5b5-4. That's why I did it the way I did it.. And everything works
    2010-06-24 04:31 AM
  10. xdviper's Avatar
    When you used b5-4, after using b5-3, is the celluar settings tab still there?

    If anything, if anyone cares to wait, and doesn't mind rejailbreaking, sn0wbreeze will come out tonight, and they can jailbreak their iDevices tonight. I'll be trying it out with that.
    Last edited by xdviper; 2010-06-24 at 04:35 AM. Reason: Automerged Doublepost
    2010-06-24 04:35 AM
  11. 95bb2's Avatar
    The tab did come back, but now every time i receive a picture text it gives me a message instead of showing the picture.
    2010-06-24 04:36 AM
  12. totoro1437's Avatar
    Hello
    I have the similar problem.
    I jailbreak and unlocked my iphone 3g.
    I was trying setup the tmobile APN.
    When I went to network--> cellular data, i only see on/off buttom.

    Any idea???? How can I setup the APN??

    Thankyou so much
    2010-06-24 04:51 AM
  13. pgergen's Avatar
    When you used b5-4, after using b5-3, is the celluar settings tab still there?

    If anything, if anyone cares to wait, and doesn't mind rejailbreaking, sn0wbreeze will come out tonight, and they can jailbreak their iDevices tonight. I'll be trying it out with that.
    Yup, the tab was still there. That's why I used b5-3 first, then b5-4 to fix iBooks.
    2010-06-24 04:54 AM
  14. gavakie's Avatar
    Sorry should have been more specific. I added cydia.************* and used that version of supreme preferences.

    I guess it won't let me add the source, pm me And I'll send it.
    Last edited by gavakie; 2010-06-24 at 05:11 AM. Reason: Automerged Doublepost
    2010-06-24 05:11 AM
  15. mrguyname's Avatar
    anyone find a fix for this yet?
    2010-06-24 05:16 AM
  16. curtisdesigngroup's Avatar
    I've now jail broken 3 3G phones today and there is no where to input celular data on any of the 3 of them. I am using RedSnow and have to agree with Varmit none of the above solutions work. I am moving on to my personal 3GS in a moment and I am now nervous to see what problems I am going to encounter there.
    2010-06-24 05:44 AM
  17. hien331's Avatar
    I also had the problem with no cellular data tab when using redsnow b5-4. But when I restore using itune, used redsnow b5-3 it worked. Well I waited until cydia is fully updated then cydia restored. After that I installed ultrasn0w them the cellular tab came. Hope this work for you guys!
    2010-06-24 05:49 AM
  18. mrguyname's Avatar
    does anyone have the link to redsnow b5-3 download?
    2010-06-24 05:56 AM
  19. 95bb2's Avatar
    so what settings did you use?
    2010-06-24 05:58 AM
  20. hien331's Avatar
    for cellular data i use internet2.voicestream.com. i havent test the mms yet.
    2010-06-24 06:06 AM
75 1234
LINK TO POST COPIED TO CLIPBOARD