1. notphonesavy's Avatar
    Ok I Unlocked And Jailbroke my iphone 3g to 4.0. The problem I am having is i cannot use internet unless im using wifi I read alot of the post here before i decided to post.

    As you can see what my username is i am not phone savy at all it took me almost 4 hrs after the release to even unlock it lol

    i really would appreciate if someone could lead me in the right direction thanks!
    2010-06-23 06:48 PM
  2. adp's Avatar
    Do you have a data plan?
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-23 07:10 PM
  3. babyblue_pimp's Avatar
    lol

    no worries man, you have to start somewhere

    but basically you have to enter your APN. go to settings-general-network-cellular data network

    and add
    epc.tmobile.com to the cellular data apn.

    If that doesn't work, try
    internet2.voicestream.com
    wap.voicestream.com
    internet3.voicestream.com
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!
    2010-06-23 07:11 PM
  4. notphonesavy's Avatar
    Do you have a data plan?
    yes i had a g1 before i bought this lovely phone lol i saw some post about downgrading to t-zones or something but tmobile doesnt off it anymore and i saw where you guys said dont let them know u have iphone so i left it alone and joined the forum before i did something stupid

    lol

    no worries man, you have to start somewhere

    but basically you have to enter your APN. go to settings-general-network-cellular data network

    and add
    epc.tmobile.com to the cellular data apn.

    If that doesn't work, try
    internet2.voicestream.com
    wap.voicestream.com
    internet3.voicestream.com
    for cellular data its only allowing me to turn on or off do i turn off the 3g?
    Last edited by notphonesavy; 2010-06-23 at 07:22 PM. Reason: Automerged Doublepost
    2010-06-23 07:22 PM
  5. rick1123581322's Avatar
    I had the same problem.

    it looks like you did the update.

    back up you phone and do a restore.

    do not apply the restore once it is loaded. set it up as a new phone.

    check for updates. more than likely there will be a carrier update. apply that.

    now restore your backup.

    for some reason the carrier updates are not being accepted from just the updates. maybe something left over from the previous os
    2010-06-23 07:25 PM
  6. notphonesavy's Avatar
    I had the same problem.

    it looks like you did the update.

    back up you phone and do a restore.

    do not apply the restore once it is loaded. set it up as a new phone.

    check for updates. more than likely there will be a carrier update. apply that.

    now restore your backup.

    for some reason the carrier updates are not being accepted from just the updates. maybe something left over from the previous os
    how do u back your phone up?

    I just used something called Tiny umbrella to save my shsh was that ok?
    Last edited by notphonesavy; 2010-06-23 at 07:48 PM. Reason: Automerged Doublepost
    2010-06-23 07:48 PM
  7. Simtech's Avatar
    3G's don't have SHSH files.
    2010-06-23 07:56 PM
  8. notphonesavy's Avatar
    3G's don't have SHSH files.
    the tiny umbrella program let me i dont know lol
    2010-06-23 08:02 PM
  9. adp's Avatar
    No need to restore.

    Just go to cydia and search for "T-mobile US Postpaid/Flexpaid" and download.

    Then go to settings - general - reset - reset network settings.
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-23 09:05 PM
  10. notphonesavy's Avatar
    No need to restore.

    Just go to cydia and search for "T-mobile US Postpaid/Flexpaid" and download.

    Then go to settings - general - reset - reset network settings.
    i restored back down from 4.0 and used what i saw on here and now im all good but thank you very very very much!

    also is there a program to get all of my sim contacts?
    Last edited by notphonesavy; 2010-06-23 at 09:13 PM. Reason: Automerged Doublepost
    2010-06-23 09:13 PM
  11. adp's Avatar
    Yea go to settings - mail, calendar & contacts - and in the bottom there should be a button that says "Import SIM contacts"
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-23 09:26 PM
  12. notphonesavy's Avatar
    Man u are a life saver I really appreciate it

    One more question!

    It won't let me connect to YouTube it's not important but just in case
    2010-06-23 09:50 PM
  13. adp's Avatar
    Hmm...this may be an issue with the new ultrasn0w on 4.0. They've had these issues with prior releases (specially ones right after a new Firmware comes out) and it happens. However, there may one fix for you. Not only *should* this fix youtube, but it will also enable Push Notifications for you. Follow this easy guide:

    How to Enable Push Notifications on Unlocked/Hacktivated iPhone with iOS 4 using Push Doctor | Apple | ithinkdifferent
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-23 09:53 PM
LINK TO POST COPIED TO CLIPBOARD