1. vietkool's Avatar
    Just got my 3Gs with version 3.0 from friend, can I upgrade it to 3.1.2 then jailbreak and unlock then upgrade to 4.0 then jb and unlock? Or just upgrade from 3.0 to 4.0 then jb/ unlock ?
    2010-06-27 02:12 AM
  2. kingkong's Avatar
    model MB? or MC?
    2010-06-27 02:24 AM
  3. vietkool's Avatar
    Model MC137LL
    Modem 04.26.08
    2010-06-27 02:45 AM
  4. adp's Avatar
    No, MC models have not yet been jailbroken for 4.0.

    Hadn't I answered this in the other thread you did this week?
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-27 04:50 AM
  5. Simtech's Avatar
    MC only applies to iPods... not iPhones.... (his phone has 3.0, has to be old bootrom.)
    Are you currently jailbroken?
    If not, jailbreak with purplera1n, then use a custom 4.0 firmware.
    Last edited by Simtech; 2010-06-27 at 06:09 AM.
    2010-06-27 04:52 AM
  6. vietkool's Avatar
    No the fone hasn't jailbroken yet. So I can upgrade to 3.1.2 first then jailbreak and then use custom 4.0 firmware ? and where do I get custom 4.0

    thanks so much for helping
    Last edited by vietkool; 2010-06-27 at 06:10 AM.
    2010-06-27 06:06 AM
  7. Simtech's Avatar
    No, if you have never been jailbroken, then you don't have your SHSH files, which means you can only restore to the latest firmware (4.0)
    Just follow the instructions I gave you above.
    2010-06-27 06:09 AM
  8. vietkool's Avatar
    do you have link how to jb by using purplera1n and link to download custom firmware 4.0 ? I found one link from iclarified (httpp://www.iclarified.com/entry/index.php?enid=4417 ) but dont know it is the rite one.
    2010-06-27 06:51 AM
  9. adp's Avatar
    MC only applies to iPods... not iPhones.... (his phone has 3.0, has to be old bootrom.)
    Are you currently jailbroken?
    If not, jailbreak with purplera1n, then use a custom 4.0 firmware.
    Neither is the iPhone 3GS with the new Bootrom, the MC models.
    http://modmyi.com/forums/iphone-news...4-windows.html
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-27 02:07 PM
  10. Simtech's Avatar
    @adp, the new bootrom is the issue, not the MC models. There are many many MC model iPhones that have the old bootrom.
    2010-06-27 05:57 PM
  11. babyblue_pimp's Avatar
    Yeah ih8sn0w dev's are never reliable

    My phone 3gs is an MC model, but its **923**


    + if he has 04.26.08, i don't even think they started making new boot rom's until post 3.1

    But why would you use purplera1n? I haven't heard that name is almost a year lol (only reason i say that it because you wont be able to find an official purplera1n download anymore)

    I'd recommend using redsn0w to jailbreak, then restoring to a custom 4.0 ipsw...
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!
    2010-06-27 06:11 PM
  12. vietkool's Avatar
    you guys make me confused. so wat should I do first? upgrade to 3.1.2 then jailbreak then use custom 4.0 to restore then jailbreak and unlock ?
    2010-06-27 08:04 PM
  13. adp's Avatar
    To clear out all confusion, download Fuzzyband from Cydia and run the app. This will tell you exactly what baseband/bootrom you currently have.
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-27 08:16 PM
  14. vietkool's Avatar
    bro, the fone is till on AT&T anh not jb or iunlocked yet. How do I get cydia to load to the phone first in order to d/l Fuzzyband app?
    Iam not really hurry for the version 4.0 if it is not truthly ready for 3Gs but I need to unlock the fone to use on Tmoblie . This is the only one I have since I traded my old 3G to the friend (of course give him som cash )
    Last edited by vietkool; 2010-06-27 at 08:30 PM.
    2010-06-27 08:27 PM
  15. adp's Avatar
    Is it on 3.1.2? You can use blackra1n to jailbreak and download from cydua
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-27 08:31 PM
  16. Simtech's Avatar
    He said in his original post that he is on 3.0. He is not jailbroken so he doesn't have SHSH files stored, so he cannot upgrade to any FW version other than 4.0. If on 3.0, purplera1n is the jailbreak for that firmware.
    Read.....
    2010-06-27 08:39 PM
  17. babyblue_pimp's Avatar
    Just use purplera1n and install ultrasn0w.
    2010-06-27 08:51 PM
  18. vietkool's Avatar
    no, the one I got now is on version 3.0, modem 04.26.08 . No jailbroken or unlock yet.
    @SimTech : I couldn't find purplera1n but I found Blackra1n ... will it work ?
    2010-06-27 08:58 PM
  19. babyblue_pimp's Avatar
    No, search for purplera1n in google, for search how to use redsn0w
    2010-06-27 09:02 PM
  20. vietkool's Avatar
    k, I used RedSn0w and got the version 3.0 Jailbroken now. with Cydia on it. Wat should I do next ? Should I use RedSn0w again to jb 3.1.2 ? or just use the custom 4.0 to restore?
    I did installed th Fuzzyband
    here info.
    Bootloader ver: 06.04 [G2M3S2]
    Baseband Ver : ICE2-04.26.08
    Iphone OS : 3.0
    Last edited by vietkool; 2010-06-27 at 11:30 PM.
    2010-06-27 09:31 PM
32 12
LINK TO POST COPIED TO CLIPBOARD