1. sumguy44's Avatar
    Hello, Ive been having this issue for a few days now. I have the iphone unlocked with tmobile operating on the new os 4.0. I have seen numerous issues with people complaining that there cellular data network tab is missing, and they cannot access the apn settings. Well Im having that issue but in my case the "cellular data" tab is there but its just an on/off toggle switch, therefore I cant access any apn settings, my mms is not working and my internet is not working.
    Help?
    Attached Thumbnails Cellular Data (On/Off Toggle)! Help-dcqzo1.png  
    2010-06-29 08:21 AM
  2. sumguy44's Avatar
    BUMP! Anyone Please??
    2010-06-29 08:24 PM
  3. adp's Avatar
    The reason why no one is answering is because everyone is so tired of the same question and people not noticing the 35 othre posts started with the same exact question in the same thread
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-29 08:55 PM
  4. sumguy44's Avatar
    Ok, instead of you being rude, I would have liked an answer to my specific question. There is only one thread that asks this question dealing with the cellular data toggle on or off. If you would have actually read my post you would understand that its not the same question as the one EVERYONE is asking. Take your comments elsewhere please, since you obviously aren't of any use.
    Last edited by sumguy44; 2010-06-29 at 09:11 PM.
    2010-06-29 09:02 PM
  5. adp's Avatar
    http://modmyi.com/forums/t-mobile/71...-fix-ios4.html

    http://modmyi.com/forums/t-mobile/71...ting-ios4.html

    http://modmyi.com/forums/t-mobile/71...k-tab-fix.html

    http://modmyi.com/forums/t-mobile/71...ny-advice.html

    http://modmyi.com/forums/t-mobile/71...-os-4-0-a.html

    http://modmyi.com/forums/t-mobile/71...-mms-help.html

    http://modmyi.com/forums/t-mobile/71...b-missing.html

    ALL related to the missing cellular data tab. All in the T-mobile forums.

    And btw the reason why you have the on/off toggle is because it's a new feature with iOS 4
    Last edited by adp; 2010-06-29 at 10:27 PM. Reason: Automerged Doublepost
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-29 10:27 PM
  6. sumguy44's Avatar
    Ok. You post it like I already haven't gone threw this thread to find out whats the issue. My cellular data network tab is there and I've tried almost everything to fix it with no luck which is why I posted a new thread. I've already restored my iphone one and re jail broke it. No luck. I tried installing APN editor but it gave me error messages, T-mobile told me to install a carrier package but I got another error message most likely because it wont work with the new update. So whats the solution bro? Im running out of luck here, and yes I had read through all of those threads but one.
    2010-06-30 12:12 AM
  7. adp's Avatar
    Well apparently there's a new redsn0w release which fixes this issue. I'll look for the link..

    EDIT:

    Here you go:
    Windows version b5-5 RapidShare: 1-CLICK Web hosting - Easy Filehosting
    Last edited by adp; 2010-06-30 at 02:10 AM. Reason: Automerged Doublepost
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-30 02:10 AM
  8. sumguy44's Avatar
    Thanks ill try this out!
    2010-06-30 09:30 AM
  9. DJM AutoWerkz's Avatar
    Lazy *** people n
    2010-06-30 09:32 AM
  10. sumguy44's Avatar
    ^Unnecessary. You don't know how many hours I have spent searching this issue and trying numerous fixes. Please exit.
    2010-06-30 09:36 AM
  11. Oliver350Z's Avatar
    No need to flame the guy...

    It took me some time to find the solution and if I recall right it was posted by adp in the middle of a thread... So after all, not everybody has the luck (patience?) to find the "solution post" in the middle of a thread that has 1,000 pages of, most of them, useless posts...

    Since this is a common issue with the 4.0 why not just make a thread with the solution and make it sticky?

    I mean it worked great for the MMS issue on 4.0...
    Housekeepin'?
    2010-06-30 03:32 PM
  12. adp's Avatar
    The new redsn0w is supposed to fix this issue..
    If I helped you out, please use the Thanks button ------------------------->
    2010-06-30 03:51 PM
  13. zcorpi's Avatar
    Ok - the new RedSn0W does fix the issue and the mms and the cellular data browsing wrks .
    But since I didnt have much data in iPhone I did
    1- Clean restore + setup the phone as a new iphone in itunes
    2- No backup restoration from old backup
    3- used redsn0w .5
    4- had at&t sim inside the iphone during the entire process
    5- Ran ultrasn0w restarted
    6- disabled 3g shut down
    7- put my other carrier sim
    8- turned off wifi and turned on cellular data and browsed
    it works . There may be shorter workarounds but i just wanted to be sure and did the entire thing and it works :-)

    Just FYI i read in many forums that opening Unlockit - APN Changer for your iPhone through iphone helps to overcome this issue but I didnt try that .

    All the very best!!!
    I'm not crazy, my reality is just different than yours.
    2010-06-30 05:22 PM
LINK TO POST COPIED TO CLIPBOARD