1. mrb1gg's Avatar
    Apologies if this has been posted before but the Safari browser will not work on the EDGE network on TMobile. I have a jailbroken 3G and I can make calls and send texts. My Youtube wasn't working but after reading the posts here, I was able to fix that with Push Doctor.

    The message I get is "Safari could not open the page because the server stopped responding".

    Please note that Safari works on Wifi but does not seem to work on the EDGE Network.

    Any advice will be greatly appreciated..
    2010-07-14 04:09 AM
  2. RaiV3R's Avatar
    What sort of internet plan do you have?

    Also, if you go to Settings -> General -> Network, do you see a "Cellular Data Network" tab? if you do, tap it.

    Inside you should see that the first section is for Cellular Data, what APN (if any) do you have in there?

    Common ones are internet2.voicestream.com & epc.tmobile.com try either one, and if one doesn't work try the other one. Make sure to reboot after you input one of those addresses into the APN box so it takes effect.
    iPhone 32GB 3GS - iOS 4.2.1 - BB: 5.11.07
    iPhone 16GB 3G - 3.1.3 - BB: 4.28.08
    2010-07-14 09:22 AM
  3. mrb1gg's Avatar
    Thanks for your reply. I have a tmobile unlimited data with enterprise plan. When I goto the settings/network/general tab i see "cellular Data" but all I can do its turn it on and off. I cannot open it up and make any changes to it.

    I also see a tab for data roaming which is off. On the bottom, there are tabs for vpn and wi-fi...
    2010-07-14 03:31 PM
  4. Ryfly's Avatar
    Thanks for your reply. I have a tmobile unlimited data with enterprise plan. When I goto the settings/network/general tab i see "cellular Data" but all I can do its turn it on and off. I cannot open it up and make any changes to it.

    I also see a tab for data roaming which is off. On the bottom, there are tabs for vpn and wi-fi...
    Ok, good info you posted, this can be fixed easily from what i see so far.

    Before we go forward, What version iOS are you running and how did you jailbreak?


    If you have iOS 4 jailbroken and unlocked via ultrasnow and you used a beta version of red snow to jailbreak it, this was a redsnow bug early which has been fixed.

    Good news, this can be fixed via red snow without having to restore.

    Download the latest version of redsnow beta 5

    Dev-Team Blog


    Re-run RedSnow BUT BE SURE to uncheck the Install Cydia.

    After that being successful, you should be able to edit your Celluar data settings

    I recommend for your data plan to use epc.tmobile.com
    2010-07-14 03:39 PM
  5. RaiV3R's Avatar
    Yeah, you'll want to re-jailbreak again because the first beta to jailbreak iOS 4 had a bug.

    b5 will work just fine, you won't need to uncheck Cydia at all though. After jailbreaking, you'd just have to go to Cydia, re-download ultrasn0w, let the iPhone reboot, and you should have Cellular Data Network appear under the Cellular Data On/Off toggle.
    iPhone 32GB 3GS - iOS 4.2.1 - BB: 5.11.07
    iPhone 16GB 3G - 3.1.3 - BB: 4.28.08
    2010-07-15 12:03 AM
LINK TO POST COPIED TO CLIPBOARD