1. spifflink's Avatar
    iPhone Model: 2G
    Carrier Bundle Used: T-Mobile US - internet2
    Voice Plan: Individual 600
    Data Plan: 9.99 web2go
    SMS: unlimited
    Time with T-Mobile: 4 years
    Last Plan Change: 3 days ago
    Problem: So I got an old 2g phone from one of my friends and I am trying to unlock it and get the edge working for another one of my friends on t-mobile. Her husband has the 9.99 web2go plan that I put on there for his iphone about a year ago and it works fine with the T-Mobile US carrier (internet2) package from cydia. We thought it would work the same for her phone as well but it doesn't. I've installed the same carrier settings thing (can't change apn settings, they are in the settings screen even with the APN settings hack installed). Now nothing comes up when we go to safari, its just times out and says the server cannot be found. We asked t-mobile if she had the same plan as her husband and he said no they've updated it just recently so hers is slightly different. Anyone know of anything I can install to get that working?
    2010-07-20 09:24 PM
  2. adp's Avatar
    Did you reset your network settings?
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-20 09:54 PM
  3. spifflink's Avatar
    Yeah I did. Originally it was giving me the web page in safari that told me I needed to upgrade my plan, which I thought was odd, so I reinstalled the US Carrier internet2 thing and reset the network settings and now it just has the timeout issues. I suppose that's an improvement?
    2010-07-20 10:38 PM
  4. adp's Avatar
    Can you manually edit APN settings?
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-20 10:52 PM
  5. spifflink's Avatar
    No, and I tried to install the APN settings hack to get that to appear but it doesn't seem to work.
    2010-07-20 11:06 PM
  6. adp's Avatar
    What firmware is the phone in?
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-20 11:34 PM
  7. spifflink's Avatar
    3.1.3. Should i downgrade it?
    2010-07-20 11:36 PM
  8. adp's Avatar
    Try restoring from backup and re-jailbreaking the phone

    Jailbreak and Unlock iPhone 2G With 3.1.3 Firmware Using Redsn0w | TechHail
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-21 12:10 AM
  9. spifflink's Avatar
    Should I install the same carrier file afterward? Or should I try a different one?
    2010-07-21 12:15 AM
  10. adp's Avatar
    If you're sure that person has web2go, then go to cydia and search for "legacy"
    2010-07-21 12:33 AM
  11. spifflink's Avatar
    I tried putting the legacy package on there before I tried the US Carrier internet2 package and I couldn't find it, is there a specific repository it is on?
    2010-07-21 12:37 AM
  12. adp's Avatar
    Make sure you have the modmyi repo in cydia
    2010-07-21 01:01 AM
  13. dvela85's Avatar
    i unlocked and j/b 3.1.3 with redsnow all i had to put in the apn was internet2.voicestream.com and it works with the web2go plan
    2010-07-21 05:13 AM
  14. spifflink's Avatar
    yep redsnow worked, just restored back to 3.1.2 and got it working. Thanks guys!
    2010-07-21 06:55 AM
LINK TO POST COPIED TO CLIPBOARD