User Tag List

  1. mao67's Avatar
    Hi,

    I have a "factory unlocked" 3GS iphone running on tmobile. I accidently updated to 4.0.1 and the place where I used to enter my APN settings and MMS settings in gone!!

    All your options now are "on or off" in cellular data network, it no longer brings you to the place where you can manually enter the settings.

    Does anyone know how to fix this, please help because my email, safara, pic messages, facebook, etc. does not work because it's not connecting to edge at all without these settings.

    I'm at a complete loss now, and also, I was thinking of buying a factory unlocked iphone 4 but now I'm scared to spend the money and get the same problems.

    Please help me if you know what I can do.

    Thanks,

    Marie
    2010-07-21 04:26 AM
  2. i.Annie's Avatar
    I think jailbreaking your phone might fix some or all the problems. It wouldnt hurt to try considering your phone is factory unlocked. Use Spirit or Pwnagetool if youve got a mac.

    Of course you should try restoring first.
    Last edited by i.Annie; 2010-07-21 at 04:46 AM. Reason: Automerged Doublepost
    2010-07-21 04:46 AM
  3. mao67's Avatar
    Hi,
    I don't think there is a jailbreak out yet for 4.0.1, I used Spirit for 3.1.3.

    Anyone know if it works on 4.0.1 yet?

    I'm going crazy, can't get email, or anything unless connected through Wifi.

    Thanks.
    2010-07-21 01:15 PM
  4. adp's Avatar
    I assume you have windows, follow this guide

    Jailbreak iOS 4.0.1 iPhone 3G with Redsn0w 0.9.5 - Complete How To Guide | Gadgets DNA

    I know if says 3G but if you have the old bootrom it should work as well...if you have the new bootrom you're out of luck and will have to wait until the iPhone 4 is jailbroken
    Last edited by adp; 2010-07-21 at 03:58 PM. Reason: Automerged Doublepost
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-21 03:58 PM
  5. mao67's Avatar
    Thanks everyone, but yes, I do have the new bootrom, so I just have to wait.
    2010-07-21 11:04 PM
  6. thor740's Avatar
    I had the same problem after jailbreaking to 4.0 with redsnow. I just did it again with pwnagetool and they came back. Not sure if thats an option for you
    2010-07-22 10:21 AM
  7. mrredwings's Avatar
    If jailbreak add lei 4.0 mms fix

    Try leimobile.com
    Last edited by mrredwings; 2010-07-22 at 05:03 PM. Reason: Automerged Doublepost
    2010-07-22 05:03 PM
  8. mao67's Avatar
    Just an update. I did a restore with a 4.0.1 firmware from here, did shift restore, and now I can get to the place where you manual enter the Cellular Data Network settings, so thankfully my internet, email, facebook, etc., is all working, but still no MMS. Guess I have to wait for the jailbreak for newer bootrom 3GS for that, but at least I got everything to work.

    Wanted to let everyone know just in case you have any similiar problems. Also thinking now its ok to get the factory unlocked iphon 4 because I can do the same thing with that until jailbreak is available for that one.

    Thanks for all your posts.

    Marie
    2010-07-23 01:57 AM
LINK TO POST COPIED TO CLIPBOARD