1. GeoIphone123's Avatar
    I have tried using wap.voicestream.com, internet2.voicetream.com, epc.tmobile.com and none of them work. Everytime I go to Safari, it keeps telling me "Cannot Open Page" "Safari cannot open the page because it is not connected to the internet" I have the $10 Web2Go Plan, I also have 2 more Iphones and the internet on them work. How can I get it fixed?...I also think that Tmobile might know I have an Iphone, so is it possible that they might have blocked me from using it?
    2010-07-26 08:53 PM
  2. adp's Avatar
    Go to settings, general, reset, reset network settings. then enter internet2.voicestream.com as the APN...

    Also make sure Data Roaming is ON and 3G is Off
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-26 09:07 PM
  3. GeoIphone123's Avatar
    I have tried that already.
    I have version 3.0.1 currently, will it work if I update it to 3.1.2 or 3.1.3?
    2010-07-26 09:30 PM
  4. adp's Avatar
    What phone do you have
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-26 09:50 PM
  5. GeoIphone123's Avatar
    All 3 Iphones that I have are the 2G.
    2010-07-26 09:54 PM
  6. adp's Avatar
    So if you switch the SIM from one phone to another you can get data on 2 but not one? Which firmware are the ones that do work?
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-26 10:19 PM
  7. GeoIphone123's Avatar
    Well I havent tried switching the sim with the other phones, should I try it to see if maybe the phone is the problem?
    I have one phone that is 3.1.2, another that is 3.1.3, and mine(the one that doesnt work) is 3.0.1
    2010-07-26 10:27 PM
  8. adp's Avatar
    Yes, I'd try switching the SIM card between the phones. There may be an issue with the data plan.
    If I helped you out, please use the Thanks button ------------------------->
    2010-07-26 10:29 PM
  9. GeoIphone123's Avatar
    Ok, well Im currently updating the iphone so I can also have it up-to date, and if that doens't work I will try what you have suggested. Thank you.

    I was able to fix it, thank you for you help.
    Last edited by GeoIphone123; 2010-07-27 at 05:26 AM. Reason: Automerged Doublepost
    2010-07-27 05:26 AM
  10. kwik13a's Avatar
    I have the same problem your having, how did you fix ? what was the solution? can you help.
    Thanks
    2010-08-02 11:39 AM
  11. kwik13a's Avatar
    anyone solved this problem that could help..
    ?
    thanks
    2010-08-04 09:45 AM
  12. alex1089's Avatar
    I have the same problem on an iPhone 4. By the way my apn settings menu is gone. It was working last night
    Last edited by alex1089; 2010-08-05 at 03:18 AM.
    2010-08-05 03:14 AM
LINK TO POST COPIED TO CLIPBOARD