1. pavelkolp's Avatar
    Hey Guys I was just as excited as all of you were when it came out but after cutting up my tmobile sim and using iphone 4 with it I have encountered a few problems # 1 facetime doesent work! but there will be fix or alternative to that, #2 mms doesent work I have found a temporary fix for this, I restoed my iphone 4 from a backup on where my iphone 3gs was set up with t-zones hack and mms fix, and now Cellular setting tab appereared and I am able to change mms and apn setting good luck all

    Cheers
    2010-08-04 11:04 AM
  2. shademagic's Avatar
    yea i am in the same position.. what were your settings?? and did you get them to work for mms at all..
    2010-08-04 03:04 PM
  3. dooey21's Avatar
    yea i am in the same position.. what were your settings?? and did you get them to work for mms at all..
    I have a SIM card cutter that supposely cuts it perfectly. The phone, SMS, and internet is working fine. I am in the same boat as for MMS and FaceTime is not working. I am not able to set settings.... I do not have a section that says "Cellular Data Settings"
    2010-08-04 04:06 PM
  4. Habusho's Avatar
    I think what you're supposed to do is this. Go to unlockit.co.nz and install "custom apn" pick us-t-mobile it will install the t-mobile apn settings for you.

    I actually did that and still get "no cellular data". Could someone else try and confirm...
    2010-08-04 04:28 PM
  5. hotairgypsy's Avatar
    also noticed i can send a regular text but no notification sound is heard
    2010-08-04 06:01 PM
  6. SpookyET's Avatar
    Read the stickies, dudes, especially the one that mentions T-Mobile USA carrier bundles. Geez.
    2010-08-04 07:26 PM
  7. Habusho's Avatar
    I actually read that thread. I thought that didn't apply to the iPhone 4.
    2010-08-04 07:41 PM
  8. alpineflip's Avatar
    I actually read that thread. I thought that didn't apply to the iPhone 4.
    You still need to patch commcenter so you can upload custom carrier bundles with a fake signature. If you go threw that thread SpookET is taking about there is more info
    2010-08-04 08:15 PM
  9. Habusho's Avatar
    Do I need to find a T-mobile carrier.plist file?
    2010-08-04 08:25 PM
  10. Alegre323's Avatar
    im having the same issues. internet works fine, but the MMS doesnt work and I really need it lol
    2010-08-04 08:29 PM
  11. alpineflip's Avatar
    Do I need to find a T-mobile carrier.plist file?
    They are already made on the first page of that thread, it says iOS4 carrier bundles I think
    2010-08-04 08:29 PM
  12. Chefanim's Avatar
    im having the same issues. internet works fine, but the MMS doesnt work and I really need it lol
    Same here, did the restore from backup method, I can edit APN settings and have them exactly the same as my 3GS, but I still can't send MMS. Odd
    So long, and thanks for all the fish
    2010-08-04 08:40 PM
  13. alpineflip's Avatar
    My MMS are coming in just really delayed between 10 and 30minutes some times instant but I patched my commcenter and am using a custom carrier bundle. if I leave facetime on I noticed my data is continually on cause its trying to activate and when I turn it off I lose data kinda odd but it should get worked out eventually
    2010-08-04 08:45 PM
  14. pavelkolp's Avatar
    Here is the trick guys grab your 3gs set it up the way you like it and back it up and plkease dont forget to set up celluar setting such as APN and MMS setting then proceed to back up after back up complete restore the iphone 4 from the backup of your 3gs it will work.
    2010-08-04 11:35 PM
  15. Chefanim's Avatar
    Does anyone have any issues with the battery on iPhone 4 after restoring from backup?
    So long, and thanks for all the fish
    2010-08-05 04:22 PM
  16. SpookyET's Avatar
    Does anyone have any issues with the battery on iPhone 4 after restoring from backup?
    Everyone has issues with restoring from backup since the iOS2 days. Never restore from backup. Always start fresh and set it as a new phone. It happens on all iPhones. I don't know why.
    2010-08-05 06:29 PM
  17. pavelkolp's Avatar
    mine seems to do fine :S Ive had issues before restoring from backup but not this time yay I love my iphone 4
    2010-08-06 03:02 AM
  18. Bi Vo's Avatar
    im using iphone 4 with T-mobile and in setting/general/ i can't see where to put the apn it just the cellular data with button turn on and off. Please help guys. Thanks
    2010-08-09 09:02 AM
  19. Chefanim's Avatar
    im using iphone 4 with T-mobile and in setting/general/ i can't see where to put the apn it just the cellular data with button turn on and off. Please help guys. Thanks
    Pop the SIM card out and put it back in, That gave me the option to edit the APN
    So long, and thanks for all the fish
    2010-08-09 04:48 PM
  20. Blondi.Josh's Avatar
    Ok I really REALLY need HELP, I almost will pay anything! Ok so I've spend well over 35 hours tryin to get MMS working with installing, re installing and restoring and re restoring, even taking with many Reps, I can't seem to get my MMS working WhatSOEVER!!!


    Problem: half the time it works. The only time I get it to work for a little while, is when I do a "reset all settings" in settings then get the apn to show up, edit it correctly and then I can send and everything fine, but when I restarting my phone the same issue comes up hundreds of times, I don't want to give up on my iPhone 4, but this is really testing my patience I must say, and I would love a comm center patch or something to help get the issue fixxed every other cydia patch I've tried doesn't do any good.

    It also worked one time when I did the following:

    Stuck the aim into a working 3Gs iPhone, sent a pic perfectly fine, then I put the aim
    Back in my iPhone 4, then I get the MMS's from 2 days worth, and it all worked! Restarting and it's doing the same evil thing! "message send error"!!!!!!!!!

    It's making me furious! I've restored from every backup possible and from clean! Nothing Nothing! I need help! ..

    Is it something to do with the commcenter???
    2010-08-10 05:21 AM
21 12
LINK TO POST COPIED TO CLIPBOARD