1. grant1x's Avatar
    Hello, everything is fine with my iPhone 4 running on jailbroken and unlocked (for tmobile) 4.0.1 FW.

    all except when sometimes, it freezes and i am forced to do a hard reboot (holding sleep/wake button and home button until shut down).

    i have SBsettings installed as well as the remove background process toggle switch which is very helpful.

    occasionally, when i delete a lot of apps from multi-tasking or delete process's with SBsettings, my iphone freezes. the only thing to make it work again is hard rebooting.

    also, when i need to restart springboard it also usually happens.


    and another thing, sometimes after rebooting, my service displays 1 bar, but it doesn't say tmobile. and i can't make calls/texts so i reboot again and it goes back to saying Tmobile and i have normal service.

    has anyone else been having these problems? they aren't terrible, just annoying.
    2010-09-17 11:47 PM
  2. xsboredom's Avatar
    I have the same EXACT problems. Except, i have to reinstall ultrasn0w before i get service back.
    2010-09-18 09:10 AM
  3. rashad1's Avatar
    I have an iPhone 4, 4.0.1, unlocked on T-Mobile...don't have that problem though
    2010-09-23 04:45 AM
  4. sa_seahawker's Avatar
    I have 3GS, 4.0 unlocked on T-Mobile. Mine locks up after calls for about 30 seconds and now recently, I have been having to respring often.

    Beginning to get frustrated. kinda hard to pimp out jailbreaking to buddies if I have issues.
    2010-10-21 10:26 PM
  5. dotFIVE's Avatar
    Try updating to 4.1. If you rely on an unlock, use Pwnage tool (Mac) or sn0wbreeze (Windows - soon to be released).

    I'm on 4.1 on my 3GS and it runs perfectly.
    2010-10-21 11:00 PM
LINK TO POST COPIED TO CLIPBOARD