1. Galrash's Avatar
    Yesterday I upgraded my iPhone 3G to 4.2 with the ipad firmware so that I could unlock it for t-mobile (I previously noobed it up and upgraded to iOS4 with the 5.14 baseband so it was useless otherwise).

    I followed the instructions to the tee and applied the MMS settings I found here at MMI.

    I'm having a couple problems however:

    1) Sometimes, seemingly randomly but definitely often, there is a huge delay on my receiving text messages. sometimes I receive texts 10-15 minutes after they are sent, and sometimes its hours.

    2) Incoming calls doesn't seem to be working that great, they go straight to voicemail 90% of the time and I don't even realize I missed a call until I get a voicemail notification

    3) omg the battery drains uberfast. I did read about this already and apparently there is a fix coming?

    Any thoughts on the first 2 problems and how to fix them would be much appreciated. Here are my settings:

    Apn: internet2.voicestream.com


    Apn: epc.tmobile.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy:
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf


    The only other settings I could see possibly interfering with text/cals are that I have emails set to Push on exchange servers with gmail
    2010-11-30 03:03 PM
  2. babyblue_pimp's Avatar
    Redo everything from scratch, but do not hacktivate the device. Use an ATT sim to bypass the activation. Then reinstall ultrasn0w, and test before entering the mms settings.

    for more information read the comments posted on the dev team blog, many people have had this issue, its due to 4.1 and 4.2.1 requiring push certificates, or else it will keep searching for them aka kill the battery.
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!
    2010-11-30 10:02 PM
  3. Galrash's Avatar
    Ok thank you I will do that, first I have 2 questions:

    1) can go back down to iOS 3.1.3 or whatever it is instead of doing iOS4.2 again? the 3G seems a bit sluggish with 4.2

    2) will redoing the jailbreak/unlock without the hacktivation like you suggested remove the problem I've been having with incoming calls being sent to voicemail automatically? And uber delayed text messages? Out of the 12 or so phone calls I've received today (that left voicemails) only one of them actually got through to the phone and allowed me to answer it
    2010-11-30 11:31 PM
  4. babyblue_pimp's Avatar
    1. Yeah you can downgrade to 3.1.3, it will give you a 1015 error though because the baseband is higher than the version on the firmware, its not an issue though, you just have to kick the phone out of recovery. (research online how to downgrade back to 3.x)

    2. T-mobile can't send/receive data and make voice calls/text messages at the same time, due to only being on edge. 4.1 and 4.2.1 require a legit push certification (obtained by using a legit sim card to activate) Since you hacktivated, the phone is desperately trying to register the certification, which it cannot due to being hackivated. In turn, the phone puts priority to the system trying to contact apple about the certifications before phone calls and such. So yes, starting from scratch and using a legit sim card should fix all your issues. But then again if your going to downgrade to 3.1.3, you can hactivate with no problems, as versions before 4.1 do not require the same push certification check.
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!
    2010-11-30 11:48 PM
  5. Galrash's Avatar
    I have done some googling, and it appears I am stuck in iOS 4.2 correct? since I installed the iPad baseband?
    2010-12-01 04:30 AM
  6. babyblue_pimp's Avatar
    no, your baseband is stuck (which is fine), you can restore to whichever firmware you desire. (4.0+ require shsh blobs)
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!
    2010-12-03 07:12 PM
  7. Galrash's Avatar
    sorry I probably should have replied sooner, but I got it restored to 3.1.3 no problem and unlocked and now its working perfectly with the new baseband and no battery drain!

    Thanks for all the input! the only thing I ran into (which was odd) was that I downloaded the appropriate version of pwnage for 3.1.3 (according to iClarified) and it wouldn't accept the IPSW file. I had to use Spirit and it worked fine though
    2010-12-03 09:52 PM
  8. babyblue_pimp's Avatar
    It didn't accept because your baseband is higher than what's on the 3.1.3. But it's fine, using spirit to get out of recovery was perfect. Glad to see your up and running
    2010-12-06 05:07 PM