User Tag List

  1. Rinnycoop121's Avatar
    MuscleNerd himself (one of the creators of ultrasn0w) has stated, iPhone 4 4.1+ ultrasn0w is only officially supported by custom firmwares built with pwnage tools. Thats the tool they use and test with. If you rely on an unlock, i'd recommend unlocking the device the way they intended on.
    Can someone proved us windows users with some custom firmware created with pwnage tools for 4.1 please

    Or are pwnage tools users having the same issues?

    Let me know
    .................................................. .................................................. ...Don't forget the hit the Thanks Button
    2010-12-14 09:34 AM
  2. lahana's Avatar
    So I think I may have found a fix. It's pretty strange how the iPhone 4 baseband works. When you get the No Service error, leave it on No Service with 3G turned ON, for about 10-15 minutes (well, this is when I left it to go take a shower). Then, slide to unlock and Power off the phone through SBSettings, not the regular "slide to power off". After it's been turned off, reboot, and you will have your T-Mobile back.

    Try it out and see if it works. This is what I did and it worked perfectly.
    ( that only worked 35 minutes for me..than "no service" again,


    do you still have Tmobile working?

    can you please tell me what steps you used to unlock?
    Last edited by lahana; 2010-12-14 at 04:33 PM. Reason: Automerged Doublepost
    2010-12-14 04:33 PM
  3. Wesss's Avatar
    I jailbroke 4.0.2 with limerain, went straight into cydia, downloaded ultrasn0w and put my trimmed down sim inside it.

    I always have it working, until I reboot.

    I BRING GREAT NEWS TO ALL READING THIS POST. Turn ON PUSH NOTIFICATIONS AND YOUR PHONE IS FIXED!
    Last edited by Wesss; 2010-12-15 at 06:19 AM. Reason: Automerged Doublepost
    2010-12-15 06:19 AM
  4. ndkone's Avatar
    I jailbroke 4.0.2 with limerain, went straight into cydia, downloaded ultrasn0w and put my trimmed down sim inside it.

    I always have it working, until I reboot.

    I BRING GREAT NEWS TO ALL READING THIS POST. Turn ON PUSH NOTIFICATIONS AND YOUR PHONE IS FIXED!
    i tried... not working....

    I rebooted, reset network.... and reinstall ultrasn0w.... notification on or off, i will still get invalid SIM after a reboot.

    Any more info you can provide?
    2010-12-15 07:24 PM
  5. Simon's Avatar
    You should try installing a older version of ultrasnow to see if that works (1.1-1)
    2010-12-15 07:28 PM
  6. ndkone's Avatar
    You should try installing a older version of ultrasnow to see if that works (1.1-1)
    OK, I have an iphone 4, IOS 4.1, BB 1.59.... jailbreak with pwnagetool with custom IOS4.1 firmware. Using ultrasn0w 1.1-1 with notification "ON". 12 hours and no invalid SIM, it is a record "good" so far. I will report back if it works or not in a few days.... let's hope this is the solution.

    Thanks for the trick. I'm going to post this on devteam message and see if anyone can look at why ultrasn0w 1.2 is having issue.
    Last edited by ndkone; 2010-12-16 at 06:40 AM.
    2010-12-16 06:34 AM
  7. CyberMew's Avatar
    Where can you get 1.1-1 when the latest is 1.2?
    2010-12-16 10:45 AM
  8. Simon's Avatar
    2010-12-16 11:04 AM
  9. CyberMew's Avatar
    I did, and all are old news talking about it being released and getting it via Cydia. But there is no way at all. Damn it. I tried everything except using 1.1-1 and restoring the phone
    2010-12-16 02:16 PM
  10. Simon's Avatar
    Stick this In google "ultrasn0w deb 1.1-1 download"
    2010-12-16 03:41 PM
  11. Simon's Avatar
    I would link you to it but the place to download it from is a site not well liked here.
    2010-12-16 03:42 PM
  12. CyberMew's Avatar
    Thanks, that helped me a lot to get me started.

    Hope to post my results soon..!
    2010-12-16 03:49 PM
  13. Simon's Avatar
    2010-12-16 03:51 PM
  14. ndkone's Avatar
    OK, I have an iphone 4, IOS 4.1, BB 1.59.... jailbreak with pwnagetool with custom IOS4.1 firmware. Using ultrasn0w 1.1-1 with notification "ON". 12 hours and no invalid SIM, it is a record "good" so far. I will report back if it works or not in a few days.... let's hope this is the solution.

    Thanks for the trick. I'm going to post this on devteam message and see if anyone can look at why ultrasn0w 1.2 is having issue.
    Still no good... I can restart and still OK, but I just walk in and out of an elavator, and obviously the signal is got for the time there. When I walk out.... INVALID SIM... So I have to reinstall ultrasn0w, reset network, take the SIM in and out to fix this. Even at once or twice a day, I think I will wear out my SIM card an the contacts on the SIM CARD slot....

    I did survived multiple reboot last night. I know I did. But it does not work now this moring since I have the elavator incident.

    Man, this is BAD. Anyone have better luck?
    Last edited by ndkone; 2010-12-16 at 04:30 PM.
    2010-12-16 04:01 PM
  15. lahana's Avatar
    Still no good... I can restart and still OK, but I just walk in and out of an elavator, and obviously the signal is got for the time there. When I walk out.... INVALID SIM... So I have to reinstall ultrasn0w, reset network, take the SIM in and out to fix this. Even at once or twice a day, I think I will wear out my SIM card an the contacts on the SIM CARD slot....

    Man, this is BAD. Anyone have better luck?
    I am still on the same boat, this totally sucks, why it is just us? I have seen a lot of people with iphone4 using tmobile...

    I think my phone is gonna end up on ebay soon, it has been two months and no permanent solution yet
    2010-12-16 04:26 PM
  16. ndkone's Avatar
    I am still on the same boat, this totally sucks, why it is just us? I have seen a lot of people with iphone4 using tmobile...

    I think my phone is gonna end up on ebay soon, it has been two months and no permanent solution yet
    I'm right there with you, LOL....

    I have a trip coming up to Canada and then Hong Kong. I think I'm just going to pick up a factory unlocked iphone4... maybe the year end bonus covers this.

    Maybe I bring a box full of iphone4 factory unlocked back if anyone interested.
    2010-12-16 04:34 PM
  17. ylerT's Avatar
    Same here. I'm going to put mine up for sale and start looking towards a factory unlocked 4.

    I just picked up an HD7 for next to nothing so I'm giving Windows phone 7 a test run for a few weeks. So far it's much better than I expected.
    2010-12-16 05:42 PM
  18. ndkone's Avatar
    Same here. I'm going to put mine up for sale and start looking towards a factory unlocked 4.

    I just picked up an HD7 for next to nothing so I'm giving Windows phone 7 a test run for a few weeks. So far it's much better than I expected.
    Really.... I was considering Android, myTouch 4G from Tmobile ... but the issue is that it has a bad speakerphone and I need to signup for new data plan and a new voice plan.

    I'm currently on a grandfathered low cost, high minutes, almost free blackberry unlimited data plan that works with my IP3GS and barely working with the IP4. Joining a new plan will cost me at least $600 over 2 years contract and I may as well buy an unlocked one. For unlocked phone, I may as well get the Iphone4 instead of Andriod/W7P since they are unlikely to keep the value - new model is poping up every month!

    Anyhow, do you think the UNLOCKED IP4 will work? or I still have the same issue of no service?
    2010-12-16 06:05 PM
  19. ylerT's Avatar
    I thought about the MyTouch 4g as well but I played with a friends and just didn't enjoy it that much. Don't get me wrong, even though I'm a super Apple fan haha, Android is not that bad. But the MyTouch had so much T-Mobile crap on it that annoyed me. It also seemed much slower than other Android devices I've used before.

    As far as you're plan, I see you're dilemma as well. I didn't use my T-Mobile upgrade and I refuse to. I got the HD7 through craigslist for a great deal so I couldn't pass it up. I'm also on a grandfathered unlimited plan I've had for 4 or 5 years now. I'm not sure what will happen if you just buy a MyTouch 4g through private party...it may cause problems with your data plan but I couldn't answer that one for sure.

    To answer your question about the factory unlocked 4, I do think it'll help. You don't have to worry about what firmware or baseband your on. I can't see how it won't make it much better. However, I don't have one and don't know anyone who does. Maybe someone here has one and can chime in with their experience.
    2010-12-16 06:30 PM
  20. CyberMew's Avatar
    iPhone 4, iOS4.0.2, baseband 1.59. Installed ultrasn0w 1.2, sim error/failed/blank. Or when detected, Facetime/Phone No/Voicemail/MMS/Tethering all not working as it should as it says not activated! Also kept prompting me to update my carrier settings once in a while, which it didn't since Settings->General->About still shows carrier settings at AT&T 7.0 and still locked.

    Now it works!

    http://modmyi.com/forums/unlocking-a...ml#post5624158

    Following the above post as guideline, I:

    1. Find and download ultrasn0w 1.1-1 deb file:-
    MD5 6E50E9E832F42DACCA2B411F74549530 or
    CA30898A8494E73A4816F4BF8E8A8E8F is fine as it seems like only file compression is different. Anyway I used the first one which worked for me.

    2. Remove ultrasn0w 1.2 from Cydia and respring from there.

    3. Install OpenSSH via Cydia if you haven't.

    4. Access/connect to the iPhone's filesystem through WinSCP via WiFi: WinSCP :: How do I connect to my iPhone or iPod Touch?
    After you login there will be a popup about some RSA key, just click Yes to proceed.
    "/private/var/root" will be the default directory once you login to your phone's folders/files via WinSCP. I used beta 3.1 works fine.

    5. Drag and drop the ultrasn0w deb file to the directory shown above (you are already there if you used WinSCP).

    6. Open Terminal in WinSCP (Ctrl + T).
    Click ok if it shows:
    ---------------------------
    Confirm
    ---------------------------
    Current SFTP-3 session does not support command you request. Separate shell session may be opened to process the command. Do you want to open separate shell session?

    Note: The server must provide Unix-like shell and the shell must use same path syntax as current SFTP-3 session.
    ---------------------------
    OK Cancel Help
    ---------------------------

    7. Black DOS-like window appears. Enter the following command: dpkg -i yourultrasn0wfilenamehere.deb
    Click on Execute button
    It should say something like: (I can't remember exactly)
    .....
    .....
    .....
    Setting up ultrasn0w

    8. Close the Terminal window, delete the yourultrasn0wfilenamehere.deb and then close WinSCP.

    Within a short while the iPhone will detect your sim card! I don't even need to restart my phone like the post says. Carrier settings etc are all normal and correspond accordingly now. You can double verify by going and viewing "/private/var/wireless/Library/Logs/ultrasn0w-dylib.log" and see it is something like http://modmyi.com/forums/unlocking-a...ml#post5624427. Kudos to Ember.

    Hope I have helped others too!
    Last edited by CyberMew; 2010-12-16 at 08:49 PM.
    2010-12-16 08:41 PM
215 ... 23456 ...
LINK TO POST COPIED TO CLIPBOARD