1. orangecure's Avatar
    Have an iPhone 4, running on 4.3.3. For some reason my Cellular Data Network tab isn't there. I have tried restoring the iPhone in iTunes, still nothing. I tried downloading the APN Editing from BigBoss in Cydia, but it gives me errors when I install.

    I am not an SSH expert but I managed to find the carrier.plist and it looks like this

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>AllowEDGEEditing</key>
    <true/>
    <key>BookmarkURLs</key>
    <array>
    <dict>

    The "AllowEDGEEditing" command is already in there

    Would anyone know how to fix this? Kinda desperate, going out of the country in a few days and need this fixed asap.
    2011-05-19 01:39 PM
  2. bondkt's Avatar
    install tetherme(worth a few bucks). free tethering+will install what you need to view what you are looking for
    2011-05-19 06:33 PM
  3. yikee's Avatar
    You need to open and close the iphone 4 sim tray without shutting the phone.
    2011-05-23 06:34 PM
  4. fedii's Avatar
    same issu here i use iphone 4 4.3.3 ios and use du sim and i cant use my internet amd mms
    cant show CELLULAR DATA NETWORK what can i do ??
    2011-05-25 01:43 PM
  5. pottsj42's Avatar
    I used this and mine is working fine so far.

    How To Fix Cellular Data Network Problem On IOS 4.3
    2011-05-25 09:20 PM
  6. Hollow Ichigo's Avatar
    I started having the same problem yesterday, the CELLULAR DATA NETWORK tab was gone plus the FaceTime toggle. I was going to do a iTunes restore today after work to see if that fixes this problem.
    The tab disappeared after i turned the 3G toggle on by accident
    I will give a try the site pottsj42 suggested, will post what happens later.

    iP4 FM 4.3.3 BB 4.10.01, Gevey Unlock.
    2011-06-06 08:57 PM
  7. pottsj42's Avatar
    I fixed the problem in 2 ways:
    1. I was having other issues as well so i did a complete restore and that worked.
    2. on my wife's phone, i installed from cydia, tmobile us mms fix for iso4 and that worked.
    I would suggest trying #2 first before doing a restore. repo: cydia.pushfix.info

    both:
    3gs, fw 4.3.3 bb 6.15.00 unlocked for tmobile.
    2011-06-06 10:49 PM
LINK TO POST COPIED TO CLIPBOARD