1. 40ozBulldog's Avatar
    After many failed attempts to get just a straight simple answer from someone I decided to just figure it out on my own. Seeing how the sticky threads above are a thousand pages long full of tons of different "solutions" and kind of confusing, I just wanted to share what worked for me. I did this 5 minutes ago, and I'm able to send and receive.

    I SSH into my phone. Clicked the following in order. /var/mobile/library/preferences then open the file called: com.apple.mms_override.plist

    I then replaced all text with the following (save what's already in there if you want):

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>MMS</key>
    <dict>
    <key>GroupModeEnabled</key>
    <false/>
    <key>MMSC</key>
    <string>http://mms.msg.eng.t-mobile.com/mms/wapenc</string>
    <key>MaxMessageSize</key>
    <integer>1048576</integer>
    <key>MaxRecipients</key>
    <integer>10</integer>
    <key>MaxVideoBitrate</key>
    <integer>131072</integer>
    <key>Proxy</key>
    <string>216.155.165.50:8080</string>
    <key>UAProf</key>
    <string>http://www.apple.com/mms/uaprof.rdf</string>
    <key>UserAgent</key>
    <string>SonyEricssonW800i/R1L</string>
    </dict>
    </dict>
    </plist>

    Saved and ended the SSH session.

    Make sure your settings under General/Network/Cellular Data Network are as follows

    Under MMS
    APN: wap.voicestream.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50.8080
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf

    The rest leave blank

    Then reboot the device and you're good to go.
    2011-06-13 02:34 PM
  2. poopz's Avatar
    Does this also take care of everything in the Spooky thread? (tethering, etc)

    Does this take care of everything in the Spooky thread (tethering, etc)?
    2011-06-16 02:33 AM
  3. 40ozBulldog's Avatar
    This is an MMS fix only. I use MyWi 4.0 for tethering.
    2011-06-16 02:58 AM
LINK TO POST COPIED TO CLIPBOARD