1. somethingblue's Avatar
    Short Story:
    • Bought legit Gevey Ultra.
    • Worked Great until today when it lost SIM connection.
    • By using Airplane switch and restarting, got SIM working again but APN settings and editable fields disappeared.
    • No MMS or EDGE capability now, and the connection is super fritzy.


    Long Story:
    Yesterday I bought an iPhone 4 and scored a legit Gevey SIM Ultra. Everything was working great aside from Facetime until today.

    Today, my phone lost signal, said there was no sim. I restarted...it said no sim again. Then it said invalid sim. I restarted again, played with the airplane mode, and eventually with enough messing around I got my T-mobile signal again. Unfortunately, it erased my MMS and Internet APN settings. I thought it wouldn't be a big deal and that I would just add them in, but then the Cellular Network section where you edit the APN settings has disappeared from the phone completely.

    On top of that, the connection is on the fritz and often goes out, saying "No SIM Card" or "No Service." Playing with the airplane mode and/or restarting it usually sorts it out for a little bit...but this problem happened four times over the course of the day.

    Has anybody else experienced issues like these? I'm 95% sure this card is legit, but I am worried that it may be defective. The T-Mobile SIM is brand new as of yesterday, and I went through three of them since January so I don't think it would be a T-mobile SIM problem.

    Lastly, does anybody have any advice?
    I'm toying with restoring the phone completely and starting from the ground up but I'd rather not waste the time if there are options to consider.
    2011-07-07 10:00 AM
  2. GnatGoSplat's Avatar
    If the Cellular Data Network option (with the APN settings) has disappeared, usually you can get it back by removing the SIM card. It will then pop up a dialog "No SIM installed" with an OK button. Do not touch OK, instead, just pop the SIM back in. That often restores that menu option.

    I can't explain why your Gevey is acting up, maybe try cleaning the contacts with a Q-tip and alcohol to remove any oils?
    You could also try putting the SIM in the phone without the Gevey. Obviously, it won't work, but you should at least be able to see if you still get the "No SIM" issues. If it never says No SIM, that should at least eliminate the SIM or phone as the problem.
    You could try a Restore, but it does sound like your Gevey may be defective.
    2011-07-07 05:54 PM
  3. somethingblue's Avatar
    Popping the SIM out didn't restore the Cellular Data Network option.

    Oddly enough, EDGE still works but MMS is non-existent.

    Think I might be headed for a restore.
    2011-07-07 08:31 PM
  4. Alexpalex15's Avatar
    Hi somethingblue,

    I'm new to this forum, but after searching for some advice on this issue I found your post (from only a few days ago)

    I'm currently experiencing the same problem. I've been using Gevey unlock with iPhone 4 (baseband 4.10.01) for months and it hadn't been a problem. (Although I wasn't able to receive mms, I wasn't bothered)

    Today, I literally drove in my car for 3 hours trying to find a place with the best reception. And then finally once it received a signal and my t-mobile logo appeared, I could text and call, BUT I COULD NOT receive data. Upon trying to fix the data settings, I realized there fields were completely gone!

    Then, I would enable data roaming and lose this signal completely and the Gevey accept screen would appear and I'd have to start from scratch. I could scream!!!!

    Any help or advice from anyone would be greatly appreciated.

    Thanks! -Alex
    2011-07-10 09:27 PM
  5. somethingblue's Avatar
    I haven't found an answer to this issue. My plan is to order another legit Gevey Ultra tomorrow. I'm going to restore and start from step 1 with a new Gevey SIM. There is no way it's the phone, so it has to be the jailbreak, the Gevey Ultra SIM, or my T-mobile SIM...or a combination of all 3.

    If I were you, I'd back up and restore, jailbreak, and try again. My guess is your Gevey SIM is either defective or fake. I know mine is legit but I think it's a bit flakey. My T-mobile SIM is brand new (3rd one also), so it would be super crazy if my tmo sim is bad.
    2011-07-11 06:58 AM
  6. Alexpalex15's Avatar
    Thanks for the reply. My Gevey is real. (I know because I unknowingly bought a fake off eBay the first time around.)

    The Gevey Is legit. And now it's unlocked. Working fine for texts & calling.

    HOWEVER, the fields for entering the APN information are gone. I enable data roaming & nothing appears.

    My questions are I guess:

    1. How can this be?
    &
    2. How can I enter the correct settings for the data?

    Thanks again!
    2011-07-11 07:42 PM
  7. somethingblue's Avatar
    HOWEVER, the fields for entering the APN information are gone. I enable data roaming & nothing appears.

    My questions are I guess:

    1. How can this be?
    &
    2. How can I enter the correct settings for the data?

    Thanks again!
    I don't know. Follow the instructions I gave you, start over. It's the only method I am aware of.
    2011-07-11 07:45 PM
  8. ihappy's Avatar
    Have you tried installing an "APN editing" app through Cydia. Usually this has to be added and the phone rebooted so that the Cellular Data Network tab is placed back on the phone and you can add the apns manually to get your mms and Edge data back. Look through Cydia and youll find it. It should be on there by default already.
    Last edited by ihappy; 2011-07-12 at 04:38 AM.
    2011-07-12 04:34 AM
  9. somethingblue's Avatar
    I have tried. It didn't work.
    2011-07-12 04:35 AM
  10. ihappy's Avatar
    This what I had originally done to get my MMS and Edge working before I had switched over to ATT. Hopefully this helps you as well.

    http://modmyi.com/forums/t-mobile/72...r-bundles.html

    I know under Cydia you have to install the Tmobile Carrier Logo tweak for the Cellular Data Network to work.
    2011-07-12 04:44 AM
  11. Idungknoe's Avatar
    http://modmyi.com/showthread.php?t=759442

    Try that thread use his app from Cydia follow directions and it will work fine
    2011-07-18 07:47 AM
  12. somethingblue's Avatar
    Fix MMS, Internet & Activate FaceTime iPhone 4 on US Carriers. TMobile, SimpleMobile.

    Try that thread use his app from Cydia follow directions and it will work fine

    I just learned that if you have the i4MMS program installed, you can go to the help section and click the fix COMM button. It will restart your phone and repopulate the missing fields.
    2011-07-19 06:12 AM
LINK TO POST COPIED TO CLIPBOARD