1. dustinlthacker's Avatar
    i unlocked my iphone 3g and was trying to install the tmobile carrier bundle. when it reaches the substrate it fails and i was wondering if i needed to update it somehow or what. help plase.
    2011-11-30 10:39 PM
  2. i.Annie's Avatar
    Could be an incompatibility issue. Depends on what fw you're on and what the bundle was made to support.
    2011-12-01 12:48 AM
  3. dustinlthacker's Avatar
    im on 4.2.1 the last update for the 3g. i can get it to install on ipod 2nd gen on the same firmware.
    2011-12-01 02:00 AM
  4. i.Annie's Avatar
    Do you remember what the error in Cydia states when you're trying to install it? Does it lock up and the progress bar doesn't move? Or?
    2011-12-01 02:09 AM
  5. dustinlthacker's Avatar
    it gets halfway through the installation then goes red text and says mobile substrate failed. can i use the tmobile sim card without installing the bundle?

    oh and it doesnt freeze its reloads and the button for return to cydia comes up

    ok i have tried it again and this is exactly what it says

    x subprocess pre-installation script returned error exit status 1

    x Sub-process /usr/bin/dpkg returned an error code (1)

    then it says return to cydia in the button. sorry i thought it was the substrate.
    Last edited by dustinlthacker; 2011-12-01 at 04:57 AM.
    2011-12-01 04:47 AM
  6. i.Annie's Avatar
    Make sure in Cydia under changes tab that everything is updated. Might have to resolve in some mobileterminal usage...that I'm not expert at.

    Try uninstalling any new repos or packages that you may have installed recently that could be causing conflict.

    If you don't want to resolve in a restore to test to see if the issue gets solved (sometimes this helps though) then I hope someone who knows how to use mobileterminal to remove bad packages and whatnot can chime in.

    I'll do some research when I get the chance if you don't get this resolved.
    2011-12-01 06:04 AM
  7. dustinlthacker's Avatar
    i did a complete restore and re jailbroke my iphone. installed cydia and updated completely all packages. the first thing i did was unlock the phone then tried to install tmobil carrier and still same thing
    2011-12-02 01:38 AM
  8. i.Annie's Avatar
    When you restored...did you restore it from a backup?
    2011-12-02 02:10 AM
  9. dustinlthacker's Avatar
    no i updated my modem so its 6.15.00 so i could unlock it for tmobile and i was told the only way to restore it was from a custom firmware
    2011-12-03 12:51 AM
  10. i.Annie's Avatar
    Right but that has nothing to do with restoring from a backup. Restoring in general is not the same thing as restoring from backup. When iTunes asked you to set up your phone, did you "set it up a new" or "restore from a backup?"
    2011-12-03 01:05 AM
  11. dustinlthacker's Avatar
    oh my fault. i set it up like a new iphone
    2011-12-03 01:10 AM
  12. Nerdnation's Avatar
    Well first off if you have tmobile on a 3G iPhone all you need is Internet and mms.. Sooooo!!!! Beta.leimobile.com/repo<<< to get mms... Your APN are epic.t-mobile.com<<< mms and Internet..
    2011-12-05 06:46 AM
  13. dustinlthacker's Avatar
    ok that helps a lot. thanks, so i dont need to keep trying to install the carrier bundle right?
    2011-12-06 12:56 AM
LINK TO POST COPIED TO CLIPBOARD