1. kawanku's Avatar
    I posted this in different thread (I apologize for thread hijacking) and I figure, it is better by itself. I would welcome any advice....

    - iPhone 4
    - iOS 5.0.1
    - Baseband 04.10.01
    - Carrier T-Mobile
    - Gevey Ultra from ApplenBerry

    Main Q: Gevey works but differently... is that normal?

    I just want to get clarification on my iPhone 4 - ver 5.0.1 baseband 04.10.01 with Gevey Ultra from ApplenBerry (6 wks old Gevey).

    I just upgraded today - somebody did it with Redsnow - Windows version (it costs $25 which I am OK. I did it myself last night using PwnageTool in Mac. But I can't never passed the Activation process - which led me to believe, that either Pwnage Tool is not perfect, or I didn't do it correctly....)

    After jailbreaking today, It is working OK, but several things changed in the way Gevey works.

    Before: (ver 4.3.5 baseband 04.10.01)
    - my network setting for 3G is ON, Cellular Data is ON and Data Roaming is ON
    - if I reboot, go to Settings - Phone - Sim Application and Instructions then click "ACCEPT"
    - I will see 1 Bar and then dial 112 etc....

    After: (ver 5.0.1 baseband 04.10.01)
    - if my 3G is ON, I can't use my Gevey and can't activate it.
    - my new network setting: 3G is off, Cellular Data is On and Data Roaming is On
    - after reboot, go to Settings - Phone - Sim Application and Instructions then click "ACCEPT"
    - even if I wait, I can't see 1 bar to show up as I did before. But if I proceed with the step of dialing 112 etc, at the end it still unlocks for me.

    - is it normal that procedures changed due to upgrade to 5.0.1
    - if I ever go to the area where 3G might be available - does it mean that I can't ever turn 3G on?
    - can I ever go back to the way it was when I reboot?

    I appreciate any advice....
    2011-12-29 10:44 PM
  2. hcgaloi's Avatar
    I replied to the same question in your other thread. So I just do a copy-n-paste here:


    Yes, the process for unlocking with Gevey has changed on iOS 5. Starting with iOS 5.0b2, Apple tried to close gevey loophole, thus, it's a little bit tricky to unlock. First, the automatic method using furiousmod doesn't work anymore. Second, we have to do the manual method for unlocking. But due to many flavors of gevey SIMs there isn't one method that would work for all. Good thing that you have one from applenberry which I also have. Below is the step-by-step procedure that I'm using:

    Note: if you are not in the area that T-mobile has recently implemented HSPA+ (3G) then you can keep 3G off to save battery. Make sure cellular data and data roaming are always ON (Settings->General->Network). Otherwise, you will experience frequent drop signals. On my iPhone 4, sometimes after a reboot data roaming is default to off, so I have to manually go in and turn it on. However, on my wife's is always stayed on. The only difference is that mine is built 7 months later.

    Just to be sure your phone is in a clean state before you start, do a reset network settings by going to Settings->General->Reset tap on Reset Network Settings. Note: you don't have to do this step every time.

    1. Do a Reboot; Press Power button then use red slider to power off then press Power button to turn on
    2. After rebooting, if Gevey msg pops up, click on Accept;
    Otherwise, go to Setting->Phone->SIM Application select the language that you like (English) or
    Instructions in a few seconds Gevey msg will popup, click on Accept
    3. Wait for No Service to appear then wait another 4 seconds
    4. Dial 112; end call after 2 seconds; wait until it says call ended
    Note: If you got a call failed, you didn't wait at least 4 seconds after No Service appear.
    You need to repeat from step 1 all over again. (You can also pop the SIM in/out but the
    method doesn't work all the time, so I'm not going into it here)
    5. Quickly go to Settings and turn on Airplane Mode
    Note: If No SIM Installed msg pops up before you could turn on Airplane mode, the process
    has failed and you need to repeat from step 1 (this would be more of a problem for people
    with imitation geveys because some would give 12 seconds window to complete the steps)
    6. Wait and eventually No SIM Installed msg will popup (1-2mins)
    7. Press Ok
    8. Turn off Airplane Mode and it will say SIM failure
    9. Press ok
    10. Wait about 4mins your carrier service will come in

    Good luck
    2011-12-29 10:56 PM
  3. kawanku's Avatar
    hcgaloi: THANK YOU so much!!!!

    I read through your posting and I actually already did what you suggested to do.
    Step 3. Wait until No Service. I was baffled by this for a bit. It used to be that I have to wait for 1 small bar (when I was in ver 4.3.5). It took me a while to wait for 1 bar and I never got it. So I went ahead with No Service, and Voila, it worked.

    My issue: I can NOT turn ON my 3G anymore. If that button in ON, T-Mobile bar will be gone and phone can't be used and it will say No Service. This worries me if TMobile is ever on 3G (such as the one in Northern CA and Nevada). Does it mean that I need to be stuck at Edge forever with Gevey (which hopefully not, when we come to that point).

    Could you try your setting - Turning ON your 3G and see if that still works?

    I was worried with upgrading 5.0.1 - but at least I know that my phone is still working.
    I still have to do restoring from my backup tonight.

    Do you know anything for the latest way (with 5.0.1) to activate Face Time, MMS, Push Notification, iMessage etc? I would like to take full advantage of 5.0.1 if I could, but I know this might need some tweaks.
    There are some instructions but I am afraid they are not up to date.

    If that is too long, could I reach you off line by email?


    Benny (a.k.a kawanku)
    2011-12-29 11:45 PM
  4. hcgaloi's Avatar
    The reason for step 3 (Wait for No Service) was because back in iOS 5b2 Apple tried to close the gevey loophole, thus, 1 bar signal doesn't show up anymore.

    When I heard that T-Mobile started to implement HSPA+ in some parts of California, I did turn on 3G to test it. I didn't have any problem with the gevey. Anyway, this was how I did it. Turned on 3G, kept cellular data and roaming to on; Rebooted and performed the gevey unlocking steps. Note that whenever you try to turn 3G or roaming on/off, gevey would go through the process of searching for signal. So, when need to make modification, I always follow with gevey unlocking steps....

    MMS is conflicting with Gevey (at least with applenberry ones). After the gevey unlocking process, I would go in and making changes to cellular network (apn, etc) to activate MMS feature. However, when the iPhone needs rebooting, normal gevey unlocking (applenberry) doesn't work because "No SIM Installed" msg will not popup. To fix this problem, I need to do Reset All Settings a COUPLE of times (most of the time doing it once may not work) with rebooting in between before attempting gevey unlocking.

    For Facetime, push notifications, etc., I activated my iPhones with an old AT&T SIM (sync with iTunes at least one time with the ATT SIM). Then, I don't need to do anything else. If you don't have an AT&T SIM to activate, you need to do the SAM method which is a little bit cumbersome. However, there are many tutorials out there to help.

    Good luck

    NOTE: Reset All Setting may require you to re-activate the iphone which I don't have a problem because I have an old ATT SIM to do it with. If you have to activate with the SAM method, you may not want to mess with MMS.

    It's very important that you don't do the Erase All Content and Settings when the iPhone is jailbroken.... Otherwise, you MUST do a complete restore and jailbreaking process again... VERY PAINFUL ... 8-((
    Last edited by hcgaloi; 2011-12-30 at 01:54 AM.
    2011-12-30 01:06 AM
  5. kawanku's Avatar
    I tried to reboot and do unlock with 3G ON - didn't work. The problem is Step 4 - the call will not end. When it ends, 'No SIMS installed' alrady pops up.
    I guess that it is my luck the card doesn't work with 3G in 5.0.1.

    For MMS - it did work for me in 4.3.5. I plan to restore my backup file in iTunes tonight (which will restore my MMS setting). Are you suggesting that I don't do that?

    I jailbreaked/unlocked using PwnageTool myself last night, but I couldn't activate. Then I used my ATT iPad SIM and I could activate, then I restored my backup files from iTunes. However, when I put my Gevey, it asked for activation again. After a while I gave up. Do you think that I should actually sync it first (instead of restore backup file) or ATT iPad can't really activate?

    I paid somebody to re-jailbreak using Redsnow and it bypassed the activation (never even asked for it).
    Since I am not going to pay again, what the safest way to get my restore back?

    If MMS doesn't work, can I just remove the entries and reboot, to redo unlock? Why do I have to do re-activate? I am more brave when I had my 3G, but with IPhone 4...I have to learn a lot more..
    Used to be simpler in the past...
    2011-12-30 01:52 AM
  6. hcgaloi's Avatar
    Sorry, I don't remember the exact steps that I did when I tested 3G. I just remember that I had to try a few things for it to work. Unfortunately, gevey unlocking under iOS 5 is not as straight forward as 4.x.x. Have you tried to not wait for call to end in Step 4 when 3G is on?

    Regarding MMS, I'm suggesting that after gevey unlocking you enter the settings manually. Then, keep the iPhone constantly on similar to tethered jailbreak. If for whatever the reason that you need to reboot (out of battery, new apps requires a reboot, etc.). Then follow the steps below to get your iPhone working again.

    1. Do Reset All Settings; go to Settings->General->Reset->Reset All Settings
    Note: Be extremely careful NOT to do Erase All Content and Settings.

    2. Activate iPhone with AT&T SIM; sync with iTunes; if AT&T SIM is not available, re-jailbreak with
    uncheck cydia use SAM method to activate the iPhone

    3. [OPTIONAL] Sometimes doing steps 1-2 once gevey unlock may fail. If so, repeat steps 1-2 twice,

    4. Apply gevey unlocking procedure

    5. Manually add MMS settings

    I know the process is cumbersome but that is the only way I got it to work. Hopefully, someone else can come up with a better method

    About ATT iPad SIM, sorry, I don't have any experience activating an iPhone with it. But the key is you need to activate with iTunes. So I don't know if you did that or not.

    When you paid someone else to do the jailbreaking with Redsn0w, that person must have checked the hactivate option. Even it's hactivated, you need to install SAM for push notification to work. Not sure if that person did this extra steps for you or not.

    The easiest way to activate and restore is to use an old ATT SIM or Cingular SIM. If you ask around, someone may have one laying around. Or, you can buy one on Ebay; get a cheapest Go phone for $10, etc.

    MMS works on iOS 5.x.x. I got the settings directly from T-mobile support website. Go to there and search +iphone +mms You will see an "unsupported" settings document dated around summer (I think). If MMS doesn't work, you need to do step 1-2 above.

    When you do Reset All Settings, it also clears activation info. That's why you have to re-activate.

    Yes, the game has gotten harder and harder as Apple tries to close all the loopholes. Fortunately, we can buy factory unlocked now.... 8-))
    2011-12-30 03:04 AM
  7. tanahycommon's Avatar
    hi hcgaloi: thanks a lot for your post: question please<< after turnning the airplane mode on in step 5,,, the No Sim installed Msg never shown up,, is this message supposed to been shown while airplane mode on,, or i should turn airplane mode back to off in order to see this message, thank you
    2012-01-07 07:33 AM
  8. rmsmillertime's Avatar
    See the posts for a FuriousMod tweak. Makes the Gevey Ultra unlock process work automatically at IOS 5.0.1

    I just did it to my Iphone 4 last night and it work flawlessly
    2012-01-07 02:30 PM
  9. get109en's Avatar
    >I tried to reboot and do unlock with 3G ON - didn't work. The problem is Step 4 - the call will not end.
    >When it ends, 'No SIMS installed' alrady pops up.
    If so, please just try to clikc HOME botton quickly after you dialed 112.
    Then go to step 5, when you turn on Airplane Mode, the call will be ended up.
    5. Quickly go to Settings and turn on Airplane Mode
    After the call is ended up, 'No SIMS installed' will pop up.
    The following steps are same.

    Good luck!
    2012-01-21 12:22 PM
  10. zenj's Avatar

    Thanks for the process that you have explained , it worked perfectly and now I have been able to help my friend use his iPhone 4 .

    I'm very very happy to see this post , it worked as per your instructions.
    2012-02-07 10:12 PM
  11. hcgaloi's Avatar

    If you have a gevey ultra, you don't need to do this manual process anymore. Squuiid and applenberry have released furiousmod fixes for the automatic unlocking process. If your iPhone is jailbroken, you can add either resource below in Cydia and load furiousmod. I have tested with both and they work the same.

    You can find tutorials here: Furiousmod Ios 5.0.1
    2012-02-08 03:07 AM
  12. brian772xls's Avatar
    hi hcgaloi: thanks a lot for your post: question please<< after turnning the airplane mode on in step 5,,, the No Sim installed Msg never shown up,, is this message supposed to been shown while airplane mode on,, or i should turn airplane mode back to off in order to see this message, thank you
    I am having the same problem, no message comes up after I turn on Airplane Mode.
    2012-04-13 10:02 PM