1. caretr's Avatar
    ok this is weird...i can get gevey sim to work perfect with stock os 5.0.1 baseband 4.10

    but if i jailbreak edge does not work? i tried all those apn settings and nothing at all worked. anybody else have this problem
    2012-01-15 01:36 PM
  2. daytonaviolet's Avatar
    did you try this?

    Settings for T-Mobile Internet and picture messaging:

    From the main menu, tap Settings.
    Tap General.
    Tap Network.
    Verify the following settings:
    Data Roaming: On
    Wi-Fi: Off
    3G Enable: Off
    Note: The Apple® iPhone® is missing the WCDMA 1700/2100 band, and cannot function on the T-Mobile 3G network.
    Note: Changing the 3G Enable function while the device is on an active call may cause the call to disconnect.
    Tap Cellular Data Network.
    Configure as follows:
    APN: epc.tmobile.com
    Note: For some iPhone unlocks you may need to use wap.voicestream.com.
    Username: <Leave Blank>
    Password: <Leave Blank>
    Enter the following information under the MMS section:
    APN: epc.tmobile.com
    Username: <Leave Blank>
    Password: <Leave Blank>
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy:
    MMS Max Message Size: 1048576
    MMS UA Prof URL: http://www.apple.com/mms/uaprof.rdf
    Press the Home button to return to the Main Menu.
    Press the Homebutton to save the APN and exit to the main screen.
    Turn the device off and back on.
    Test the connection by opening the Safari web browser.

    Verify MMS is enabled:

    Tap Settings.
    Tap Messages.
    Tap MMS.
    Set MMS Messaging to On.

    Relate Error: 'The media content was not included due to a picture resolution or message size restriction'

    To resolve this error, perform a Google™ search with this phrase "MMS fix for iPhone 4".
    Note: The fix for iOS 4 will be the same for iOS 5.
    2012-01-16 04:04 AM
  3. caretr's Avatar
    yep tried didnt work
    2012-01-16 05:23 AM