1. wyvon54's Avatar
    I have just upgraded my iphone 3Gs to 5.0.1 but can't get past the "Activate Phone" screen. I have an AT&T generic sim card in my phone put iTunes says "There is no SIM card in the Phone you are attempting to activate. Please disconnect and insert a SIM card into the Phone."

    Any one know what I can do, short of borrowing someone else's SIM card to activate it?

    TIA
    Yvonne

    ETA I have just borrowed a fellow employee's AT&T SIM card with the same result. This is VERY frustrating!! Any help would be appreciated!
    Last edited by wyvon54; 2012-01-24 at 07:01 PM. Reason: further developments
    2012-01-24 06:34 AM
  2. Boweezie's Avatar
    You can use redsn0w to activate it without having to get an official sim card.
    2012-01-26 03:09 AM
  3. Rustomrobot's Avatar
    You also could do the emergency call-hang up method, go into cydia and download hacktivate it.
    2012-01-27 09:27 PM
  4. cjuni's Avatar
    Im havin the same problem how do you get the redsn0w to work, after I restore it?
    iPhone 5
    iPhone 4
    iPad2 64gb wi-fi
    iPad1 64gb/3G/wi-fi
    2012-01-30 01:48 AM
  5. i.Annie's Avatar
    It should activate fine with an AT&T SIM unless the device isn't an AT&T phone. Try a restore again and try activating again. What exactly is it showing you (like what screen is it on)?
    2012-01-30 02:29 AM
  6. cjuni's Avatar
    i dont have an at&t sim card it has an t-moblie sim in it, but after i restore it i cant do anything?
    iPhone 5
    iPhone 4
    iPad2 64gb wi-fi
    iPad1 64gb/3G/wi-fi
    2012-01-30 02:32 AM
  7. i.Annie's Avatar
    Sorry I was talking to the OP.

    You need to jailbreak yours (hacktivate) to get past it. It's better to use an AT&T SIM if available though. If not jus hacktivate by jailbreaking.
    2012-01-30 02:39 AM
  8. wyvon54's Avatar
    Hello i.Annie, thanks for helping me with this. Sorry for not getting back sooner. I've been ill all weekend. I have a generic AT&T SIM that I purchased specifically for jailbreaking/unlocking. I have run the upgrade and restore several times with the AT&T SIM card in my phone. It runs through the Activate phone procedure asking for language, then country, then enabling location services, choosing a network, until it gets to the "Activating your iPhone" screen. "It may take up to three minutes to activate your iPhone" comes up and then tells me that it could not activate.

    OMG, thank you for making me do this AGAIN. I tried several times last week to Hacktivate it and got nothing but frustration. It is now in the process of restoring from my back up. THANK YOU!! All I have to do now is unlock it.!!!

    i.Annie you are the best!!
    2012-01-30 06:09 PM
  9. i.Annie's Avatar
    Well I didn't do much, you just tried the same thing again lol. Glad you fixed it.
    2012-01-30 06:48 PM
  10. ThaNatrix's Avatar
    Know that if you are having this issue with a 3gs it could be because you previously had the iPad baseband installed and upgraded to a stock firmware bundle. This technically leaves the BB and 6.15.00 but screws it up trying to put a lower version on top of it. I got hung at several activation screens because of this. In this instance you simply need to reflash the iPad baseband with redsn0w and it'll work correctly. You don't have to hacktivate it....the ATT sims will work just fine.
    2012-01-31 06:38 AM
LINK TO POST COPIED TO CLIPBOARD