1. holdown's Avatar
    I've got an att iPhone 4s unlocked for tmobile with gevey sim ultra s running iOS 5.1.1/2.10.12.
    I can receive calls and text messages even MMS and browse the web. Only issue is i CAN NOT SEND SMS...
    Ive read multiple threads about this issue and different ways to try and over come it, nothing seems to work. Its driving me insane. Gevey hasnt given me a straight answer on it and ive tried multiple chips.

    So i figured i turn to the Genius's of the iphone community and see if anyone else has found complete solution to this. I know im not the only one experiencing this issue. I have gotten the SMS to work randomly, but if turn off the phone, put it in airplane mode. BOOM the SMS stops working. I havent been able to get the sms back on since and ive done mulitple restores, resets.... im going insane not being able to send sms
    2012-06-15 01:58 AM
  2. Inni's Avatar
    Here is a thread that seems to have results and it may help you.

    http://modmyi.com/forums/t-mobile/80...5-1-gevey.html
    Moderator notice: Please keep all sales pitches in the B-S-T forum.
    2012-06-15 10:26 AM
  3. mustangfrnk's Avatar
    Try "unlockit.co.nz"
    2012-06-17 08:43 AM
  4. phanguin's Avatar
    i found out that for me. sms wasn't working because of "Find My Iphone" in the Icloud setting was messing around with the iphone smsc. try turning that off, reset the iphone and see if it works.
    2012-06-17 03:17 PM
  5. holdown's Avatar
    I tried the temp fix through "unlockit.co.nz" and no such luck...
    I haven't tried the find my iphone part yet through icloud but i will and shall see if it works. when i get the iphone back ill try and post about it next week
    2012-06-19 11:08 PM
  6. Chocolatesmurf's Avatar
    My friends verizon iPhone 4s sends and receives SMS.. Could it be the Gevey?
    2012-06-20 03:50 AM
  7. iphonemedic's Avatar
    This will resolve it please update with your results.
    http://modmyi.com/forums/t-mobile/80...1-tmobile.html
    2012-06-21 04:16 PM
  8. CFised's Avatar
    Have you tried this with AT&T yet?
    2012-06-24 04:50 AM
LINK TO POST COPIED TO CLIPBOARD