User Tag List

  1. aruv's Avatar
    Hi MMI, I need a little help. I seem to have either a stubborn iPhone or a bad SIM card. Here's my situation:
    My friend's wife moved to the US from China and brought her iphone with her. He went to the Tmobile store and got himself a SIM card. He called me because he didn't understand why it wasn't working. I explained the phone had to be jailbroken and unlocked. I had him read off some numbers and it turns out it is an iPhone 4 IOS 4.3.1 and Baseband 3.10.01.

    When I brought the phone home I was surprised to see Cydia already installed. I was also surprised to see a Gevey SIM chip. However, even with the SIM installed the phone read "NO SIM". I tried reinstalling the SIM card, reseting network settings, and nothing worked. When I used my SIM (AT&T), the phone read it with the Gevey board. This leads me to conclude it could be a bad T-Mobile SIM card.

    However when I pulled out the Gevey board and put the T-Mobile SIM back in, it read the SIM. I went into Cydia and installed the SAMprefs. I followed the instructions posted on IClarified, but had no success getting the phone unlocked or activated. Am I missing something? Any help is appreciated.
    2012-06-16 10:02 PM
  2. mustangfrnk's Avatar
    If it read the tmo sim like you wrote, you shouldn't need SAM. I had the same problem until i found that the phone was factory unlocked. Try to put your AT&T sim without the gevey. It Should read it also.
    2012-06-17 08:35 AM
  3. aruv's Avatar
    If it's unlocked then why isn't the phone finding a network with the SIM installed? What do I have to do activate the SIM or pair the SIM and phone?
    2012-06-17 10:35 AM
  4. somethingblue's Avatar
    I went through 3 brand new sim cards from Tmo before my current one actually worked. I'd try another tmo sim.
    2012-06-26 09:11 AM