1. goastros's Avatar
    I'm so frustrated... everything seems to be perfect. i bought an iPhone yesterday, i've restored the 1.0.2 firmware and also successfully downgraded the modem to 03.14.08, installed and ran anySIM but it still says that i have an incorrect SIM. what have I done wrong or what do I still have to do? I'm not kidding i may give my first born to who ever can help me.
    Last edited by goastros; 2007-10-14 at 03:21 AM.
    2007-10-14 03:16 AM
  2. ctsd's Avatar
    I did come across this problem when I used anySIM. I have done a bit of hacking to my phone over the last two weeks and have had to restore the phone a couple of times. Recently when I did so when upgrading to 1.1.1 was unsuccessful. Had to downgrade the firmware and modem as you had and then used anySIM (first time i have used this unlocking app) and got the same error as you. I restored again and when came time to using the anySIM i used the unlock.app instead. You can find it anywhere on the web, should come in a zip with a unlock.app application and lockdownd file which needs to replace the lockdownd file on the iphone under /usr/libexec using cyberduck or fugu (whatever works for you). In a bit of a hurry so don't have time to place link for the unlock app, you can find it on MMI where I got if from an earlier unlocking tutorial. Three out of four restores I have done to my phone was using the unlock.app and was 100% without fault. Let me know how ya go mate!
    2007-10-14 07:51 AM
  3. goastros's Avatar
    hey man thanks, but i just don't know what's wrong. here's what i'm doing: restore to 1.0.2 with the .ipsw file, activating with independence, installing apptapp and the three apps in the installer on the phone, downgrading the modem to 03.14.08_G via ssh on the terminal, upload bbupdater, ICE03.14.08_G.eep, ICE03.14.08_G.fls, ieraser, secpack, and lockdownd (thanks for that one), and then i tried using Unlock like you said...the result...i restart it, put in my sim, and it still says i need to use a correct sim. is there anything else i can do or should i just give up? thanks in advance man.
    2007-10-14 09:20 AM
  4. ctsd's Avatar
    Did you use the app iunlock? http://www.appsafari.com/category/software/page/3/
    (Should see it on this page), sorry should of been more clear of the apps name. When you run iunlock you should not have a sim card in the phone. Here are a few notes i wrote up for when i was first learning to unlock the 1.0.2 firmware, this section would be relevant to you after you have the firmware at 1.0.2 and modem back to 3.14 etc. Are you doing the firmware downgrade with the original AAPT sim in the phone? I kept mine in till i got to the stage with using the iunlock app, from there i took out the card altogether.

    22. Open Cyberduck
    23. Open connection, select 'Secure File Transfer' from drop down menu. You will need to put in your phones server number located on your phone under Settings/wifi and press blue button to the right. Username is root, password is dottie
    24. The first connection may not work, getting an error. Do it again and should have no problem connecting
    25. Now, open up /usr/libexec, and drag the lockdownd file into it.
    26. It will ask you to overwrite the file. Click Continue, and it will upload the file.
    27. Now drag the Unlock file from your desktop onto the /Applications folder in CyberDuck.
    28. Now once copied onto phone, turn off phone and take out AAPT sim card. Turn phone back on WITHOUT SIM inserted and you should see a padlock icon application. (Cannot stress to make sure you have no sim in your phone whatsoever)
    29. Should say 'All files found. Ready to go. Press start', so go on, press start :-)
    30. Will say flashing firmware, allow 20 minutes. let it do its thing, it takes ages. The last line that lets you know it is done will say 'Completed enjoy'. The progress status on this work from the top not the bottom so the first line will be at the bottom saying 'All files found. Ready to go. Press Start'. Once you get the completed enjoy comment at the top of the page, it is all done.
    31. As you are still connected to cyber duck, delete the unlock folder application from the app folder to tidy up your home screen, you only need it that once
    32. Turn off phone, insert your own sim card and restart. Voula all done!

    Know this is a stupid question but you can confirm that under your phone settings it says it is running the correct version of firmware and modem? If so, you are following pretty much the same process i did as well..

    Keep me posted, will think of anything else that might help and post if do. Best of luck mate!
    Last edited by ctsd; 2007-10-14 at 01:37 PM.
    2007-10-14 01:04 PM
  5. goastros's Avatar
    wow, i really wish after those sweet instructions that i could come back with some sweet news. sadly however i've gotten nowhere. i literally followed the steps perfectly. like you said, it says that i'm using the correct downgraded version of firmware and modem but even the iunlock app doesn't work. i don't know if this helps but when i try using anySIM it says "the flash operation succeded but the unlock commands failed. You might want to check the baseband manually using minicom." what's that all about. anyway, thanks so much again in advance for any help. later.
    2007-10-15 02:42 AM
  6. ctsd's Avatar
    Mate two heads are better than one, we can work this out. Don't take failure as an option haha. check this thread out, this method may work better for you, requires alot of terminal use (assuming you are a mac user??)


    As i had a phone with 1.0.2 originally on it my success was pretty much first pop I tried. After a fair bit of internet research the above thread seem to work for alot of individuals in your situation who got the same error you did with anySIM. Keep me posted!!

    2007-10-15 11:00 AM